Subject: Re: [Gendispatch] Grounding the exclusionary language discussion

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 27 Aug 2020 18:12:09 +0000

(personal views - no hats - see inline)

On 8/27/20, 1:50 PM, "Keith Moore" <[email-masked]> wrote:
>    For instance, if we're talking about database replicas in single-master
    databases, I'd be fine with primary-replica as IMO it's actually more
    descriptive and the substitution can be made with little or no loss in
    clarity.   But I don't feel comfortable making that judgment about all
    potential uses of master-slave, because "master" and "slave" actually
    mean different things in different cases and it's not always clear that
    there's a good substitute.

[JL] I don’t agree that it's appropriate to perpetuate the use of 'master-slave' in technical standards and associated documents. I think it's trivially easy to change to primary-secondary or something similar & am confident that creative minds can find workable alternatives.

>    Also, these are not always simple terms, and there are potential ripple
    effects from such changes.

[JL] As well, there are likely ripple effects from not making changes - the status quo is not without cost or issue.

> What if we're talking about what are
    currently called "multi-master" databases that do conflict resolution
    without reference to a single primary copy?

[JL] My question was on the narrow change from 'master-slave' rather than broader use of 'master'. But I'm sure creative people will devise new terms or create new words or acronyms as the IETF does all the time. IETF creativity is boundless & I doubt a straightforward terminology issue like changing 'master-slave' to 'primary-secondary' is going to be insurmountable.

>   There are real costs to changing our language that should not be summarily
    dismissed.

[JL] Likewise, there are costs that arise from not changing language with the times.

---

From: Keith Moore <[email-masked]>
Date: Thu, 27 Aug 2020 14:28:48 -0400

> [JL] I don’t agree that it's appropriate to perpetuate the use of 'master-slave' in technical standards and associated documents. I think it's trivially easy to change to primary-secondary or somet…

I emphatically disagree about it being "trivially easy", and I don't 
think you've supported your argument at all.

>>     Also, these are not always simple terms, and there are potential ripple effects from such changes.
>>

Granted, though it might be harder to clearly see the ripple effects 
from maintaining the status quo.  But I'm not arguing to maintain the 
status quo, I'm just arguing that we need to be careful about what we 
change and how we do it.

>> What if we're talking about what are currently called "multi-master" databases that do conflict resolution without reference to a single primary copy?
>>

I doubt it's insurmountable either, but it does argue that changes 
should not be imposed by fiat from on high.   IETF creativity is 
boundless, but measures like this could stifle creativity if not done 
carefully.  Nothing stifles creativity as much as a loss of agency.

>>    There are real costs to changing our language that should not be summarily dismissed.
>>

What did I say that made you think I would disagree with this? This 
isn't (at least in my mind) an all-or-nothing decision.

Keith