Subject: Re: [Gendispatch] I-D Action: draft-nottingham-discussion-recharter-00.txt

From: Mark Nottingham <[email-masked]>
Date: Tue, 18 Aug 2020 15:49:43 +1000

Hi Brian,

As promised, discussion on the GENDISPATCH list. Thanks for the comments, they're good food for thought. Some responses below.

> On 18 Aug 2020, at 12:46 pm, Brian E Carpenter <[email-masked]> wrote:
> 
>> This document updates RFC3005, the charter of the IETF discussion
>>   list.
> 
> Then its intended status needs to be BCP.

Thanks, will update.

>>   Comparing its membership to a sample of other IETF mailing lists, we
>>   find that there are typically many members that are not taking part
>>   on the IETF discussion list:
> 
> People specialise. The intersection count given (628) is therefore not a
> useful statistic. The intersection with the union of all WG mailing lists
> would be useful. But for now, we simply do not know how many subscribers
> to at least one WG are missing from the ietf list, and we do not know how
> many subscribers to ietf are subscribed to no WG list. Those numbers could
> be discovered, of course.
> 
> If I had to guess, I'd use ietf-announce as a proxy for active participation,
> and that would suggest that at (most) 1799/3037 = 59% of active participants
> were on the ietf list at the end of July. That imperfect measurement is a
> good deal higher than the estimates in the draft.

That's not comparing apples and apples, though -- we need to get the portion of those subscribed to both lists to those subscribed to ietf-announce@. 

Jay said that 1,087 were subscribed to ietf@ but not ietf-announce@; given that ietf-announce@ has 3,038 and ietf@ has 1,751, so I think the right figure is 21.8%.

BTW, since I wrote the draft, the subscriber lists for a couple more mailing lists have become available:

- art: 26.8%
- last-call: 93.9%

Last-call is an interesting case, in that it shows we can spool up a new list and migrate specific kinds of discussion over successfully (in particular, without the acrimonious aspect of much ietf@ discussion).

> As I said earlier, there is evidence that only a small fraction (10%?) of
> the ietf list is interested enough in policy/process/admin to subscribe to
> lists on those topics. So using my imperfect measurement above, we find that
> at a generous estimate, 6% of IETF participants care about policy/process/admin.

I don't disagree. I included the data more to motivate the second and third statements in the recommendations, quoted below.

>>  2.  The IESG should not consider the IETF discussion list as an
>>       appropriate venue for notifying IETF participants of its actions
>>       or items under consideration. 
> 
> That's not new. The formal channel has been ietf-announce (which is not a
> discussion list) for 20+ years. True, the IESG sometimes puts the ietf list
> in Cc:, but since ietf-announce is not a discussion list, that's a natural
> thing to do. Thus:
> 
>>  More suitable channels include the
>>       IETF Announcements list and the GENDISPATCH Working Group,
>>       depending on the notification.
> 
> is standard operating procedure.

It is, but reminding people of this might be worthwhile; while the Secretariat, the IETF Chair and the IAB Chair are good at this, there are occasions where others (e.g., individual ADs, NomCom chairs, etc.) use the ietf@ list as an announcement channel.

>>   3.  The IESG should not consider the IETF discussion list as
>>       representative of the broader IETF community.
> 
> Then where can the IESG go for that? (Of course, when something reaches
> a formal Last Call, we know the answer, but that is the very last stage
> in discussing a topic).

It doesn't say that the IESG can't consider discussion on the IETF list -- just that it cannot consider that discussion as solely representative (because it can be skewed by a few loud voices). Again, I don't think this is too far from the current operating procedure; most ADs I talk to are very aware of the dynamics of the IETF list. 

I'm happy to try to write this down more clearly.

>>   4.  IETF participants who wish to make proposals about or discuss the
>>       IETF's direction, policy, meetings and procedures should do so in
>>       GENDISPATCH or other Working Group, if one more specific to that
>>       topic should exist.
> 
> Here's where it gets tricky. That is indeed what should happen as a
> proposal crystallizes. But is the draft really saying that the plenary
> discussion list shouldn't be used for the early rounds of discussion of
> an IETF-wide topic? That such topics should be discussed *from the start
> to finish* by the self-selected 6% or fewer of participants who are process
> wonks? That the rest of the IETF will only hear about it when a Last Call
> comes out?
> 
> That sounds like mushroom management to me.

People can and will discuss whatever they like on the ietf@ list -- as I said earlier on gendispatch@, this proposal does not include closing it.

However, when they want their proposals to move forward, they'll need to go elsewhere. Again, not a big change -- just writing down what we already do.

>>   5.  IETF participants who wish to make proposals about or discuss
>>       technical issues should do so in the most appropriate Working
>>       Group or Area mailing list to the topic
> 
> That's mainly what people do. Just occasionally somebody (usually not
> a regular participant) sends a technical query to the ietf list, and
> usually gets politely redirected. I think it's great when that happens.

Indeed.

>>   7.  There should be no explicit or implicit requirement for IETF
>>       leadership or any other person to be subscribed to the IETF
>>       discussion list.
> 
> I absolutely utterly violently disagree. I must confess that the day
> I stepped down from the IAB, I dropped the ietf list, but after a year
> or so I realised that just wasn't viable unless I only wanted to work
> in my own tiny corner of the protocol stack, and I rejoined. (There is
> a handy delete button in my MUA, which I have always used very freely on
> [email-masked] threads.)

Looking at the content of the list over the last year or so (subtracting messages also sent to ietf-announce@ and the now-moved last call discussions), I see very little technical content, and even less that really spans multiple areas.

So the ietf@ list doesn't promote cross-participation technically; that's a fiction. If someone wants to broadly participate across the IETF, they subscribe to multiple lists and participate in multiple areas, using the area WGs and/or dispatch groups to get a sense of what's going on elsewhere.

> It isn't acceptable to me that IAB or IESG members would *not* keep an
> eye on the list.

Why? I really want to understand what value you think is realised by them doing so.

> In summary, I think the proposed changes would change the list from
> being mainly useful but sometimes toxic, to being mainly toxic and rarely
> useful.

I don't agree with the characterisation of the list in its current form as 'mainly useful but sometimes toxic' -- 'mainly toxic and rarely useful' is much more apt. I'd be interested to hear what others think, though.

I do agree that these changes aren't likely to make it more useful.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Rob Sayre <[email-masked]>
Date: Mon, 17 Aug 2020 23:01:27 -0700

On Mon, Aug 17, 2020 at 10:49 PM Mark Nottingham <[email-masked]> wrote:

> I don't agree with the characterisation of the list in its current form as
> 'mainly useful but sometimes toxic' -- 'mainly toxic and rarely useful' is
> much more apt. I'd be interested to hear what others think, though.
>

Agree with Mark. I don't think the ietf@ list is useful most of the time,
but it is often toxic.

This draft is the correct remedy, as it removes the audience some email
senders seem to think they are entitled to.

thanks,
Rob

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 18 Aug 2020 11:24:51 +0100

Hiya,

On 18/08/2020 06:49, Mark Nottingham wrote:
> I don't agree with the characterisation of the list in its current
> form as 'mainly useful but sometimes toxic' -- 'mainly toxic and
> rarely useful' is much more apt. I'd be interested to hear what
> others think, though.
I think that the level of subjectivity involved makes
me wonder if it's worthwhile trying to figure that out.

FWIW, I'd characterise ietf@ietf as "mostly boring,
sometimes annoying, rarely useful but overall still
needed for the few IETF things that need really broad
list discussion."

I doubt gendispatch is a good substitute for things
that do need such broad discussion so I'm not sure
if this draft can end up useful.

S.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 18 Aug 2020 12:54:00 +0200

In terms of the usefulness ratio I's also say it’s low compared to the total traffic volume and time investment (as a German I really focus on efficient here :-) ). However, there is some useful feedback on the list that we want to contain somehow. I’m really mostly worried about the point that the feedback there is not representative. The recent example is that we only got good replies to the meeting survey when we also asked the chairs to announce it on their wg mailing lists. We usually don’t do that because we don’t want to spam those lists but in this case we really thought it also important for the groups itself that the IESG and LLC get input from a large community on how to hold online meetings. The ietf-announce and ietf list were not able to generate that needed feedback. So I think what is most important is to have a good way to reach a large portion of the (active) community without requiring a large time investment from the group of people that other are not subscribed to ietf@ or overly interesting in most of the processing questions. 

Mirja

> On 18. Aug 2020, at 12:24, Stephen Farrell <[email-masked]> wrote:
> 
> 
> Hiya,
> 
> <0x5AB2FAF17B172BEA.asc>-- 
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 18 Aug 2020 11:34:52 +0000

I think the IETF list is rarely toxic. Maybe since I grew up on Usenet and xml-dev I have a higher tolerance, but I can’t recall a toxic thread other than the language one. And even then, my feelings are more sensitized because I participate perhaps (and was just recently “burned” by the same topic over in an open source project). So I’m curious what other topic threads others consider toxic.

It is noisy, repetitive, and sometimes not useful. So are humans. Just because something’s not always good doesn’t mean it’s bad or broken and needs to be fixed. Openness is worth it, and it comes with costs we should be willing to pay.

I dislike this draft and prefer it gets abandoned.

                /r$

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 19 Aug 2020 00:24:57 +1000

I agree that it's not often toxic.  Off the top of my head other recent cases that got somewhat obnoxious are:

* the nomcom validation process (also: nomcom eligibility for ietf107 got a bit off the rails)
* meetecho reviews
* criteria for deciding if IETF108 should be virtual
* criteria for deciding if IETF107 should go ahead
* anything about requiring IETF services to support ipv6
* anything that Jay has done, ever
* spring-wg drama
* the .org sale

looking back to 2019:

* IETF SMTP server was configured to block IP address HELO
* RFCv3 format reviews
* OMG Heather quit - GRAB THE PITCHFORKS WHO WAS AT FAULT WE MUST KNOW!!!
* probably others

The problem is, at the core of each of these is a complex problem that the IETF has to grapple with (except "all services must use ipv6", those people are tilting at windmills), but conversations devolve into mud-slinging and tribes settling back into their familiar trenches quite easily.

I'm in two minds about Mark's proposal:

On the one hand, plenty of people don't see things on that list because of volume or disinterest.

On the other, the answer to "why wasn't I consulted" can be "it was on the ietf@ietf list, that's how you find out".  Or if it wasn't said on the list, that's when the complainer has reasonable grounds to be upset about being uninformed.

If we splinter to lots of places, I'm not convinced that the problems go away.  They are hard problems, and they won't be solved by a subset of people with similar opinions as to the correct path forward working off to one side, and then coming back with a pre-prepared solution and declaring the work to be finished.  If anything, that will just lead to the last-call list picking up all the problems that this list has, but at the end when the only way to solve them is more extreme than hashing issues out up-front (as painful as that is).  I'm can imagine last-call would become filled with "STRONG NO, THIS WORK IS WRONG AND SHOULDN'T HAVE BEEN DONE.  I OBJECT" rather than the current small tweaks on documents where the main consensus work has already been done.

As a moderator of last-call, I'm not keen on that as a path forward!

Regards,

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 18 Aug 2020 14:27:27 +0000

*   I agree that it's not often toxic.  Off the top of my head other recent cases that got somewhat obnoxious are:

Would you describe any of the controversial items from your list as toxic?  I might put the Heather thread there, if pressed.

---

From: Kyle Rose <[email-masked]>
Date: Tue, 18 Aug 2020 10:42:27 -0400

On Tue, Aug 18, 2020 at 10:25 AM Bron Gondwana <[email-masked]>
wrote:

> I think the IETF list is rarely toxic. Maybe since I grew up on Usenet and
> xml-dev I have a higher tolerance, but I can’t recall a toxic thread other
> than the language one. And even then, my feelings are more sensitized
> because I participate perhaps (and was just recently “burned” by the same
> topic over in an open source project). So I’m curious what other topic
> threads others consider toxic.
>
>
>
>

Can we stop using the word "toxic" in our analysis of the problem? One
person's toxic thread is another person's debate on a serious, material
complaint. That sometimes the discussions devolve into name calling by some
shouldn't be used as a justification for downplaying the seriousness of the
underlying issues.

The SAA's role should be to keep the discussion civil and to, in a
progression, gently remind/warn/reprimand/punish those who violate decorum.
They should never shut down a discussion entirely, nor should they target a
participant or one whole side of a debate on a serious, material complaint.
Furthermore, action should be taken only for things we can establish rough
consensus are bad: I suspect this means personal and ad hominem attacks,
insults, and language intended to denigrate, e.g., racial epithets and the
like.

Kyle

---

From: Colin Perkins <[email-masked]>
Date: Tue, 18 Aug 2020 17:01:01 +0100

> On 18 Aug 2020, at 04:10, Jay Daley <[email-masked]> wrote:
> 
> Brian
> 
>> On 18/08/2020, at 2:46 PM, Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> I am in the process of determining data like this for a number of reasons and so I can give you some interim results now.  
> 
> First the disclaimer:
> 
> * I’m relying on mailman storing email addresses consistently and I have not completely checked that it does
> * I am counting address with different +box notation as a single subscriber
> * Addresses that have been disabled by bounce processing are counted the same as those that are not (one of the main reasons these are only interim results)
> * This data is from three weeks ago and will have changed since then
> 
> With that in mind, the interim results are:
> 
> 1. The membership of ietf@ was 1796 distinct subscribers 
> 
> 
> 2. There were 55,894 distinct email addresses subscribed to mailing lists that allow open subscription
> 
> 3. 123 subscribers to ietf@ did not subscribe to any other list

If I’m wrangling the datatracker correctly:

1608 subscribers to [email-masked] <mailto:[email-masked]>
…932 of whom subscribe to at least one list for an active working group
…676 do not appear to be subscribed to any of the active working groups

20264 subscribers to mailing lists for active working groups. 

Colin

> 4. Three weeks ago the membership of ietf-announce was 3038
> 
> 5. 800 were subscribed to ietf-announce@ and no other list
> 
> 6. 1087 were subscribed to ietf@ but not ietf-announce@
> 
> Jay
> 
>> 
>> [email-masked] <mailto:[email-masked]> threads.)
>> 
>> Regards
>>   Brian Carpenter
>> On 17-Aug-20 13:00, [email-masked] <mailto:[email-masked]> wrote:
>>> 
>>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>> 
>>> 
>>>        Title           : Rechartering the IETF Discussion List
>>>        Author          : Mark Nottingham
>>> 	Filename        : draft-nottingham-discussion-recharter-00.txt
>>> 	Pages           : 7
>>> 	Date            : 2020-08-16
>>> 
>>> Abstract:
>>> The IETF datatracker status page for this draft is:
>>> https://datatracker.ietf.org/doc/draft-nottingham-discussion-recharter/ <https://datatracker.ietf.org/doc/draft-nottingham-discussion-recharter/>
>>> 
>>> There are also htmlized versions available at:
>>> https://tools.ietf.org/html/draft-nottingham-discussion-recharter-00
>>> https://datatracker.ietf.org/doc/html/draft-nottingham-discussion-recharter-00
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> Internet-Drafts are also available by anonymous FTP at:
>>> ftp://ftp.ietf.org/internet-drafts/
>>> 
>>> 
>>> _______________________________________________
>>> I-D-Announce mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/i-d-announce
>>> Internet-Draft directories: http://www.ietf.org/shadow.html
>>> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>> 
>> 
> 
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked] <mailto:[email-masked]>

-- 
Colin Perkins
https://csperkins.org/

---

From: Viktor Dukhovni <[email-masked]>
Date: Tue, 18 Aug 2020 12:49:57 -0400

On Tue, Aug 18, 2020 at 11:34:52AM +0000, Salz, Rich wrote:

> It is noisy, repetitive, and sometimes not useful. So are humans. Just
> because something’s not always good doesn’t mean it’s bad or broken
> and needs to be fixed. Openness is worth it, and it comes with costs
> we should be willing to pay.
> 

+1.  I concur, a single recent contentious topic is not sufficient
grounds to throw out the baby with the bathwater.  I imagine most
subscribers have emaill clients that group messages by thread.  It is
then quite easy to skip threads that cease to be worth reading.

-- 
    Viktor.

---

From: Nico Williams <[email-masked]>
Date: Tue, 18 Aug 2020 12:13:44 -0500

> then quite easy to skip threads that cease to be worth reading.

+1.  Hard cases make bad law and all that.

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 18 Aug 2020 19:26:31 +0200

For me the openness principle of the IETF also includes that the barrier to participation must be kept low, meaning that the we should help to reduce the time commitment people have to make to work productively whenever possible. In that sense I don’t think the ietf list currently serves us well and trying to use more specific lists as much as possible seems to me a good proposal for discussion.

Rich, I really don’t know what you mean by "this draft should get abandoned". Part of this openness is that every one can submit (and maintain) individual drafts. If there is support in the community to further work on the proposal is a different question but I think that’s what we are currently trying to figure out.

> On 18. Aug 2020, at 13:34, Salz, Rich <rsalz=[email-masked]> wrote:
>

---

From: Dan Harkins <[email-masked]>
Date: Tue, 18 Aug 2020 10:31:29 -0700

On 8/18/20 4:34 AM, Salz, Rich wrote:
> I think the IETF list is rarely toxic. Maybe since I grew up on Usenet 
> and xml-dev I have a higher tolerance, but I can’t recall a toxic 
> thread other than the language one. And even then, my feelings are 
> more sensitized because I participate perhaps (and was just recently 
> “burned” by the same topic over in an open source project). So I’m 
> curious what other topic threads others consider toxic.
>

   I agree. These contentious issues happen so infrequently that I'm 
having trouble
recalling another one (although I seem to remember getting angry in the 
past over
ietf traffic).

> we should be willing to pay.

   That is a great way to put it!

> I dislike this draft and prefer it gets abandoned.

   Agree. I think the recent flare-up shows that something needs to be done
vis-a-vis power and its (ab)use by IETF leadership but this draft isn't it.

   regards,

   Dan.

---

From: Christian Huitema <[email-masked]>
Date: Tue, 18 Aug 2020 10:32:05 -0700

> then quite easy to skip threads that cease to be worth reading.

I am not entirely convinced by Mark's draft either. My personal
assessment is that we have many problems:

* The IETF list acts as the offline general assembly, but without any
rules of order. We would not run a meeting of 1000 people without any
such rules, and for example we use mike queues and time limits during
the plenary. The lack of order leads to poor behavior and reduced utility.

* The IETF list also acts as the IETF lobby, a place that newcomers
might join in order to sense the pulse of the organization. But we are
conducting a permanent and sometimes very loud general assembly in the
lobby, and that scares visitors away.

* To expand on the previous point, the tolerance for loud discussions
naturally selects for loud spoken and loudness tolerant individuals,
typically oldtimers. It turns away other types of participants,
contributing to lack of renewal and lack of diversity in the organization.

* As Mark points out, the list membership is a fraction of the IETF
participants, which makes it a rather unrepresentative general assembly.
But that may well be a consequence of the other issues.

Mark's proposal addresses the "rules of order" issue by directing
discussions to the gendispatch WG, and then possibly to specialized WG.
The advantage is that WG chairs can and do impose discussion rules. We
have examples that it works, e.g., moving the RFC-ED discussion from the
IETF list to a specialized group. But Mark's proposal also does away
with any notion of an online general assembly -- the IETF list is left
to its own devices, some kind of playground for people who like loud
debates, and the IESG is told that it just does not have to listen. That
seems sub-optimal, because feedback is indeed useful.

If I am right -- :-) -- the main missing component is some kind of
"rules of order" for the IETF list, similar to the mike lines and time
limits that we have in working groups or in the physical plenary. This
requires some authority to enforce the rules, an authority that should
be separate from the IAB/IESG leadership if we want an avenue of
feedback for that leadership.

We may also consider not washing our dirty laundry in the front lobby,
i.e., separating the "social discussion" and "plenary" functions.

-- Christian Huitema

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 18 Aug 2020 17:53:40 +0000

>    Rich, I really don’t know what you mean by "this draft should get abandoned". 

I want this to not be advanced to a WG.  Sorry if I used the wrong term for that action.

---

From: Mary Barnes <[email-masked]>
Date: Tue, 18 Aug 2020 13:24:30 -0500

On Tue, Aug 18, 2020 at 12:26 PM Mirja Kuehlewind <[email-masked]>
wrote:

> For me the openness principle of the IETF also includes that the barrier
> to participation must be kept low, meaning that the we should help to
> reduce the time commitment people have to make to work productively
> whenever possible. In that sense I don’t think the ietf list currently
> serves us well and trying to use more specific lists as much as possible
> seems to me a good proposal for discussion.
>
[MB] I don't believe most people come first to the IETF discussion list
when they are interested in participating in IETF - announcement list,
yes.   In my experience, people come to IETF because they have a specific
technical area that they want to learn more about and ideally contribute
to.  People would generally subscribe to various WG (and area) mailing
lists.  People might join the IETF discussion list just to get the broader
view, but that would be secondary in my experience.    I long, long ago
switched my subscription to the IETF discussion list to a different email
address so it didn't distract me from the real IETF technical work.
Definitely, for topics that fit the scope of other groups, discussions can
be directed there.  I think there are a whole lot of other things that are
barriers (or deterrents) to participation than the IETF discussion list and
I haven't found it to be any more brutal (or toxic) than what one can
experience in WG sessions.  It doesn't take long for the average person to
figure out that the discussion list can be a free for all and as others
have pointed out, it's pretty easy to redirect these messages so that
they're not getting in the way of higher priority IETF activities.  [/MB]

>
> Rich, I really don’t know what you mean by "this draft should get
> abandoned". Part of this openness is that every one can submit (and
> maintain) individual drafts. If there is support in the community to
> further work on the proposal is a different question but I think that’s
> what we are currently trying to figure out.
>
>
>
> >> I don't agree with the characterisation of the list in its current form
> as 'mainly useful but sometimes toxic' -- 'mainly toxic and rarely useful'
> is much more apt. I'd be interested to hear what others think, though.
> >
> and xml-dev I have a higher tolerance, but I can’t recall a toxic thread
> other than the language one. And even then, my feelings are more sensitized
> because something’s not always good doesn’t mean it’s bad or broken and
> needs to be fixed. Openness is worth it, and it comes with costs we should
> be willing to pay.
> >

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Aug 2020 10:42:54 +1200

On 19-Aug-20 04:01, Colin Perkins wrote:
...

> 20264 subscribers to mailing lists for active working groups. 

Interesting. But without further analysis of people who use different
addresses for different lists, and how many of those addresses are
dormant, it's not clear what the definitive conclusions should be.

At face value, 932/20264 would rather seem to validate my claim that
less than 10% of participants are interested in plenary matters.

    Brian

---

From: Colin Perkins <[email-masked]>
Date: Tue, 18 Aug 2020 23:50:52 +0100

> On 18 Aug 2020, at 23:42, Brian E Carpenter <[email-masked]> wrote:

Sure – and such analysis is possible, but will take time.

> less than 10% of participants are interested in plenary matters.

That’s certainly one interpretation; another might be that less than 10% of participants can stand the bickering and toxic atmosphere on the ietf@ mailing list. Getting a clear answer to which is the case might be difficult. 

Cheers,
Colin

---

From: Dan Harkins <[email-masked]>
Date: Tue, 18 Aug 2020 16:07:05 -0700

> That’s certainly one interpretation; another might be that less than 10% of participants can stand the bickering and toxic atmosphere on the ietf@ mailing list. Getting a clear answer to which is t…

   Well how many people attend the IETF Plenary at in-person meetings? Maybe
250-300 people? Out of 1100-1200 or so? So let's say 20%? 25%? And 
figure half
of them are reading mail or expressing bad attitude on jabber so then 
roughly
10% of the attendees of the meeting are interested in the goings on at the
plenary.

   Dan.

---

From: Rob Sayre <[email-masked]>
Date: Tue, 18 Aug 2020 21:33:05 -0700

On Tue, Aug 18, 2020 at 3:51 PM Colin Perkins <[email-masked]> wrote:

>
> That’s certainly one interpretation; another might be that less than 10%
> of participants can stand the bickering and toxic atmosphere on the ietf@
> mailing list. Getting a clear answer to which is the case might be
> difficult.
>

The way this draft suggests demoting the the ietf@ mailing list (perhaps as
an experiment) is a great way to test this.

thanks,
Rob

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 19 Aug 2020 15:35:30 +1000

Hi Christian,

I'm not going to respond to every message on this thread, as I want to hear what others think. 

I think we agree that the question at hand is reconciling the nature of the discussion with the need for it. My draft is one proposal; there maybe others, and I'm happy to discuss changing mine. I wrote this one down because it's pretty clear (at least to me) that imposing rules of order on this list isn't possible, because many people are unwilling to change how they use or think about it. If I'm wrong about that, that's great.

Regarding 'Mark's proposal also does away with any notion of an online general assembly'  -- My expectation is that even if the IESG and other leadership would be told that they don't have to listen to ietf@, they still would -- provided that the list didn't become mired in endless acrimonious cycles, as it has of late. De-emphasing the list also restores some balance between those that use it to amplify their voices and those who are turned away from such activity.

Perhaps that goes too far, and there does need to be an expectation that leadership will be on the list. If that's the case, it's important to recognise that this becomes a selector for leadership -- if you can't 'take it' on the ietf@ list, you're not fit for leadership. That will in turn reduce the diversity of work and participants in the IETF over time. 

Cheers,

> On 19 Aug 2020, at 3:32 am, Christian Huitema <[email-masked]> wrote:
> 
> I am not entirely convinced by Mark's draft either. My personal assessment is that we have many problems:
> 
> * The IETF list acts as the offline general assembly, but without any rules of order. We would not run a meeting of 1000 people without any such rules, and for example we use mike queues and time limits during the plenary. The lack of order leads to poor behavior and reduced utility.
> 
> * The IETF list also acts as the IETF lobby, a place that newcomers might join in order to sense the pulse of the organization. But we are conducting a permanent and sometimes very loud general assembly in the lobby, and that scares visitors away.
> 
> * To expand on the previous point, the tolerance for loud discussions naturally selects for loud spoken and loudness tolerant individuals, typically oldtimers. It turns away other types of participants, contributing to lack of renewal and lack of diversity in the organization.
> 
> * As Mark points out, the list membership is a fraction of the IETF participants, which makes it a rather unrepresentative general assembly. But that may well be a consequence of the other issues.
> 
> Mark's proposal addresses the "rules of order" issue by directing discussions to the gendispatch WG, and then possibly to specialized WG. The advantage is that WG chairs can and do impose discussion rules. We have examples that it works, e.g., moving the RFC-ED discussion from the IETF list to a specialized group. But Mark's proposal also does away with any notion of an online general assembly -- the IETF list is left to its own devices, some kind of playground for people who like loud debates, and the IESG is told that it just does not have to listen. That seems sub-optimal, because feedback is indeed useful.
> 
> If I am right -- :-) -- the main missing component is some kind of "rules of order" for the IETF list, similar to the mike lines and time limits that we have in working groups or in the physical plenary. This requires some authority to enforce the rules, an authority that should be separate from the IAB/IESG leadership if we want an avenue of feedback for that leadership.
> 
> We may also consider not washing our dirty laundry in the front lobby, i.e., separating the "social discussion" and "plenary" functions.
>

---

From: Keith Moore <[email-masked]>
Date: Wed, 19 Aug 2020 09:10:46 -0400

On 8/18/20 10:42 AM, Kyle Rose wrote:

> person's toxic thread is another person's debate on a serious, 
> material complaint. That sometimes the discussions devolve into name 
> calling by some shouldn't be used as a justification for downplaying 
> the seriousness of the underlying issues.

Yes, and would people try to be more descriptive/specific as to what 
they mean by "toxic"?

I hope people don't use the word "toxic" to mean merely "it makes me 
uncomfortable".   But I can't tell what they mean.

Reading the ietf list sometimes makes me uncomfortable but at least for 
me it's usually in _what_ they are saying as opposed to _how_.

(And then I have to remind myself that I need to accept the reality of 
different points-of-view, to accept that there really are people who 
want to destroy what I believe is essential about IETF, and admit they 
may think they're doing a Good Thing even though I disagree, and they 
may have valid points even if I strongly oppose their proposed 
remedies.   None of which is fun, but it's necessarily part of the hard 
work of trying to find common ground that can lead to rough consensus.)

Keith

---

From: Rob Sayre <[email-masked]>
Date: Wed, 19 Aug 2020 21:05:53 -0700

> Yes, and would people try to be more descriptive/specific as to what

It seems like the ietf@ list has been damaged by "sealioning".

https://www.urbandictionary.com/define.php?term=Sealioning

I can't tell exactly which messages fall under that definition, but I am
pretty sure that some of them do.

This proposal seems to remove habitat for the described behavior, and I
can't see a downside.

thanks,
Rob

---

From: Keith Moore <[email-masked]>
Date: Thu, 20 Aug 2020 00:10:54 -0400

On 8/20/20 12:05 AM, Rob Sayre wrote:

> I can't tell exactly which messages fall under that definition, but I 
> am pretty sure that some of them do.

I generally find it unhelpful in the extreme to presume bad intent in 
the absence of a preponderance of evidence.

Keith

---

From: Rob Sayre <[email-masked]>
Date: Wed, 19 Aug 2020 21:25:15 -0700

On Wed, Aug 19, 2020 at 9:11 PM Keith Moore <[email-masked]>
wrote:

> I generally find it unhelpful in the extreme to presume bad intent in the
> absence of a preponderance of evidence.
>

That is pretty much the definition of the trust that sealioning takes
advantage of.

I favor removing the habitat. I don't want to guess at anyone's
motivations, and I don't see a lot of productive input coming from the ietf@
list that couldn't be delivered elsewhere.

thanks,
Rob

---

From: Keith Moore <[email-masked]>
Date: Thu, 20 Aug 2020 00:33:20 -0400

>>     I can't tell exactly which messages fall under that definition,
>>     but I am pretty sure that some of them do.
>
>     I generally find it unhelpful in the extreme to presume bad intent
>     in the absence of a preponderance of evidence.
>
>

It's also often the only way to help build consensus.  If you assume 
malicious intent any time someone has a position that's different than 
yours, you'll never be able to see merit in their positions, and you're 
unlikely to be able to contribute to any kind of win-win or compromise.

> motivations, and I don't see a lot of productive input coming from the 
> ietf@ list that couldn't be delivered elsewhere.

I emphatically disagree with your characterization.   Just because 
someone defins a term for an unhelpful tactic, is no reason to presume 
that it must be defeated at all costs.

The "habitat" is essential to the continued functioning of IETF, in 
particular the community's ability to keep the "leadership" from going 
off the rails.

That's not to say that it's not worth considering some changes, but the 
named proposal is IMO unacceptable.

Keith

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 20 Aug 2020 00:33:26 -0400

This seems a very bad argument for removing the IETF list.
The argument does not cite any specific messages.
And seems, although I could be mistaken, to rely on inferring the 
interpretation of the sender of whatever unspecified messages are being 
considered.

That is a very different claim than the one Mark makes in his email. 
Which is itself being debated as to the scope and seriousness of the 
problem.

Removing lists has consequences / costs.

Yours,
Joel

On 8/20/2020 12:25 AM, Rob Sayre wrote:
> On Wed, Aug 19, 2020 at 9:11 PM Keith Moore <moore@network-heretics..com 
> <mailto:[email-masked]>> wrote:
>

---

From: Rob Sayre <[email-masked]>
Date: Wed, 19 Aug 2020 21:35:55 -0700

...

I believe the proposal does not remove the list. Did I misread?

I think it does change the role of the ietf@ list.

thanks,
Rob

---

From: Dan Harkins <[email-masked]>
Date: Wed, 19 Aug 2020 23:42:04 -0700

On 8/19/20 9:05 PM, Rob Sayre wrote:
> On Wed, Aug 19, 2020 at 6:10 AM Keith Moore 
> <moore@network-heretics..com <mailto:[email-masked]>> wrote:
>

   Yea, Richard Barnes already made that accusation [1].

   Thing is, the definition claims that sealioning means:

     "You disingenuously frame your conversation as a sincere request
     to be enlightened, placing the burden of educating you entirely
     on the other party. If your bait is successful, the other party
     may engage, painstakingly 
<https://www.urbandictionary.com/define.php?term=painstakingly> laying 
out their logic and evidence in
     the false hope 
<https://www.urbandictionary.com/define.php?term=false%20hope> of 
helping someone learn."

and that's the thing. "The other party" (that being YOU! since you're
accusing others of sealioning) never engages in any laying out of their
logic and evidence here. It's just accusations of bullying [2] and
toxicity [3]. When asked for exactly what makes words "exclusionary"
and who is excluded by them and why, the response is that we haven't
agreed yet that words can be "exclusionary" so the actual reasoning
on why one would make such an assertion-- the "logic and evidence",
an actual answer-- need not be given [4].

   Merely accusing others of bad faith is not painstakingly laying out
of logic and evidence.

> am pretty sure that some of them do.

   It's not sealioning. None of the messages fall under that definition
and that won't change unless and until the "other party" initiates
some serious engagement.

> This proposal seems to remove habitat for the described behavior, and 
> I can't see a downside.

   If you see no value in a mailing list then don't subscribe but
it's quite presumptive to say that your view means the list should be
handicapped in some way that might prevent it from being useful to
others.

   Dan.

[1] https://mailarchive.ietf.org/arch/msg/ietf/ElLB2AodSLaBBvztvxj1xIzhk3U/
[2] https://mailarchive.ietf.org/arch/msg/ietf/q-abE5H-lGcydsbZqI8mz1P1ChA/
[3] https://mailarchive.ietf.org/arch/msg/ietf/R9e-sp6Sjy5KhiD9L_9_yWVoRfs/
[4] https://mailarchive.ietf.org/arch/msg/ietf/-0KIGNdrT0YdG5k4IRN0mC4rdnk/

---

From: Rob Sayre <[email-masked]>
Date: Thu, 20 Aug 2020 00:32:02 -0700

On Wed, Aug 19, 2020 at 11:42 PM Dan Harkins <[email-masked]> wrote:

>   If you see no value in a mailing list then don't subscribe
>

I don't subscribe to that list.

thanks,
Rob

---

From: Dan Harkins <[email-masked]>
Date: Thu, 20 Aug 2020 01:00:01 -0700

On 8/20/20 12:32 AM, Rob Sayre wrote:
> On Wed, Aug 19, 2020 at 11:42 PM Dan Harkins <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>>     This proposal seems to remove habitat for the described behavior,
>>     and I can't see a downside.
>

   You should recuse yourself from matters concerning a list that you
expressly refuse to subscribe to.

   Dan.

---

From: Rob Sayre <[email-masked]>
Date: Thu, 20 Aug 2020 01:04:57 -0700

> expressly refuse to subscribe to.

I unsubscribed a few days ago. I think I joined in 2005.

thanks,
Rob

---

From: Kyle Rose <[email-masked]>
Date: Thu, 20 Aug 2020 08:54:33 -0400

> handicapped in some way that might prevent it from being useful to

Indeed, quitting a list and then claiming (accurately) that it can no
longer be relied on to represent IETF rough consensus is precisely begging
the question. Sometimes you have to do things you don't like in service of
the greater good of the organization. IMO, one of those things is paying
attention to the IETF list and contributing where you have a strongly-held
view so we can continue to have an organization-wide forum for establishing
rough consensus (or an inability to do so: that must also be an acceptable
outcome) on broad, contentious topics that aren't just document last calls.

Kyle

---

From: "Pete Resnick" <[email-masked]>
Date: Thu, 20 Aug 2020 11:18:27 -0500

It sounds to me like Christian is saying, "The lack of rules of order 
for the IETF list is a problem", and it sounds like that is a statement 
with which Mark would probably agree. I'm also guessing that the two of 
you would also agree that the "SAA SoP" is not a workable set of rules 
of order. So it sounds like the counter-proposal to Mark's would have to 
say what kinds of rules of order might work. That might be good to 
explore.

I'm definitely hearing a contingent saying that they don't want Mark's 
proposal moving forward, but if I think about DISPATCHing it, I'd like 
to hear if work on some form of change to the structure of or 
operational rules of the IETF list would be acceptable to that 
contingent. Is there something here people think would be useful, and if 
so, in what forum should it be worked on?

Cheers,

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

On 19 Aug 2020, at 0:35, Mark Nottingham wrote:

> I think we agree that the question at hand is reconciling the nature 
> of the discussion with the need for it. My draft is one proposal; 
> there maybe others, and I'm happy to discuss changing mine. I wrote 
> this one down because it's pretty clear (at least to me) that imposing 
> rules of order on this list isn't possible, because many people are 
> unwilling to change how they use or think about it. If I'm wrong about 
> that, that's great.
>
> Regarding 'Mark's proposal also does away with any notion of an online 
> general assembly'  -- My expectation is that even if the IESG and 
> other leadership would be told that they don't have to listen to 
> ietf@, they still would -- provided that the list didn't become mired 
> in endless acrimonious cycles, as it has of late. De-emphasing the 
> list also restores some balance between those that use it to amplify 
> their voices and those who are turned away from such activity.
>
> Perhaps that goes too far, and there does need to be an expectation 
> that leadership will be on the list. If that's the case, it's 
> important to recognise that this becomes a selector for leadership -- 
> if you can't 'take it' on the ietf@ list, you're not fit for 
> leadership. That will in turn reduce the diversity of work and 
> participants in the IETF over time.
>
> Cheers,
>
>
>> might join in order to sense the pulse of the organization. But we 
>> are conducting a permanent and sometimes very loud general assembly 
>> in the lobby, and that scares visitors away.
>>
>> participants, which makes it a rather unrepresentative general 
>> assembly. But that may well be a consequence of the other issues.
>>
>> discussions to the gendispatch WG, and then possibly to specialized 
>> WG. The advantage is that WG chairs can and do impose discussion 
>> rules. We have examples that it works, e.g., moving the RFC-ED 
>> discussion from the IETF list to a specialized group. But Mark's 
>> proposal also does away with any notion of an online general assembly 
>> -- the IETF list is left to its own devices, some kind of playground 
>> for people who like loud debates, and the IESG is told that it just 
>> does not have to listen. That seems sub-optimal, because feedback is 
>> indeed useful.
>>
>> "rules of order" for the IETF list, similar to the mike lines and 
>> time limits that we have in working groups or in the physical 
>> plenary. This requires some authority to enforce the rules, an 
>> authority that should be separate from the IAB/IESG leadership if we 
>> want an avenue of feedback for that leadership.
>>
>> We may also consider not washing our dirty laundry in the front 
>> lobby, i.e., separating the "social discussion" and "plenary" 
>> functions.
>>
>
> --

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 20 Aug 2020 17:59:46 +0000

>  I'd like 
    contingent.

Not to me.  Maybe revisit in six months, or a couple of months after the "problematic language" drafts are dispatched.

---

From: Keith Moore <[email-masked]>
Date: Thu, 20 Aug 2020 15:12:32 -0400

On 8/20/20 12:18 PM, Pete Resnick wrote:

> for the IETF list is a problem", and it sounds like that is a 
> statement with which Mark would probably agree. I'm also guessing that 
> the two of you would also agree that the "SAA SoP" is not a workable 
> set of rules of order. So it sounds like the counter-proposal to 
> Mark's would have to say what kinds of rules of order might work. That 
> might be good to explore.
>
> contingent. Is there something here people think would be useful, and 
> if so, in what forum should it be worked on?

I do think some changes might be appropriate, but don't think of them as 
limited to, or specifically scoped by, changes to the rules of order.

1. I believe that the IETF needs a "center", i.e. a list that nearly 
everyone participating in IETF will want to subscribe to. That list 
should be devoted to topics of relevance to the Internet and/or IETF, 
and the purpose of the list should be to make IETF participants 
generally aware of those topics and related issues, so that we're all 
more-or-less on the same page.  (That's not to say that everyone should 
agree on how to address those issues, just that there's a set of things 
that probably everyone who participates in IETF should be aware of.)   
IMO, there should be room for discussion on that list - it should not be 
announce-only - but perhaps there should be some measures to keep that 
discussion (a) on-topic and (b) relatively low-volume. Especially (b) is 
implied by the desire to have nearly everyone who participates in IETF 
to be subscribed to this list.   Since Censorship Is Bad, perhaps there 
should be a designated separate "overflow" list so long discussions can 
be redirected there to keep the main list volume low but without 
silencing people. (Perhaps the ietf-details@ list proposed below would 
be appropriate for that.)

(It's possible that this list would need to be moderated in order to 
keep volume low, but I hope not because then it might degrade into just 
another announce list.   IMO it should be limited to topics of broad 
interest to the IETF community, but NOT only the topics that I* think 
are relevant.   It might be tricky to maintain that balance.)

2. In addition there is a need to have a place for potentially 
contentious and/or lengthy discussions - including Last Calls, WG 
chartering, policy discussions (however the policies are implemented), 
and public discussion of how IETF is run.   I will tentatively call it 
ietf-details@ (as in "the devil is in the details") though ietf-swamp@ 
might also be a good name.   This list would serve as a place to 
publicly collect input that IESG and other IETF participants can use to 
gauge the degree of consensus on a particular topic, but also for 
discussion of such topics - especially efforts to refine points of 
contention, and to identify potential common ground on which rough 
consensus might eventually be built.   This list would be separate from 
the main IETF list so that not everyone who subscribes to ietf@ would 
have to see it.    However anyone who subscribes to the main IETF list 
should be able to post to the ietf-details@ list without a separate 
subscription to that list.   Non-subscribers to ietf-details@ who 
occasionally want to wade into the swamp should be free to do so.   They 
can read messages on the ietf-details@ list via the archive or the IMAP 
server.   Occasionally it might be appropriate to post a message to 
ietf@ of the form "discussion of topic X is taking place on the 
ietf-details@ list, you can see it in the archive at <URL>".

Both of these lists would be subject to ordinary rules of decorum, but 
the ietf@ list would have a narrower range of acceptable topics as well 
as perhaps some limits on number of messages posted on any particular topic.

Part of the idea here is to let people be "in the loop" even if they 
don't want to be "in the swamp".   Part of the idea is to minimize the 
number of occasions in which it's necessary to make value judgments 
about the propriety of conversations in order to avoid discouraging 
relatively casual participants.

(Of course if the above structure were adopted it would be appropriate 
to update RFC3005 to reflect that.)

3. Regarding rules of order, I suspect that only slight tweaks are 
needed.   First, the SAAs should not be either chosen by or act under 
the direction of the IETF Chair.  IMO they should act as independent and 
ideally impartial moderators, but adhere strictly to standards already 
established except in the rare occasion when they don't know how to 
interpret those standards... then they should consult IAB.   Second, 
there needs to be a clear process for appeal of SAA actions (presumably 
to IAB) rather than just a vague "complaints ... should be referred to 
the IAB" as currently in 3005.   Third, IMO it would be beneficial to 
define the standards of decorum more precisely, and particularly to 
avoid ambiguous words like "[un]professional" (as well as "[un]helpful", 
"toxic", "tone", etc.) which may mean very different things to different 
people, and which can therefore be enforced arbitrarily and in a 
potentially discriminatory fashion, according to the whims of the 
enforcers or people who direct them.  Fourth, perhaps SAAs should have a 
broader range of actions available to them when moderating the ietf@ 
list - e.g. redirecting a conversation to the ietf-details@ list.

4. I'm wondering if it would also be useful to publish a document on the 
subject of "making effective use of IETF email lists" which suggests 
things like: (a) using an email reader that allows threaded reading (so 
readers can ignore entire threads that they're not interested in and 
easily peruse the ones they are interested in), (b) using a separate 
email address from one's normal work address so that the work address 
isn't flooded with traffic, (c) using subfolders and subfolder 
addressing when available, (d) how to reply effectively, (e) when to 
move a discussion to private mail, etc.

5. More ambitiously, I'm thinking it's also possible that the current 
hodgepodge of ietf lists (ietf@, ietf-announce@, last-call@, ...) could 
use some cleaning up and potential reorganization with the idea of 
making it easier for IETF participants to keep track of the things 
they're interested in, without having to wade through volumes of 
material they're not interested in.   For instance, a better ability to 
fine-tune which announcements one receives, say per-area or per-WG or 
per-document, might be useful.

More ambitiously, some or all of these topics might be appropriately 
deferred to a working group tasked with making IETF communications more 
accessible / easier to use.

Keith

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 Aug 2020 10:22:31 +1200

On 20-Aug-20 16:25, Rob Sayre wrote:
> On Wed, Aug 19, 2020 at 9:11 PM Keith Moore <moore@network-heretics..com <mailto:[email-masked]>> wrote:
> 
>>     I can't tell exactly which messages fall under that definition, but I am pretty sure that some of them do.
> 
>     I generally find it unhelpful in the extreme to presume bad intent in the absence of a preponderance of evidence. 
> 
> 
> That is pretty much the definition of the trust that sealioning takes advantage of.
> 
> I favor removing the habitat. I don't want to guess at anyone's motivations, and I don't see a lot of productive input coming from the ietf@ list that couldn't be delivered elsewhere.

I have to invoke one of the first things we all learned in CS: Any problem can be solved by an extra level of indirection. And its corollary: After some time, the problem will come back, one level down. In other words, whatever vehicle you use for discussing IETF-wide issues will end up in the same state: some discussions either get out of hand, or upset some people, or both.

Let's not just drive this problem elsewhere. Fix what's wrong with the SAA mechanism. Keith's message would be a good basis for an I-D.

Regards
    Brian

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 21 Aug 2020 10:32:06 +1000

Hi Pete,

> On 21 Aug 2020, at 2:18 am, Pete Resnick <[email-masked]> wrote:
> 
> It sounds to me like Christian is saying, "The lack of rules of order for the IETF list is a problem", and it sounds like that is a statement with which Mark would probably agree. I'm also guessing that the two of you would also agree that the "SAA SoP" is not a workable set of rules of order. So it sounds like the counter-proposal to Mark's would have to say what kinds of rules of order might work. That might be good to explore.

I'd like to believe that's a way forward, but am somewhat pessimistic about its chances of success. 

My reading of the situation is that there are a few somewhat conflicting purposes for the ietf@ list, and that blocks any meaningful progress.

Many see the IETF list as having a plenary function; it is where the organisation comes together to discuss matters of import to everyone. The IESG can get a sense of the community there, participants can hold them to account and raise new ideas, and so on.

As Christian and others have pointed out, a plenary function needs rules of order for even mildly contentious discussions; otherwise, the loudest can drown out other voices, arguments become circular, and everything becomes generally unproductive.

Some people also see the IETF list as a Speakers' Corner; the priority is on everyone being able to express themselves. The boundaries of acceptable discourse are therefore broad; it's OK to send a message dripping with sarcasm, ascribing motives to others, meandering about conspiracy theories, and so on. It's also OK in this view to respond to such messages with disdain, etc. -- which brings what one could call 'robust discourse' or 'endless ratholing' depending on your disposition.

These functions are in obvious conflict. 

Of course, some plenaries do serve both functions -- e.g., most legislatures allow a member to speak about whatever is on their mind. However, they always impose limits on that right; e.g., members' speeches only happen at certain times, can only be of a certain length, and there are still ethical requirements that, if violated, can be punished.

On the IETF list, we don't have effective limits; one can post on any given topic ad nauseam, and as we've seen recently imposing order is tricky (the SAA has been given very blunt tools. I won't defend the recent attempt to use them, but I do sympathise with their position).

I speculate that this is because while some people see the IETF list as a Speakers' Corner, others see it through the lens of a modern workplace, where behaviour suitable to a Speakers' Corner would often be seen as unprofessional at a minimum, and cause for dismissal in some cases. I suspect that some believe they shouldn't be subjected to unprofessional behaviour as part of their job; beyond just 'standards professionals', _any_ developer that comes to engage with IETF technology is also potentially exposed to such unprofessional behaviour, and may avoid some parts of the organisation or the whole of it as a result.

I suspect that some people think that that's not a good outcome for the IETF and the Internet, and that others are fine with it. There are some underlying tensions here regarding not only professional behaviour, but also academic freedom, individual vs. collective rights, etc., before you even get to issues of Internet governance. I'm sure that this will all be rich fodder for social scientists for quite some time.

This is why I made my proposal; it keeps the IETF list as a Speakers' Corner, but moves the plenary function elsewhere. That doesn't mean the plenary (or the leadership) is unaware of what happens on the Speakers' Corner; it's just that they're different venues.

> I'm definitely hearing a contingent saying that they don't want Mark's proposal moving forward, but if I think about DISPATCHing it, I'd like to hear if work on some form of change to the structure of or operational rules of the IETF list would be acceptable to that contingent. Is there something here people think would be useful, and if so, in what forum should it be worked on?

I'd characterise many of the negative responses as "I don't have that problem, so it's not worth changing anything." Perhaps we could get a description of the problem agreed to -- *if* those folks are willing to cede that just because they don't personally have a problem, others still might encounter it.

Cheers,

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 20 Aug 2020 21:38:43 -0400

While it is possible that some people see the ietf@ list as a speakers 
corner with the terms you describe, my understanding is that the IETF 
has explicitly said that things like "ascribing motives to others" are 
not permitted on any IETF list.  I think some of the other behaviors you 
list would also be prohibited by our existing standards of conduct.

Whether those standards are enforced well on the ietf@ list, or for that 
matter on all WG lists, is a different question from whether we have 
claimed that they apply.

Yours,
Joel

---

From: Rob Sayre <[email-masked]>
Date: Thu, 20 Aug 2020 21:11:42 -0700

On Thu, Aug 20, 2020 at 3:22 PM Brian E Carpenter <
[email-masked]> wrote:

>
> I have to invoke one of the first things we all learned in CS: Any problem
> can be solved by an extra level of indirection. And its corollary: After
> some time, the problem will come back, one level down. In other words,
> whatever vehicle you use for discussing IETF-wide issues will end up in the
> same state: some discussions either get out of hand, or upset some people,
> or both.
>
> Let's not just drive this problem elsewhere. Fix what's wrong with the SAA
> mechanism. Keith's message would be a good basis for an I-D.
>

I don't think the draft really focuses on enforcement. It just points out
that it's difficult to be successful in that role, since the charter of the
list is not precise enough.

To anyone: What's wrong with the 9 changes the draft recommends?

thanks,
Rob

---

From: Keith Moore <[email-masked]>
Date: Fri, 21 Aug 2020 09:39:56 -0400

> Some people also see the IETF list as a Speakers' Corner; the priority is on everyone being able to express themselves. The boundaries of acceptable discourse are therefore broad; it's OK to send a…

Perhaps I misunderstand but this doesn't sound like a good analogy to 
me.   It seems to me that the only situations in which there is a 
purpose to a Speakers' Corner, is if people are generally /not/ free to 
speak elsewhere, or cannot find an audience anywhere else.   In IETF 
there is generally more freedom to speak on other mailing lists than on 
the ietf@ list.    A Speakers' Corner lets people blow off steam but 
also marginalizes the speakers by the very fact that they feel the need 
to choose such a venue.   A physical Speakers' Corner might be a 
prominent location, but there's no assurance of a large audience.    The 
ietf@ list presumably does have a large audience relative to the set of 
IETF participants.   I've never personally heard any IETF participant 
argue that the ietf@ list should be a place where people are free to 
speak on any topic, and the set of topics explicitly permitted in RFC 
3005 is fairly narrow.

So I suspect many more people want the ietf@ list to serve the plenary 
function, among other things, than for it to serve as a Speakers' Corner.

That said, the ietf@ list sometimes has served as a venue of last 
resort, by participants who have tried to air their concerns on more 
narrowly-targeted lists and been unhappy with the results. I believe 
that's an essential function (as long as there's some sense to what the 
speakers are saying), but to me that isn't the same function as a 
Speakers' Corner.

> On the IETF list, we don't have effective limits; one can post on any given topic ad nauseam, and as we've seen recently imposing order is tricky (the SAA has been given very blunt tools. I won't d…

Traffic volume can definitely discourage participation even when the 
topic is well within scope and the discourse is civil.   The SAAs might 
have a role to play in keeping volume to a manageable level, as they do 
in keeping discussion civil and within scope.

> I speculate that this is because while some people see the IETF list as a Speakers' Corner, others see it through the lens of a modern workplace, where behaviour suitable to a Speakers' Corner woul…

While the Speakers' Corner analogy seems dubious to me, I suspect the 
"workplace" analogy is apt - particularly for people who are at IETF 
because they're paid to be there rather than because they have a strong 
interest in the work.   But I believe there are some ideas that are 
commonly associated with "professional behavior" that are actually 
harmful to IETF - especially the notion, common in many workplaces, that 
there is no room for disagreement with technical decisions issued from 
on high.   This is probably the biggest reason that I dislike the use of 
the word "professional" and its derivatives when trying to set bounds on 
IETF discourse. For IETF it is absolutely essential that participants be 
free to respectfully disagree with one another, and even (especially) 
with community leaders.   Any notion of consensus that doesn't result 
from an open discussion is dubious at best.

(We need to let leaders do their jobs but that doesn't mean that they 
can't be challenged when they misuse or exceed their authority.    ADs 
are supposed to be able to have technical opinions but it's not wrong to 
respectfully disagree with them. etc.)

Beyond notions of professionalism, I suspect that an broader reason for 
some participants' discomfort (particularly newcomers) is that IETF 
doesn't expect or enforce a notion of social hierarchy like they're 
accustomed to.   Different societies have somewhat different ideas about 
what defines such a hierarchy. But it's common worldwide for humans feel 
an obligation to defer to other humans, for reasons that may not be 
explicit or examined.   Some people will find it disturbing when their 
peers fail to adhere to those imagined obligations, especially if 
they're not reprimanded for doing so.   I've seen it happen elsewhere 
that participants in a technical discussion can become very 
uncomfortable, even distressed, when their notions of "pecking order" 
were violated by others, even if the supposedly higher status person 
being challenged explicitly said its ok. /This discomfort exists even 
when nobody is using insults or ridicule or hostile "tone"; the mere 
fact of disagreement with a person of supposedly higher"status" will 
disrespectful to some participants./

In IETF we need to act as peers as much as practicable.    But the 
expectation of a pecking order is so common in human society that it's 
hardly surprising if newcomers feel uncomfortable when they're suddenly 
expected to function in an environment which, of necessity, has 
essentially no pecking order.

Keith