Subject: [Idnet] Uses case for ML -- automating traffic prioritisation

From: grenville armitage <[email-masked]>
Date: Thu, 30 Mar 2017 11:02:42 +1100

Apologies for some repetition here -- I sent an earlier version of the below note to [email-masked] in October last year, but then ran out of cycles to further engage in discussion. Just in case the idnet@ list has slightly expanded membership, here's a lightly-expanded version of the information again:

Between ~2005 and ~2012 my group explored the application of machine learning to the task of classifying application flows. One of the specific use cases was to classify traffic that required different QoS treatment, and automate the subsequent configuration of bottleneck home gateways to achieve said QoS treatment. A more topical variant might be to use ML for recognising traffic you wish to de-prioritise (e.g. protection from DoS, enforcing scavenger-class service, etc)

Our top-level DIFFUSE project page: http://caia.swin.edu.au/urp/diffuse/
A proof-of-concept implemented in OpenWRT: http://caia.swin.edu.au/urp/diffuse/openwrt/
(pre-cursor to DIFFUSE: http://caia.swin.edu.au/sitcrc/angel, and even earlier work on statistical traffic classification: http://caia.swin.edu.au/urp/dstc)

Some past academic papers that might be of (historical) interest:

Thuy T. T. Nguyen, Grenville Armitage, Philip Branch and Sebastian Zander.
Timely and Continuous Machine-Learning-Based Classification for Interactive IP Traffic
IEEE/ACM Transactions on Networking, vol. 20 no. 6 pp. 1880-1894, December 2012
http://dx.doi.org/10.1109/TNET.2012.2187305

Thuy Nguyen and Grenville Armitage.
A Survey of Techniques for Internet Traffic Classification using Machine Learning
IEEE Communications Surveys & Tutorials, vol. 10 no. 4 pp. 56-76, 2008
http://dx.doi.org/10.1109/SURV.2008.080406

Jason But, Grenville Armitage and Lawrence Stewart.
Outsourcing Automated QoS Control of Home Routers for a Better Online Game Experience
IEEE Communications Magazine, vol. 46, no. 12, pp.64-70, December 2008
http://dx.doi.org/10.1109/MCOM.2008.4689209

cheers,
gja

---

From: grenville armitage <[email-masked]>
Date: Thu, 30 Mar 2017 11:09:15 +1100

(Belatedly following up on a question I failed to answer on nmrlg@ last year... I figure idnet@ is the appropriate place for a mea culpa and followup...)

On 10/30/2015 13:50, Liubing (Leo) wrote:
> Hi Grenville,
>
> Thanks for sharing your use case. I think it is a valuable use case in networking.
>
> You mentioned the PoC:
>> A proof-of-concept implemented in OpenWRT:
>> http://caia.swin.edu.au/urp/diffuse/openwrt/
> Does it imply that your study was specific to home networks scenarios, and the algorithms were specifically designed to adapt those low performance embedded devices?

Our specific demonstration use-case was home networking, yes. But I don't recall that we specifically made algorithm choices for low performance embedded devices. Of course, when a Professor says "my group" did something, it means the student(s) at the time were the ones who really understood the finer details :-)

> I personally expect your study was not limited in home network scenarios, because the flow classification is also an important use case in carrier networks.

Agreed. My particular focus was on simplifying the remote configuration of home gateways so they could automagically prioritise interactive traffic without being pre-loaded with N*thousands of static QoS rules for all possible VoIP, game, etc, services. But the idea generalises.

cheers,
gja