Subject: [Idnet] Network AI Use case: Predicting-based QoS ensurance

From: yanshen <[email-masked]>
Date: Tue, 27 Jun 2017 11:58:33 +0000

Hi all,

I try to list some valuable use cases that the AI technology may play a role in the network management and optimization. 

Use case 01: Use prediction to ensure VPN's QoS

It is worthy to predict the traffic change for avoiding the congestion and ensuring QoS. As the following figure shown, the AI system continuously collects link status data from the network. This AI system is responsible for two things. One is monitoring and predicting the traffic on each link and the other one is calculating the usable route for any pair of nodes according to the prediction and current link status. Assume that there is a VPN named VPN_S_D from node S to D which pass through S-A-B-C-D. According to the prediction, there will be a huge traffic flow from node A to C in the future 10 min. The traffic will increase the end-to-end delay from S to D so that the QoS will not be ensured. 

                \/     \/
                /\     /\			 ----->
           _ A ----- B ----- C._      link status data       -----------
         ,'     \      /     `.   =================| AI system |
       -'        \    /          `-                    -----------
     S ----------I------ J -------K -------  D
       .         /    \          ,'
        `.      /       \      ,'
          '  O ---- P ----  Q '	

There are at least two solutions. one is modifying the object's configuration to avoid the potential congestion. For example, we modify the VPN_S_D's route from S-A-B-C-D to S-I-J-K-D. The other one is restricting non-object's transmission so that to protect the object's QoS. For example, we increase the reserved bandwidth of VPN_S_D or modify the route of non-object flows from S-A-B-C-D to S-I-J-K-D therefore most of the traffic will not affect VPN_S_D. 

Here we may have some challenges. 

Challenge 1 is the AI prediction and autonomic decision should be a quick response. The whole process must be finished before the congestion happens meanwhile the AI system is meaningless. The question is how to implement such quick response? 

Challenge 2 is whether there is existing protocols which can support high frequency measurement? Because AI system needs to be fed with continuous link status data. And the real-time data need to be captured frequently otherwise the route change will be worthless. I think the protocols that support high frequency measurement and data collection may become one of our focuses.

regards,

------------------------------------------------------------------------------------------
Yansen

---

From: Sheng Jiang <[email-masked]>
Date: Thu, 29 Jun 2017 01:48:52 +0000

Hi, Yanshen,

Thanks for the use case. This use case by itself is useful and attractive. I also agree the two challenge you like are something that is worth working on. However, this use case is based on the precondition of accurate traffic prediction. As far as we know, there are many existing efforts on the prediction for the traffic changes. However, for my understanding, although most of existing efforts does not have the ability to do traffic prediction, there are many limitations. I don't think the current result of traffic prediction could be mature enough to support your use case. So far, the traffic prediction can only have good result on certain conditions, such as on limited interface or devices, for certain type of traffic models. 

So far, there are at least three aspects that the traffic prediction needs to be largely improved: a) granularity b) error range or accurate c) calculation time assumption d) universal validity, independent from certain topology or certain traffic model, including prediction on small traffics, reduce the influence of traffic burst, etc.

Regards,

Sheng

> -----Original Message-----
> From: yanshen
> Sent: Tuesday, June 27, 2017 7:59 PM
> To: [email-masked]
> Subject: Network AI Use case: Predicting-based QoS ensurance
> 
> Hi all,
> 
> It is worthy to predict the traffic change for avoiding the congestion and
> ensuring QoS. As the following figure shown, the AI system continuously
> collects link status data from the network. This AI system is responsible for two
> things. One is monitoring and predicting the traffic on each link and the other
> one is calculating the usable route for any pair of nodes according to the
> prediction and current link status. Assume that there is a VPN named VPN_S_D
> from node S to D which pass through S-A-B-C-D. According to the prediction,
> there will be a huge traffic flow from node A to C in the future 10 min. The
> traffic will increase the end-to-end delay from S to D so that the QoS will not be
> ensured.
> 
>                 \/     \/
>                 /\     /\			 ----->
> There are at least two solutions. one is modifying the object's configuration to
> avoid the potential congestion. For example, we modify the VPN_S_D's route
> from S-A-B-C-D to S-I-J-K-D. The other one is restricting non-object's
> transmission so that to protect the object's QoS. For example, we increase the
> reserved bandwidth of VPN_S_D or modify the route of non-object flows from
> S-A-B-C-D to S-I-J-K-D therefore most of the traffic will not affect VPN_S_D.
> 
> Challenge 1 is the AI prediction and autonomic decision should be a quick
> response. The whole process must be finished before the congestion happens
> meanwhile the AI system is meaningless. The question is how to implement
> such quick response?
> 
> Challenge 2 is whether there is existing protocols which can support high
> frequency measurement? Because AI system needs to be fed with continuous
> link status data. And the real-time data need to be captured frequently
> otherwise the route change will be worthless. I think the protocols that support
> high frequency measurement and data collection may become one of our
> focuses.
> 
> regards,
> 
>

---

From: yanshen <[email-masked]>
Date: Thu, 29 Jun 2017 13:13:54 +0000

Hi Sheng,

Thanks for your response. 

I think there is a question that should be considered. What can be predicted and what cannot? Take the traffic as example. It can be divided into two parts. On one hand, there should be something certain that roughly generate predictable result. One the other hand, there must be something uncertain that unpredictable (such as physical link failure or the burst caused by hidden reasons). For the predictable part, we can use AI method (e.g. Neural Network) to module the traffic according to the statistics. For the unpredictable part, I think it is meaningless to concern because these have been beyond the scope that network and AI technology can cover. IT IS HARD TO SOLVE A HIGHER DIMENSION PROBLEM BY LOWER DIMENSION METHOD. In other word, these type of unpredictable problem should be solve by some other method but AI can join in the process, for example, to launch the backup strategies. Is it reasonable?

The granularity should depend on the specific scenario. For example, if I focus on the quality of some route, the prediction should be based on the interface level. If I focus on the security, such as we use the traffic to judge whether there is data leak, the granularity should be based on the whole scope in focus.

BTW, you give a hint that may become the next high value use case. Thank you very much.

Yansen

> From: Sheng Jiang
> Sent: Thursday, June 29, 2017 9:49 AM
> To: yanshen <[email-masked]>; [email-masked]
> Subject: RE: Network AI Use case: Predicting-based QoS ensurance
> 
> Hi, Yanshen,
> 
> Thanks for the use case. This use case by itself is useful and attractive. I also
> agree the two challenge you like are something that is worth working on.
> However, this use case is based on the precondition of accurate traffic prediction.
> As far as we know, there are many existing efforts on the prediction for the
> traffic changes. However, for my understanding, although most of existing
> efforts does not have the ability to do traffic prediction, there are many
> limitations. I don't think the current result of traffic prediction could be mature
> enough to support your use case. So far, the traffic prediction can only have good
> result on certain conditions, such as on limited interface or devices, for certain
> type of traffic models.
> 
> So far, there are at least three aspects that the traffic prediction needs to be
> largely improved: a) granularity b) error range or accurate c) calculation time
> assumption d) universal validity, independent from certain topology or certain
> traffic model, including prediction on small traffics, reduce the influence of traffic
> burst, etc.
> 
> Regards,
> 
> Sheng
> 
> > I try to list some valuable use cases that the AI technology may play
> > a role in the network management and optimization.
> >
> > It is worthy to predict the traffic change for avoiding the congestion
> > and ensuring QoS. As the following figure shown, the AI system
> > continuously collects link status data from the network. This AI
> > system is responsible for two things. One is monitoring and predicting
> > the traffic on each link and the other one is calculating the usable
> > route for any pair of nodes according to the prediction and current
> > link status. Assume that there is a VPN named VPN_S_D from node S to D
> > which pass through S-A-B-C-D. According to the prediction, there will
> > be a huge traffic flow from node A to C in the future 10 min. The
> > There are at least two solutions. one is modifying the object's
> > configuration to avoid the potential congestion. For example, we
> > modify the VPN_S_D's route from S-A-B-C-D to S-I-J-K-D. The other one
> > is restricting non-object's transmission so that to protect the
> > object's QoS. For example, we increase the reserved bandwidth of
> > VPN_S_D or modify the route of non-object flows from S-A-B-C-D to S-I-J-K-D
> therefore most of the traffic will not affect VPN_S_D.
> >
> > Challenge 1 is the AI prediction and autonomic decision should be a
> > quick response. The whole process must be finished before the
> > congestion happens meanwhile the AI system is meaningless. The
> > question is how to implement such quick response?
> >
> > Challenge 2 is whether there is existing protocols which can support
> > high frequency measurement? Because AI system needs to be fed with
> > continuous link status data. And the real-time data need to be
> > captured frequently otherwise the route change will be worthless. I
> > think the protocols that support high frequency measurement and data
> > collection may become one of our focuses.
> >
> > regards,
> >
> >