Subject: Re: [Idnet] Architecture and standard opportunities of IDN

From: Sheng Jiang <[email-masked]>
Date: Tue, 1 Aug 2017 08:14:23 +0000

Hi, Kim,

Agree your concern regarding to Reinforcement Learning. Actually, it was just a symbol in the slide to represent machine learning in general.

The current plan, if workable, is to organize a dedicated session in NMRG, IETF100, for applying AI into network management. You are more than welcome to take part in.

Regards,

Sheng

From: 김민석 [mailto:[email-masked]]
Sent: Monday, July 31, 2017 10:06 AM
To: Sheng Jiang <[email-masked]>; [email-masked]
Cc: yanshen <[email-masked]>
Subject: RE: Architecture and standard opportunities of IDN

Dear Sheng,

Thank  you for giving us last IDNET side-meeting in Prague.

Many guys mentioned data-set problems in the IDN archetecture, so I strongly agree with these kinds of opinions.

BUT, we should carefully consider a ML-based algorithm set-up for Reinforcement Learning (RL) that you described in the other slide. Reward is one of the components in RL algorithm so that we should take all of the options of RL into consideration, such as which action we can take in the loop, which state should be optimized for reward, how policy will cover and dominate for learning process.

I submitted and presented our related internet draft based on RL in NMRG, Prague so that it might help to figure out more specifically. Hopefully. we are additionally able to discuss related RL setting-up more by email discussion or next meeting.

Best,

Min-Suk Kim

Senior Researcher / Ph.D.

________________________________
보낸 사람 : "Sheng Jiang" <[email-masked]<mailto:[email-masked]>>
보낸 날짜 : 2017-07-26 20:38:50 ( +0900 )
받는 사람 : [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
참조 : yanshen <[email-masked]<mailto:[email-masked]>>
제목 : [Idnet] Architecture and standard opportunities of IDN

Hi, all,

Please find the below figure that I shared in the IDN discussion meeting last week in Prague. This illustrates the IDN architecture in a very generic way. The on-site participants had the very similar understanding that the upper left box – the unified and selected data is should be the prior work towards standardization. Also, the participants shared the same opinion that the data structure may be various among use cases. So, we should keep discussing on use cases with the target to converge on one or two significant and specific use cases.

Regards,

Sheng

---

From: 김민석 <[email-masked]>
Date: Tue, 1 Aug 2017 09:25:26 +0000

Dear Yansen,

Thoes are good key points!

We firslty need to set real networking model to collect data (Qos Data), then making a scenario which component of data-set can be applied with ML algorithms such as RL, RNN and etc.

It's a little hard to consider key characters for ML-based data structure to be clear, but I can make couple of opinions to the key characters of structure in aspect of ML algorithm.

1) QoS may be convert to reward for RL, but it needs learning processing time. We can set an initial period to collect information for learning process. In general, an initial period should be defined by random process in RL. After then, the data will be continuously updated.

2) Set a policy. Policy is important points for RL. It has all of the next available values for actions so that the policy is a brain involved with opimized data.

3) We should make clear of purpose for "Source-destination". Sheng has a plan to organize a dedicated session in next NMRG meeting so it may be clear for intelligent management before establishment of ML-based data structures.

Regards,

Min-Suk Kim

________________________________
보낸 사람 : "yanshen" <[email-masked]>
보낸 날짜 : 2017-07-31 22:15:37 ( +09:00 )
받는 사람 : 김민석 <[email-masked]>, Pedro Martinez-Julia <[email-masked]>
참조 : [email-masked] <[email-masked]>
제목 : RE: Architecture and standard opportunities of IDN

Dear Kim,

May you have seen that we have a consensus on the potential standardization point of data and data format.

In your experience, what the structure or feature that ML-based algorithm potentially tend to? If we have a consensus and full view in this question, the data structure may be clear.

For example, if we want to train a model with QoS data (or reward). Assume that these data can be captured via some method. Some following key characters of data structure may be needed:

-          QoS data, such as delay. It may be organized with time series/quantized (the “reward”) / ...

-          Starting-ending time. It is significant and should be differentiated.

-          Time interval. We can capture the delay values in different frequency. High frequency time series delay value may be “down-sampled” when it is used in training low frequency model.

-          Source-destination. Obviously.

-          TBD

Any other keys?

Yansen

Dear Sheng,

Best,

Min-Suk Kim

Hi, all,

Regards,

Sheng

---

From: Jérôme François <[email-masked]>
Date: Tue, 1 Aug 2017 18:28:00 +0200

Hi,

Le 31/07/2017 à 14:25, yanshen a écrit :
>> Le 27/07/2017 à 02:45, Pedro Martinez-Julia a écrit :
>>> Dear Sheng,
>>>
>>> First of all, and considering my recent experience with the Network
>>> Slicing work, I think we have some aspects of our work that are
>>> probably essential for the IETF and network technology in general:
>>>
>>> - As you mention and all of us know well, we need to standardize the
>>>   data format, so it is a good opportunity to define some ontology and
>>>   the corresponding YANG model that structures such data.
>> Do you imagine kind of a transformation process in the architecture as data to be
>> used can come with pre-existing various data formats ?
> My two cents. I ever think about that. The proposed data format should be easily "re-constructed" via existing data formats. The new attributes in the new format should can be auto-filled. Like the transformation of "XML schema" to "YANG".
>
>>
So, listing "all" (the most used) data format (attributes and encoding)
should be a starting point

jerome

---

From: 김민석 <[email-masked]>
Date: Wed, 2 Aug 2017 00:44:45 +0000

Hi Sheng,

Sure, I will take a part in the draft if there is an available portion of ML to contribute.

We would discuss more in advance before next IETF meeting.

Best,

Min-Suk Kim

________________________________
보낸 사람 : "Sheng Jiang" <[email-masked]>
보낸 날짜 : 2017-08-01 17:14:47 ( +09:00 )
받는 사람 : 김민석 <[email-masked]>, [email-masked] <[email-masked]>
참조 : yanshen <[email-masked]>
제목 : RE: Architecture and standard opportunities of IDN

Hi, Kim,

Regards,

Sheng

Dear Sheng,

Best,

Min-Suk Kim

Hi, all,

Regards,

Sheng