Subject: [IPP] JPS3 comment on xxx-preferred

From: "Zehler, Peter" <[email-masked]>
Date: Sun, 15 Jan 2012 09:21:22 -0800

Why do we have a bunch of xxx-preferred attributes?  It complicates the
model with a bunch of attributes and is not general purpose enough to
address all the possible conflicting attributes and values. 

Is there any reason we cannot provide this functionality in a manner
similar to "unsupported-attributes".  The "unsupported-attributes" is
handled in IPP as an out of band group in an IPP response.   We could
extend the encoding of out of band attributes to include a new group for
"xxx-preferred" .  That way any substituted or conflicting attributes
and values could be returned for a Validate operation.

I would prefer to handle "xxx-preferred" using the collection syntax.  I
think it is easier and requires fewer changes to the IPP encoding.
Defining "attributes-preferred" as a collection of attributes and
permitting any template attributes to be included would be a simple
generalization.  It would also allow a client to pick those
attribute/values out to correct their request and not rely on printer
substitution.

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 16 Jan 2012 09:26:42 -0800

On Jan 15, 2012, at 9:21 AM, Zehler, Peter wrote:
> Why do we have a bunch of xxx-preferred attributes?  It complicates the model with a bunch of attributes and is not general purpose enough to address all the possible conflicting attributes and values.

The idea was to have a -preferred attribute for every job/document template attribute that could cause a conflict.

> ...
> I would prefer to handle “xxx-preferred” using the collection syntax.  I think it is easier and requires fewer changes to the IPP encoding.  Defining “attributes-preferred” as a collection of attributes and permitting any template attributes to be included would be a simple generalization.  It would also allow a client to pick those attribute/values out to correct their request and not rely on printer substitution.

I prefer (no pun intended) the collection attribute syntax rather than introducing another attribute group tag.  In the definition for IPP, would you envision this being returned in the unsupported attributes group or in the job/document attributes group?

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Michael Sweet <[email-masked]>
Date: Mon, 16 Jan 2012 10:39:52 -0800

Pete,

>From today's Cloud conference call we decided on "preferred-attributes" (collection) as the IPP attribute name and "PreferredElements" (group) for the XML schema.  The IPP attribute will be returned in the unsupported attributes group.

On Jan 15, 2012, at 9:21 AM, Zehler, Peter wrote:

> Is there any reason we cannot provide this functionality in a manner similar to “unsupported-attributes”.  The “unsupported-attributes” is handled in IPP as an out of band group in an IPP response.   We could extend the encoding of out of band attributes to include a new group for “xxx-preferred” .  That way any substituted or conflicting attributes and values could be returned for a Validate operation.
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701
>  
> 
> -- 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair