Subject: [IPP] JPS3 comment

From: "Zehler, Peter" <[email-masked]>
Date: Sat, 14 Jan 2012 05:05:38 -0800

Is the intention of "requesting-user-uri" to be used in place of
"requesting-user-name".  If it is, then section 5.1.5 should clarify.
If not, then section 5.1.5 should clarify what happens when both are
supplied.  I favor making it one or the other. 

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 16 Jan 2012 10:03:59 -0800

Pete,

On Jan 14, 2012, at 5:05 AM, Zehler, Peter wrote:
> Is the intention of “requesting-user-uri” to be used in place of “requesting-user-name”.  If it is, then section 5.1.5 should clarify.  If not, then section 5.1.5 should clarify what happens when both are supplied.  I favor making it one or the other.

requesting-user-uri is the more-specific (i.e. should be unique) value, but conceptually a client would supply both since the printer may not be able to map the URI to a human-readable name (like that provided in requesting-user-name...)

I can clarify this in the next update of JPS3.

> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701
>  
> 
> -- 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair