Subject: [IPP] JPS3 comment

From: "Zehler, Peter" <[email-masked]>
Date: Thu, 2 Feb 2012 05:23:01 -0800

Are there any requirements placed on the printer as to how long and in
what manner the operational attribute "document-password" must be
retained by the Printer?

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Thu, 2 Feb 2012 11:44:01 -0500

Hi Pete,

I suggest that "document-password" and "job-password"
MUST be retained until the Job enters history (that is, until
the Job can no longer be re-run if saved/proofed).

Does that make sense?

Cheers,
- Ira

On Thu, Feb 2, 2012 at 8:23 AM, Zehler, Peter <[email-masked]>wrote:

> what manner the operational attribute “document-password” must be retained
> by the Printer?****
>
> ** **
>
> ** **
>
> Peter Zehler
>
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701 ****
>
> ** **
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: "Zehler, Peter" <[email-masked]>
Date: Thu, 2 Feb 2012 08:52:08 -0800

I was under the impression that jobs that have reached a terminating
state (i.e., put on the JobHistory list) can be resubmitted.  I would
expect that the DocumentPassword would be tied to the retention of the
Document Data. When the document data is deleted so is the
DocumentPassword.  Printers that do not support resubmit would delete
the document data once the document has been processed or when the job
moves to JobHistory.  

Peter Zehler

From: Ira McDonald [mailto:[email-masked]] 
Sent: Thursday, February 02, 2012 11:44 AM
To: Zehler, Peter; Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] JPS3 comment

Hi Pete,

Does that make sense?

Cheers,
- Ira

On Thu, Feb 2, 2012 at 8:23 AM, Zehler, Peter <[email-masked]>
wrote:

 

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755 <tel:%28585%29%20265-8755> 
FAX: (585) 265-7441 <tel:%28585%29%20265-7441> 
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean.

---

From: Ira McDonald <[email-masked]>
Date: Thu, 2 Feb 2012 11:57:18 -0500

Hi Pete,

I agree with you.

I thought that as soon as the document data was discarded,
the Job would enter history - I thought that was the criteria
(losing document data or selected job processing attrributes)
for entering history.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Feb 2, 2012 at 11:52 AM, Zehler, Peter <[email-masked]>wrote:

> I was under the impression that jobs that have reached a terminating state
> (i.e., put on the JobHistory list) can be resubmitted.  I would expect that
> the DocumentPassword would be tied to the retention of the Document Data.
> When the document data is deleted so is the DocumentPassword.  Printers
> that do not support resubmit would delete the document data once the
> document has been processed or when the job moves to JobHistory.  ****
>
> ** **
>
> ** **
>
> Peter Zehler
>
> *From:* Ira McDonald [mailto:[email-masked]]
> *Sent:* Thursday, February 02, 2012 11:44 AM
> *To:* Zehler, Peter; Ira McDonald
> *Cc:* [email-masked]
> *Subject:* Re: [IPP] JPS3 comment****
>
> ** **
>
> Hi Pete,
>
> ****
> wrote:****
>  ****
>  ****
>  ****
> believed to be clean. ****
>
>
> https://www.pwg.org/mailman/listinfo/ipp****
>
> ** **
>

---

From: Michael Sweet <[email-masked]>
Date: Thu, 02 Feb 2012 11:39:07 -0800

Pete,

On Feb 2, 2012, at 5:23 AM, Zehler, Peter wrote:
> Are there any requirements placed on the printer as to how long and in what manner the operational attribute “document-password” must be retained by the Printer?

We don't currently spell it out, although I think I will need to add this along with a section in the security considerations.

IMHO you need the document-password as long as the document and job are retained in the printer - otherwise Resubmit-Job would not work.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair