Subject: [IPP] Media Color for MSN spec

From: "Petrie, Glen" <[email-masked]>
Date: Fri, 30 Mar 2012 09:48:39 -0700

All,

I have completed the table for media colors for the msn spec.   (I have
already provided the data to Mike.)   The (summary) table and set of
snap-shot images from a color application shows more details for each
color.

The actual colors are initially based on the government standard for
media color at http://www.gpo.gov/customers/text/vol11/123.htm.  Please
note that the l*ab value for buff has an error (the -25.7 should be
+25.7).  The remainder of the colors were either determined using the
government values as seed or based on the "actual color"

Please note that some of the colors in the table are for PAPER COLOR and
NOT JUST for the COLOR.  For example, Blue is for the paper color called
blue (from the government std) and not the color blue. 

Please examine the information.  If you or your company has better or
different values, I can make changes.

ftp://ftp.pwg.org/pub/pwg/ipp/whitepaper/PwgMsnColors-Summary.doc 

ftp://ftp.pwg.org/pub/pwg/ipp/whitepaper/PwgMsnColors-Summary.pdf 

ftp://ftp.pwg.org/pub/pwg/ipp/whitepaper/PwgMsnColors.djvu 

djvu reader/writer can be found at http://djvu.org/resources/ 

Color application is called OpenRGB found at  

http://www.logicol.com/index.php?X=ORGB&LogicolId=dd59d1b2413bd8744edc93
f54598a9ac 

glen

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 30 Mar 2012 09:59:56 -0700

FWIW, because MSN defines both colorant and media color names, I think it makes sense to add "paper" to any paper colors that are obviously different from the corresponding colorant/primary colors (like blue).

Any objections before I integrate Glen's table into the next draft?

On Mar 30, 2012, at 9:48 AM, Petrie, Glen wrote:

> All,
>  
> I have completed the table for media colors for the msn spec.   (I have already provided the data to Mike.)   The (summary) table and set of snap-shot images from a color application shows more details for each color.
>  
> The actual colors are initially based on the government standard for media color athttp://www.gpo.gov/customers/text/vol11/123.htm.  Please note that the l*ab value for buff has an error (the -25.7 should be +25.7).  The remainder of the colors were either determined using the government values as seed or based on the “actual color”
>  
> Please note that some of the colors in the table are for PAPER COLOR and NOT JUST for the COLOR.  For example, Blue is for the paper color called blue (from the government std) and not the color blue.
>  
> Please examine the information.  If you or your company has better or different values, I can make changes.
>  
> http://www.logicol.com/index.php?X=ORGB&LogicolId=dd59d1b2413bd8744edc93f54598a9ac
>  
>  
> glen
>  
> 
> -- 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: Michael Sweet <[email-masked]>
Date: Fri, 30 Mar 2012 13:26:35 -0700

[Adding IPP list]

On Mar 30, 2012, at 1:19 PM, Petrie, Glen wrote:
> Is it a good discussion item for the f2f.    If you think so, we may want to push this email to the mailing list.

Done!

> Green is problematic

All of these colors are problematic as they are approximations/generic name to value mappings. The key improvement, aside from defining standard sRGB reference values, is to support a naming convention that allows for a more accurate sRGB reference value.

> White is called White 82 (paper brightness 82); so from the table it is problematic

Actually if the name is White 82 (which should be converted to keyword form - maybe white-82?) then that isn't a conflict with "pure" white.

> Is it realistic to have colorant and paper color in the table.   For me at least, when I think of green paper, I think of a sort of light green (i.e. the stuff we all use in our office.  Yes there is a dark green paper too.)  Green colorant is really not the same color.   A simple test, if I print with a colorant of color Foo on to a media of the same color Foo, can I see what was printed?   In theory; no.   However, “every” blue paper is slightly different.

Just as every vendors' colorant is slightly different.

> Another consideration is that table really is a mix of colorant and media.   I don’t really know of a magenta media

It is usually marketed as pink/fluorescent pink.

> and I don’t know of a goldenrod colorant (maybe some highlight or spot color).  I would hoping we could leave out highlight/spot colors since most are “made by hand” to met a specific customer’s specification (i.e. Coca-Cola Red is a specific L*ab value not just red).   The color table (both tables) should be extensible. 

That's why we have the user/vendor naming conventions that include sRGB(A) reference values.

> From: Michael Sweet [mailto:[email-masked]] 
> Sent: Friday, March 30, 2012 12:39 PM
> To: Petrie, Glen
> Subject: Re: [IPP] Media Color for MSN spec
>  
> Glen,
>  
> This is actually something we talked about briefly at the last F2F (though I did not capture it in the minutes, grumble grumble...) - RFC 3805 refers back to MSN (indirectly, I forget exactly) in order to pick up ISO and other color names for colorants and media.
>  
> So I will clarify the intro text and table, and bring up the color naming issue (where there are conflicts) at the F2F. So far blue and yellow are the only colors I think are problematic, but I'll continue to look at it while I merge your stuff in...
>  
> The issue with two tables is the overlap - white, black, orange, magenta, red, and green (at least) are both colorant and media colors and we can reasonably use the same names and sRGB values for both. Better, I think, to simply note the few colors where we chose one name over the other.
>  
>  
> On Mar 30, 2012, at 12:05 PM, Petrie, Glen wrote:
> 
> 
> Mike,
>  
> I did not realize it was colorant and media color.   I could add colorant values back in (i.e. blue color).
>  
> A longer term solution is have two table.
>  
>  
> Glen
>  
>  
> From: Michael Sweet [mailto:[email-masked]] 
> Sent: Friday, March 30, 2012 10:00 AM
> To: Petrie, Glen
> Cc: [email-masked]
> Subject: Re: [IPP] Media Color for MSN spec
>

---

From: Michael Sweet <[email-masked]>
Date: Fri, 30 Mar 2012 13:51:06 -0700

All,

Here are some "reference" pages I pulled from a search on staples.com for "colored paper"...

Solid paper colors which match up to what I'd expect for a colorant color:

	http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Assorted-Colors/product_733088

Solid paper colors which map to alternate colors, some of which match what you might use for a colorant color (for purposes of UI...):

	http://www.staples.com/Staples-Pastel-Colored-Copy-Paper-11-x-17-Assorted-Colors/product_679462

Neon colors:

	http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Neon-Assorted/product_733097

And even within a single supplier, you'll find multiple products with the same color name but vastly different actual colors:

	GREEN

	http://www.staples.com/Staples-Brights-Colored-Paper-8-1-2-x-11-Green-Ream/product_490879
	http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Green/product_733093

	ORANGE

	http://www.staples.com/Staples-Brights-Colored-Paper-8-1-2-x-11-Orange-Ream/product_490881
	http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Orange/product_733086

Then there are names we don't have (again from the same Staples search results for "colored paper"):

	bright white (synonym for current "white"?)
	canary
	cherry
	cream
	fuschia
	grape
	juniper
	lilac
	orchid
	purple
	salmon
	teal

Finally, there are the vendor adjectives ("Pulsar Pink", "Solar Yellow", etc.), but I feel safe ignoring those for this spec... :)

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Petrie, Glen" <[email-masked]>
Date: Fri, 30 Mar 2012 14:27:34 -0700

Mike

Thanks for jogging my memory on some of the more vivid colored media.  I
still not sure colorant and media with the same color name are the same
color.  I looked at these and others; most do not give rgb values and in
many cases a color name like "green" is used for several different
"green colored" media.   

As you stated in the last email "magenta colored media" is sold as
pink/fluorescent-pink.  So do we have magenta colorant and
pink/fluorescent-pink media; even thought they are the """"same""""
color.   Is there a "well-known" list of colored media names?

What I did not consider at the time was investigating the actual paper
manufactures (that would a shorter list) instead of distributor or
retailers.    Note that distributors and retailers give product
"interesting name" for selling/marketing purposes which increases the
problem.

Perhaps, as time, permits I can contact one or more manufactures to see
if can provide rgb values for the various colored and white media.
Short of that, I have a spectrometer that I could actually measure
samples to determine a media rgb value for each color media we decide to
list. 

I would hope any list for colorant is short(er) and fairly well known
even if there are variations in the actual rgb value of a specific
colorant color.

Glen

 

________________________________

From: Michael Sweet [mailto:[email-masked]] 
Sent: Friday, March 30, 2012 1:51 PM
To: Petrie, Glen
Cc: <[email-masked]>
Subject: Re: [IPP] Media Color for MSN spec

All,

Here are some "reference" pages I pulled from a search on staples.com
for "colored paper"...

Solid paper colors which match up to what I'd expect for a colorant
color:

http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Assorted-Colo
rs/product_733088

Solid paper colors which map to alternate colors, some of which match
what you might use for a colorant color (for purposes of UI...):

http://www.staples.com/Staples-Pastel-Colored-Copy-Paper-11-x-17-Assorte
d-Colors/product_679462

Neon colors:

http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Neon-Assorted
/product_733097

And even within a single supplier, you'll find multiple products with
the same color name but vastly different actual colors:

            GREEN

http://www.staples.com/Staples-Brights-Colored-Paper-8-1-2-x-11-Green-Re
am/product_490879

http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Green/product
_733093

            ORANGE

http://www.staples.com/Staples-Brights-Colored-Paper-8-1-2-x-11-Orange-R
eam/product_490881

http://www.staples.com/Staples-Brights-24-lb-Colored-Paper-Orange/produc
t_733086

Then there are names we don't have (again from the same Staples search
results for "colored paper"):

            canary

            cherry

            cream

            fuschia

            grape

            juniper

            lilac

            orchid

            purple

            salmon

            teal

Finally, there are the vendor adjectives ("Pulsar Pink", "Solar Yellow",
etc.), but I feel safe ignoring those for this spec... :)

---

From: Michael Sweet <[email-masked]>
Date: Fri, 30 Mar 2012 14:50:37 -0700

Glen,

On Mar 30, 2012, at 2:27 PM, Petrie, Glen wrote:
> Mike
>  
> Thanks for jogging my memory on some of the more vivid colored media.  I still not sure colorant and media with the same color name are the same color.  I looked at these and others; most do not give rgb values and in many cases a color name like “green” is used for several different “green colored” media.  

Right.  IMHO our focus for the MSN color names should be on identifying common or primary colors with simple variations (I like light, dark, and clear) along with the reference sRGB values. Ultimately a client should be able to present UI with both the name and the reference color to facilitate media selection or monitoring of printer supplies.

We shouldn't get stuck on having exact matches for color since a) that isn't feasible given the number of different media and colorants we would need to list and b) the viewing conditions and technologies are different enough that the sRGB value displayed on-screen is never going to exactly match the media or colorant anyways.

> As you stated in the last email “magenta colored media” is sold as pink/fluorescent-pink.  So do we have magenta colorant and pink/fluorescent-pink media; even thought they are the “”””same”””” color.   Is there a “well-known” list of colored media names?

There are several :) including the specs we already reference. However, none of them exactly match what is manufactured today and due to the issues I mentioned above I don't think it matters that we have an exhaustive list or "accurate" sRGB reference values for the non-primary colors.

> Perhaps, as time, permits I can contact one or more manufactures to see if can provide rgb values for the various colored and white media.  Short of that, I have a spectrometer that I could actually measure samples to determine a media rgb value for each color media we decide to list.

Aside from maybe Teal in my list below (which doesn't have a close match), I don't think we need to extend our current list. New colors can be added using our standard naming convention with sRGB reference values, and I have no objection to listing common aliases for some colors, e.g., Purple -> Dark Magenta, Fuschia/Fluorescent Pink -> Magenta, Salmon -> Light Pink, etc. like we do for media sizes.

We could also allow <standardcolorname>_RRGGBB[AA] to identify a specific version of a named color - that would allow for localization using the standard names but presentation using the custom color.

Thoughts?

---

From: "Petrie, Glen" <[email-masked]>
Date: Fri, 30 Mar 2012 15:10:10 -0700

Mike, 

I agree with your points you make below   Given has a chance, any
discussion or specification related to color quickly gets out of hand.
So keeping the list short and color values "representative" is the best
course of action.  

Glen

From: Michael Sweet [mailto:[email-masked]] 
Sent: Friday, March 30, 2012 2:51 PM
To: Petrie, Glen
Cc: [email-masked]
Subject: Re: [IPP] Media Color for MSN spec

Glen,

	Mike

	Thanks for jogging my memory on some of the more vivid colored
media.  I still not sure colorant and media with the same color name are
the same color.  I looked at these and others; most do not give rgb
values and in many cases a color name like "green" is used for several
different "green colored" media.   

Right.  IMHO our focus for the MSN color names should be on identifying
common or primary colors with simple variations (I like light, dark, and
clear) along with the reference sRGB values. Ultimately a client should
be able to present UI with both the name and the reference color to
facilitate media selection or monitoring of printer supplies.

We shouldn't get stuck on having exact matches for color since a) that
isn't feasible given the number of different media and colorants we
would need to list and b) the viewing conditions and technologies are
different enough that the sRGB value displayed on-screen is never going
to exactly match the media or colorant anyways.

	As you stated in the last email "magenta colored media" is sold
as pink/fluorescent-pink.  So do we have magenta colorant and
pink/fluorescent-pink media; even thought they are the """"same""""
color.   Is there a "well-known" list of colored media names?

There are several :) including the specs we already reference. However,
none of them exactly match what is manufactured today and due to the
issues I mentioned above I don't think it matters that we have an
exhaustive list or "accurate" sRGB reference values for the non-primary
colors.

	Perhaps, as time, permits I can contact one or more manufactures
to see if can provide rgb values for the various colored and white
media.  Short of that, I have a spectrometer that I could actually
measure samples to determine a media rgb value for each color media we
decide to list.

Aside from maybe Teal in my list below (which doesn't have a close
match), I don't think we need to extend our current list. New colors can
be added using our standard naming convention with sRGB reference
values, and I have no objection to listing common aliases for some
colors, e.g., Purple -> Dark Magenta, Fuschia/Fluorescent Pink ->
Magenta, Salmon -> Light Pink, etc. like we do for media sizes.

We could also allow <standardcolorname>_RRGGBB[AA] to identify a
specific version of a named color - that would allow for localization
using the standard names but presentation using the custom color.

Thoughts?

---

From: Ira McDonald <[email-masked]>
Date: Sat, 31 Mar 2012 11:21:10 -0400

Hi,

Although it seems suitable, separating color names/values
into two tables (media and colorant) would be a bad idea
because ISO DPA (ISO 10175), Printer MIB v2 (RFC 3805),
IPP/1.1 (RFC 2911), and CIP4 JDF all conflate/combine
the names into a single list.  Two lists in MSN would break
some of the mixed use (e.g., in RFC 3805) in different
properties and would make job ticket mapping much harder.

My two cents.

Cheers,
- Ira
Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Fri, Mar 30, 2012 at 6:10 PM, Petrie, Glen <[email-masked]>wrote:

>  Mike, ****
> ** **
> discussion or specification related to color quickly gets out of hand.   So
> keeping the list short and color values “representative” is the best course
> of action.  ****
>
> ** **
>
> Glen****
>
> ** **
>
> ** **
>  ------------------------------
>
> *From:* Michael Sweet [mailto:[email-masked]]
> *Sent:* Friday, March 30, 2012 2:51 PM
> *To:* Petrie, Glen
> *Cc:* [email-masked]
> *Subject:* Re: [IPP] Media Color for MSN spec****
>
> ** **
>
> Glen,****
>
> ** **
>
> On Mar 30, 2012, at 2:27 PM, Petrie, Glen wrote:****
>
> ****
>
> Mike********
>
> ** ******
>
> many cases a color name like “green” is used for several different “green
> colored” media.   ****
>
>  ** **
>  ****
>
> clear) along with the reference sRGB values. Ultimately a client should be
> able to present UI with both the name and the reference color to facilitate
> media selection or monitoring of printer supplies.****
>
> ** **
>
> isn't feasible given the number of different media and colorants we would
> need to list and b) the viewing conditions and technologies are different
> enough that the sRGB value displayed on-screen is never going to exactly
> match the media or colorant anyways.****
>
> ** **
>
> ****
>
> As you stated in the last email “magenta colored media” is sold as
> pink/fluorescent-pink media; even thought they are the “”””same”””” color.
>   Is there a “well-known” list of colored media names?****
>
>  ** **
>  ****
>
> none of them exactly match what is manufactured today and due to the issues
> I mentioned above I don't think it matters that we have an exhaustive list
> or "accurate" sRGB reference values for the non-primary colors.****
>
> ** **
>
> ****
>
> Perhaps, as time, permits I can contact one or more manufactures to see if
> can provide rgb values for the various colored and white media.  Short of
> that, I have a spectrometer that I could actually measure samples to
> determine a media rgb value for each color media we decide to list.****
>
>  ** **
>  ****
>
> Aside from maybe Teal in my list below (which doesn't have a close match),
> I don't think we need to extend our current list. New colors can be added
> using our standard naming convention with sRGB reference values, and I have
> no objection to listing common aliases for some colors, e.g., Purple
> -> Dark Magenta, Fuschia/Fluorescent Pink -> Magenta, Salmon -> Light Pink,
> etc. like we do for media sizes.****
>
> ** **
>
> We could also allow <standardcolorname>_RRGGBB[AA] to identify a specific
> version of a named color - that would allow for localization using the
> standard names but presentation using the custom color.****
>
> ** **
>
> Thoughts?****
>
> ** **
>
> ________________________________________________________________________**
> **
>
> Michael Sweet, Senior Printing System Engineer, PWG Chair****
>
> ** **
>
> --
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>