Subject: [IPP] WG Last Call - IPP Job and Printer Extensions - Set 3 (JPS3) (April 9 through April 18, 2012)

From: Michael Sweet <[email-masked]>
Date: Mon, 09 Apr 2012 17:13:45 -0700

All,

This message initiates the IPP Working Group last call of the IPP Job and Printer Extensions - Set 3 (JPS3) specification that has been in extended development since last year. The latest stable draft can be found here:

	ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20120409.docx
	ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20120409.pdf
	ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20120409-rev.pdf

Please send all feedback to the IPP mailing list (reply-all works fine for this) and it will be collected and processed as quickly as possible. Our intent is to move JPS3 to PWG Last Call to span the April 2012 F2F.

Thank you!

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Zehler, Peter" <[email-masked]>
Date: Thu, 19 Apr 2012 10:14:11 -0700

Xerox has a strong objection to making the value 'process-monochrome"
REQUIRED for color printers.  We want it changed to OPTIONAL.  For laser
printers, process monochrome function causes trouble with drums and/or
developers.  It also can cause a degradation in print quality.   

Peter Zehler

Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Monday, April 09, 2012 8:14 PM
To: <[email-masked]>
Subject: [IPP] WG Last Call - IPP Job and Printer Extensions - Set 3
(JPS3) (April 9 through April 18, 2012)

All,

This message initiates the IPP Working Group last call of the IPP Job
and Printer Extensions - Set 3 (JPS3) specification that has been in
extended development since last year. The latest stable draft can be
found here:

ftp://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippjobprinterext3v10-20120409-rev.pd
f

Please send all feedback to the IPP mailing list (reply-all works fine
for this) and it will be collected and processed as quickly as possible.
Our intent is to move JPS3 to PWG Last Call to span the April 2012 F2F.

Thank you!

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

believed to be clean.

---

From: Michael Sweet <[email-masked]>
Date: Thu, 19 Apr 2012 10:46:22 -0700

Pete,

I've received the same concerns from a couple people offline (yes, I asked them to post their comments to the list..) - changed process-monochrome to OPTIONAL but left monochrome, color, and auto as REQUIRED. I have also added a note for this explaining why process-monochrome is OPTIONAL.

On Apr 19, 2012, at 10:14 AM, Zehler, Peter wrote:

> Xerox has a strong objection to making the value ‘process-monochrome” REQUIRED for color printers.  We want it changed to OPTIONAL.  For laser printers, process monochrome function causes trouble with drums and/or developers.  It also can cause a degradation in print quality.   
>  
>  
> Peter Zehler
> 
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Sweet
> Subject: [IPP] WG Last Call - IPP Job and Printer Extensions - Set 3 (JPS3) (April 9 through April 18, 2012)
>  
> All,
>  

_________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: James Cloos <[email-masked]>
Date: Thu, 19 Apr 2012 17:30:50 -0400

Apologies for the stupid question, but I couldn't find an explanation....

For a colour printer, what is the difference between monochrome and
process-monochome?

-JimC
-- 
James Cloos <[email-masked]>         OpenPGP: 1024D/ED7DAEA6

---

From: Michael Sweet <[email-masked]>
Date: Thu, 19 Apr 2012 17:11:35 -0700

James,

> For a colour printer, what is the difference between monochrome and

monochrome is black using 1 color (black).

process-monochrome is black using many colors (typically black plus varying amounts of cyan, magenta, and yellow, although it can also apply to black from just cyan, magenta, and yellow).

---

From: "William Wagner" <[email-masked]>
Date: Thu, 19 Apr 2012 20:55:33 -0400

Michael,
My memory might be off, but although the distinction between monochrome and
process monochrome as referring to marking with a single colorant versus
obtaining that color from multiple colorants is right, I thought that we
used the term 'monochrome' rather than just 'black' to refer to one-color
printing, where that color was usually but not necessarily black. But
perhaps it is an unimportant distinction.
Thanks,
Bill Wagner

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
Sweet
Sent: Thursday, April 19, 2012 8:12 PM
To: James Cloos
Cc: [email-masked]
Subject: Re: [IPP] WG Last Call - IPP Job and Printer Extensions - Set 3
(JPS3) (April 9 through April 18, 2012)

James,

process-monochrome is black using many colors (typically black plus varying
amounts of cyan, magenta, and yellow, although it can also apply to black
from just cyan, magenta, and yellow).

--
This message has been scanned for viruses and dangerous content by
MailScanner, and is believed to be clean.

---

From: Michael Sweet <[email-masked]>
Date: Thu, 19 Apr 2012 18:02:29 -0700

Bill,

We do, in fact, define "monochrome" as being 1 colorant, typically black. A vendor might choose to implement an IPP Printer that uses blue ink, for example, but I expect the mainstream usage to be black ink.

---

From: "Zehler, Peter" <[email-masked]>
Date: Fri, 20 Apr 2012 02:38:37 -0700

Perhaps the description of 'process-monochrome' and 'process-bi-level'
could include the clarification  "(more than 1 colorant)".

Peter Zehler

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Thursday, April 19, 2012 9:02 PM
To: William Wagner
Cc: [email-masked]
Subject: Re: [IPP] WG Last Call - IPP Job and Printer Extensions - Set 3
(JPS3)(April 9 through April 18, 2012)

Bill,

We do, in fact, define "monochrome" as being 1 colorant, typically
black. A vendor might choose to implement an IPP Printer that uses blue
ink, for example, but I expect the mainstream usage to be black ink.

On Apr 19, 2012, at 5:55 PM, William Wagner wrote:

> Michael,
> My memory might be off, but although the distinction between 
> monochrome and process monochrome as referring to marking with a 
> single colorant versus obtaining that color from multiple colorants is

> right, I thought that we used the term 'monochrome' rather than just 
> 'black' to refer to one-color printing, where that color was usually 
> but not necessarily black. But perhaps it is an unimportant
distinction.
> Subject: Re: [IPP] WG Last Call - IPP Job and Printer Extensions - Set

> 3
> process-monochrome is black using many colors (typically black plus 
> varying amounts of cyan, magenta, and yellow, although it can also 
> apply to black from just cyan, magenta, and yellow).
>

---

From: Michael R Sweet <[email-masked]>
Date: Fri, 20 Apr 2012 07:39:20 -0700

Works for me!

Sent from my iPhone

---

From: "Petrie, Glen" <[email-masked]>
Date: Fri, 20 Apr 2012 08:04:58 -0700

Monochrome is defined as "the range of shades of a single Color to
white" and not a single colorant and not just black.   

In the days when we have just black/white printers, monochrome came to
mean half-tone printing using the black colorant only; which is really
binary printing (one colorant and the white of the media) using halftone
technques to simulate the color "gray" (shading) versus true monochrome
printing that prints using various shades of the actual color gray.

Today, """"Black"""" monochrome printing is printing the color gray over
the range from black to white.  Since gray is produced using all
colorants, it is processed-monochrome that is important.

Another common case of actually monochrome is Sepia.   The color sepia
is not a single colorant but a single composite color (a combination of
rgb).   

So if you want a definition using a single colorant, then this binary
printing using halftoning to simulation "shades" (intensity variations
of the colorant).
 
Glen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael Sweet
Sent: Thursday, April 19, 2012 6:02 PM
To: William Wagner
Cc: [email-masked]
Subject: Re: [IPP] WG Last Call - IPP Job and Printer Extensions - Set 3
(JPS3)(April 9 through April 18, 2012)

Bill,

> My memory might be off, but although the distinction between
monochrome and
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
Michael
3
> process-monochrome is black using many colors (typically black plus
varying

---

From: "Petrie, Glen" <[email-masked]>
Date: Fri, 20 Apr 2012 08:17:04 -0700

In fact,  I believe we should introduce a new term

Color Printing
Mono-Chrome Printing
Mono-Colorant Printing
B/W-Printing

This is much clearer 

Glen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Petrie, Glen
Sent: Friday, April 20, 2012 8:05 AM
To: Michael Sweet; William Wagner
Cc: [email-masked]
Subject: RE: [IPP] WG Last Call - IPP Job and Printer Extensions - Set
3(JPS3)(April 9 through April 18, 2012)

 
Glen

-----Original Message-----

Bill,

monochrome and
Michael
3
varying

---

From: Randy Turner <[email-masked]>
Date: Fri, 20 Apr 2012 08:43:17 -0700

Amazing, I can remember this argument in 1993/1994 when we were working on the Printer MIB…

I guess there are some questions which will never have a definitive answer… :)

R.

---

From: Michael Sweet <[email-masked]>
Date: Fri, 20 Apr 2012 09:37:19 -0700

Glen,

> white" and not a single colorant and not just black.

As defined in JPS3, monochrome is output using a single colorant. This was the definition that everyone agreed to 2 years ago after hours of discussion at the December 2010 F2F.

"process-monochrome" was added at that meeting to address the many use cases where a vendor might want to use multiple colorants to produce a single color - typically black but it could be any color/effect.

Further definition/clarification about halftoning and continuous tone printing was deemed too implementation-specific to be added - the compromise was to add bi-level and process-bi-level for threshold output with monochrome and process-monochrome mapping to grayscale/shaded output.

---

From: Michael Sweet <[email-masked]>
Date: Fri, 20 Apr 2012 09:38:57 -0700

Glen,

> In fact,  I believe we should introduce a new term

It wasn't clearer when this was brought up 2 years ago...