Subject: Re: [IPP] WS-discovery binding for IPP Everywhere

From: Michael Sweet <[email-masked]>
Date: Fri, 06 Apr 2012 08:25:35 -0700

Justin,

Can you provide a schema file that I can put up on the PWG web site?  The namespace should be "http://www.pwg.org/schemas/2012/4/ipp-everywhere" to match the form we use for Semantic Model schema.

Thanks!

On Feb 10, 2012, at 10:20 AM, Justin Hutchings <[email-masked]> wrote:

> All,
> Per the discussion at this week’s face to face, I mocked up an example of how to do discovery of an IPP endpoint using ws-discovery. Since WS-discovery doesn’t especially care what matching semantic model is used, I would propose that we just reuse the LDAP model to simplify the development experience for people. The only unique descriptions we’ll need are to establish some keywords that describe the different IPP protocols, like IPP Everywhere print, scan, fax, etc. That should be pretty trivial, as we just need to name them and publish a schema.
>  
> How does this look?
>  
> Thanks!
> Justin
>  
> Example probe message:
> <s:Envelope
>      xmlns:a="http://schemas.xmlsoap.org/ws/2004/08/addressing"
>      xmlns:d="http://schemas.xmlsoap.org/ws/2005/04/discovery"
>      xmlns:ippe="http://pwg.org/2012/08/ipp-everywhere"
>      xmlns:s="http://www.w3.org/2003/05/soap-envelope" >
>    <s:Header>
>      <a:Action>
>        http://schemas.xmlsoap.org/ws/2005/04/discovery/Probe
>      </a:Action>
>      <a:MessageID>
>        uuid:0a6dc791-2be6-4991-9af1-454778a1917a
>      </a:MessageID>
>      <a:To>urn:schemas-xmlsoap-org:ws:2005:04:discovery</a:To>
>    </s:Header>
>    <s:Body>   
>      <d:Probe>
>        <d:Types>ippe:Print</d:Types>
>        <d:Scopes
>     MatchBy="http://schemas.xmlsoap.org/ws/2005/04/discovery/ldap" >
>          ldap:///ou=engineering,o=examplecom,c=us
>        </d:Scopes>
>      </d:Probe>
>    </s:Body>
>  </s:Envelope>
>  
>  
>  
>  
> Justin Hutchings | Program Manager | Windows\DNT\DeviceConnectivity::Printing and Imaging
>  
> 
> -- 
> This message has been scanned for viruses and 
> dangerous content by MailScanner, and is 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]
> https://www.pwg.org/mailman/listinfo/ipp

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Justin Hutchings <[email-masked]>
Date: Fri, 20 Apr 2012 21:03:04 +0000

Hi Michael,
I'm sorry, I don't know how to do that. The ippe:Print is a QName, but I frankly have no idea how to build an XSD that establishes a well defined set of QNames.

Perhaps someone else in the group has more expertise in this space? There's only 1 QName to document, AFAIK.

Thanks
Justin

From: Michael Sweet [mailto:[email-masked]]
Sent: Friday, April 06, 2012 8:26 AM
To: Justin Hutchings
Cc: [email-masked]
Subject: Re: [IPP] WS-discovery binding for IPP Everywhere

Justin,

Thanks!

On Feb 10, 2012, at 10:20 AM, Justin Hutchings <[email-masked]<mailto:[email-masked]>> wrote:

All,
Per the discussion at this week's face to face, I mocked up an example of how to do discovery of an IPP endpoint using ws-discovery. Since WS-discovery doesn't especially care what matching semantic model is used, I would propose that we just reuse the LDAP model to simplify the development experience for people. The only unique descriptions we'll need are to establish some keywords that describe the different IPP protocols, like IPP Everywhere print, scan, fax, etc. That should be pretty trivial, as we just need to name them and publish a schema.

How does this look?

Thanks!
Justin

Example probe message:
<s:Envelope
         ldap:///ou=engineering,o=examplecom,c=us<ldap://ou=engineering,o=examplecom,c=us>
       </d:Scopes>
     </d:Probe>
   </s:Body>
 </s:Envelope>

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean. _______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp