Subject: [IPP] Pages for documents

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 18 Jun 2012 08:49:15 -0700

All,

Does anyone see any problem with us no longer having a flat namespace in
the PWG model?  In my final JPS3 edits I found a collision on "pages".
JPS3 has the "pages"  element whose semantics is the number of input
pages and a syntax of integer.  The "overrides" element already contains
the "pages" element whose semantics is to identifies one or more output
pages and it is of type RangeOfInt.  

Pete

Peter Zehler

Xerox Research Center Webster
Email: [email-masked] <mailto:[email-masked]> 
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701 

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 18 Jun 2012 09:10:19 -0700

Pete,

I think we should change the JPS3 name to prevent the collision. In this case it isn't a problem for the registry, but I can see this causing confusion in the future.

I propose adding a "document-" prefix to the "pages-[suffix]" Document Description attributes (e.g. "pages" becomes "document-pages", etc.) to mirror the "job-" prefix used for the corresponding Job Description attributes.

Any objections?

On Jun 18, 2012, at 8:49 AM, Zehler, Peter wrote:

> All,
> Does anyone see any problem with us no longer having a flat namespace in the PWG model?  In my final JPS3 edits I found a collision on “pages”.  JPS3 has the “pages”  element whose semantics is the number of input pages and a syntax of integer.  The “overrides” element already contains the “pages” element whose semantics is to identifies one or more output pages and it is of type RangeOfInt. 
> Pete
>  
>  
> Peter Zehler
> 
> Email: [email-masked]
> Voice: (585) 265-8755
> FAX: (585) 265-7441
> US Mail: Peter Zehler
> Xerox Corp.
> 800 Phillips Rd.
> M/S 128-25E
> Webster NY, 14580-9701
>  
> 
> -- 
> believed to be clean. _______________________________________________
> ipp mailing list
> [email-masked]

________________________________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

---

From: "Zehler, Peter" <[email-masked]>
Date: Mon, 18 Jun 2012 09:38:31 -0700

I have no objection to "document-pages", "document-pages-completed", and
"document-pages=completed-current-copy".  I will make the changes to the
schema and the PJT specification.  (I can always change back if there is
stiff opposition.)

Peter Zehler

From: Michael Sweet [mailto:[email-masked]] 
Sent: Monday, June 18, 2012 12:10 PM
To: Zehler, Peter
Cc: <[email-masked]>
Subject: Re: [IPP] Pages for documents

Pete,

I think we should change the JPS3 name to prevent the collision. In this
case it isn't a problem for the registry, but I can see this causing
confusion in the future.

I propose adding a "document-" prefix to the "pages-[suffix]" Document
Description attributes (e.g. "pages" becomes "document-pages", etc.) to
mirror the "job-" prefix used for the corresponding Job Description
attributes.

Any objections?

All,

Pete

Peter Zehler

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner <http://www.mailscanner.info/> , and is

---

From: Ira McDonald <[email-masked]>
Date: Mon, 18 Jun 2012 13:25:39 -0400

Hi,

Thanks Mike and Pete - elegant solution w/ "document" prefix.

I think keeping PWG flat namespace is important.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Jun 18, 2012 at 12:38 PM, Zehler, Peter <[email-masked]> wrote:
> I have no objection to “document-pages”, “document-pages-completed”, and
> “document-pages=completed-current-copy”.  I will make the changes to the
> Does anyone see any problem with us no longer having a flat namespace in the
> PWG model?  In my final JPS3 edits I found a collision on “pages”.  JPS3 has
> the “pages”  element whose semantics is the number of input pages and a
> syntax of integer.  The “overrides” element already contains the “pages”
> element whose semantics is to identifies one or more output pages and it is
> of type RangeOfInt.
>
> Pete
>
>
>
>
>
> Peter Zehler
>