Subject: [IPP] Coloring, Coloring: Wherefore Art Thou?

From: Michael Sweet <[email-masked]>
Date: Thu, 18 Oct 2012 11:03:04 -0400

All,

I have gotten more feedback on the continued use of the term "Coloring" in IPP specifications, and the reference back to 2911 as the reason for continuing its confusing existence.

Thus far I have gone along with this reference - I remember us using the term when IPP/1.0 and 1.1 were being hammered out so naturally we must have used it in the spec, right?  But when one of my colleagues actually went looking for the term being used in 2911 she couldn't find it.  And then I went digging...

So, as far as I can tell, we have *never* used the term "coloring" in an IETF RFC for IPP.  I also could not find the term used in ISO DPA.  The only place we have used it is in IPP JPS3 (now published) and IPP Everywhere (pending posting for Formal Vote).

I also did a search of the mailing list archives and found several uses of the term, but I don't see it in any of the drafts (other than JPS3 and Everywhere)

So, can anyone point me to the origins of the term?  Given the number of complaints about this in the past (even for JPS3), the obscure usage, and the apparent lack of precedent, I would prefer to use "filtering" (as requested on several occasions) instead of "coloring" in IPP Everywhere.

Thoughts?

__________________________________________________
Michael Sweet, Senior Printing System Engineer, PWG Chair

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Thu, 18 Oct 2012 12:56:34 -0400

Hi Mike,

I agree with replacing "coloring" with the standard "filtering" term.

I found coloring in a lot of minutes, but also couldn't find it in the
IETF or early PWG IPP specs.

Cheers,
- Ira (buried in TCG meetings this week)

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434
Temporary Cabin *** 2012 only *** 906-494-2523

On Thu, Oct 18, 2012 at 11:03 AM, Michael Sweet <[email-masked]> wrote:

> All,
>
> I have gotten more feedback on the continued use of the term "Coloring" in
> IPP specifications, and the reference back to 2911 as the reason for
> continuing its confusing existence.
>
> Thus far I have gone along with this reference - I remember us using the
> term when IPP/1.0 and 1.1 were being hammered out so naturally we must have
> used it in the spec, right?  But when one of my colleagues actually went
> looking for the term being used in 2911 she couldn't find it.  And then I
> went digging...
>
> So, as far as I can tell, we have *never* used the term "coloring" in an
> IETF RFC for IPP.  I also could not find the term used in ISO DPA.  The
> only place we have used it is in IPP JPS3 (now published) and IPP
> Everywhere (pending posting for Formal Vote).
>
> I also did a search of the mailing list archives and found several uses of
> the term, but I don't see it in any of the drafts (other than JPS3 and
> Everywhere)
>
> So, can anyone point me to the origins of the term?  Given the number of
> complaints about this in the past (even for JPS3), the obscure usage, and
> the apparent lack of precedent, I would prefer to use "filtering" (as
> requested on several occasions) instead of "coloring" in IPP Everywhere.
>
> Thoughts?
>
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.
>

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 18 Oct 2012 22:28:50 +0000

Hello,

I agree with the use of "filtering" if including the document-format attribute in a Get-Printer-Attributes operation should always return a subset of what is returned when document-format is NOT included as an attribute in the operation request.  If that is not supposed to always be the case, then I worry that the term "filtering" might be misleading.  I cannot think of concrete examples for or against, but I wanted to point this out.

HTH,

Smith

/**
    Smith Kennedy
    Hewlett-Packard Co.
    [email-masked]<mailto:[email-masked]>
*/

On 2012-10-18, at 10:56 AM, Ira McDonald <[email-masked]<mailto:[email-masked]>>
 wrote:

Hi Mike,

Cheers,

mailto:[email-masked]<mailto:[email-masked]>

On Thu, Oct 18, 2012 at 11:03 AM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:
All,

Thoughts?

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean.

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

--
This message has been scanned for viruses and
dangerous content by MailScanner<http://www.mailscanner.info/>, and is
believed to be clean. _______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 18 Oct 2012 18:50:46 -0400

Smith,

The definition of the filtering/coloring used has always been a little squishy, but generally Get-Printer-Attributes with a document-format should always return a proper subset of the Get-Printer-Attributes response without a document-format value supplied (where that proper subset might be the whole shebang...)

---

From: "William A Wagner" <[email-masked]>
Date: Thu, 18 Oct 2012 20:19:23 -0400

Strange that we have held ourselves hostage to this odd use of the term for
so long without anyone  checking on it. I think the use of 'coloring' needed
to be explained at least once to anyone coming across it in this context.
But then, the meaning of 'filtering' would need to be explained too.
Actually, coloring would not be a bad term if it were not being applied to
printers, which all quite literally do coloring. Take this as a vote for
filtering.

Bill Wagner

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ira
McDonald
Sent: Thursday, October 18, 2012 12:57 PM
To: Michael Sweet; Ira McDonald
Cc: [email-masked]
Subject: Re: [IPP] Coloring, Coloring: Wherefore Art Thou?

Hi Mike,

Cheers,

 <http://sites.google.com/site/blueroofmusic>
 <http://sites.google.com/site/highnorthinc>

All,

So, as far as I can tell, we have *never* used the term "coloring" in an
IETF RFC for IPP.  I also could not find the term used in ISO DPA.  The only
place we have used it is in IPP JPS3 (now published) and IPP Everywhere
(pending posting for Formal Vote).

Thoughts?

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 
believed to be clean. 

-- 
This message has been scanned for viruses and 
dangerous content by  <http://www.mailscanner.info/> MailScanner, and is 
believed to be clean.

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Fri, 19 Oct 2012 00:32:10 +0000

Given that I concur with "filtering".  

--
Smith Kennedy
Hewlett-Packard Co.
[email-masked]