Subject: [IPP] IPP FaxOut and "cover-page-info" conditionally required depending on PDF support - is this a good idea?

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 10 Dec 2012 04:02:23 +0000

Hello,

In our IPP F2F / teleconference yesterday, we discussed making "cover-page-info" conditionally required depending on some other criteria, such as whether the fax-capable printer supports PDF as a document format.  In thinking about this afterward, I began to have worries about whether this was really a good idea.

Interpolating between points like this seems like some kind of "formalized side effect", which doesn't sound like an optimal solution.  It would be much more clear if the fax-capable printer could explicitly communicate it does not support cover page generation by a boolean attribute.  I'm not sure of the best way to do this, and I assume there are "design patterns" for creating and extending "IPP attribute clusters" to address issues such as this?

My apologies if I missed something…
 
Smith

/**
    Smith Kennedy
    Hewlett-Packard Co.
    [email-masked]
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Tue, 11 Dec 2012 04:44:50 +0000

Thanks, Mike!

BTW, looping the reflector back into the thread.

Smith

On 2012-12-10, at 12:34 PM, Michael Sweet <[email-masked]> wrote:

> Smith,
> 
> I'll make sure we have the usual "if you support this you must support that" verbiage; it is somewhat implicit for xxx, xxx-default, and xxx-supported, but it also doesn't hurt to have the explicit conformance requirement in there too...
> 
> 
> On 2012-12-10, at 2:07 PM, "Kennedy, Smith (Wireless Architect)" <[email-masked]> wrote:
> 
>> Hi Mike,
>> 
>> In "wd-ippfaxout10-20121128.pdf", it wasn't clear to me from the definition of "cover-sheet-info" in section 6.1.2 (which I mistakenly called "cover-page-info" in my query) that the printer could simply not implement the "cover-sheet-info-supported" attribute and that clients would interpret that as the printer not supporting it, especially since the "cover-sheet-info" attribute is required.  Can this be called out more clearly?  Maybe I'm just exposing myself as an IPP sophomore ("wise fool") but this isn't obvious to me, and it wasn't to others within HP either.
>> 
>> Smith
>> 
>> 
>> 
>> On 2012-12-10, at 11:47 AM, Michael Sweet <[email-masked]>
>> wrote:
>> 
>>> Smith,
>>> 
>>> On 2012-12-09, at 11:02 PM, "Kennedy, Smith (Wireless Architect)" <[email-masked]> wrote:
>>>> Hello,
>>>> 
>>> The cover-page-info-supported attribute conveys whether the printer can generate cover pages and what member attributes are supported. If the printer does not report this attribute then the client knows it does not support it...
>>> 
>>> As for tying this to PDF support, it is more to say that "if you are a PDF printer then you must support it, otherwise support it optional/recommended."  The client still needs to look for cover-page-info-supported to know whether the printer can generate a cover page...
>>> 
>>> __________________________________________________
>>> Michael Sweet, Senior Printing System Engineer, PWG Chair
>>> 
>> 
> 
> __________________________________________________
> Michael Sweet, Senior Printing System Engineer, PWG Chair
>