Subject: [IPP] Report on CUPS attribute group ordering restrictions

From: Michael Sweet <[email-masked]>
Date: Mon, 15 May 2017 18:13:00 -0400

All,

Re: my pending action item:

	Action: Mike to check on group ordering restrictions in CUPS (PENDING)

I have the following information to provide:

1. The CUPS scheduler (cupsd) enforces the RFC 8011 group ordering in IPP requests.

2. The ipptool utility enforces the RFC 8011 group ordering in IPP responses.

3. The CUPS library (libcups) does not enforce the RFC 8011 group ordering for requests or responses.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Mon, 15 May 2017 18:55:23 -0400

Hi Mike,

Bottom line - does that mean it's OK and appropriate to have the System
attributes
group (for System status changes from Printer operations) at the *end*
(last) of the
response attribute groups?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: Michael Sweet <[email-masked]>
Date: Mon, 15 May 2017 19:29:00 -0400

Ira,

The order should match the tag values, so if system-attributes-tag ends up as 0x0a (next open slot) then it needs to come after all other attribute groups (at the end).

FWIW, the resource-attributes-tag value will be 0x08 (from the original ipp-get-resources drafts) so resource attributes will come before document attributes (0x09) and system attributes (0x0a) but after all others.

> On May 15, 2017, at 6:55 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> Bottom line - does that mean it's OK and appropriate to have the System attributes
> group (for System status changes from Printer operations) at the *end* (last) of the

---

From: Ira McDonald <[email-masked]>
Date: Mon, 15 May 2017 19:36:46 -0400

Hi Mike,

Thanks.

AFAIK there will never be a Document attributes group in a System Service
operation?

Having the Resource attributes and then System attributes last in all the
applicable
operations should simplify the edits a bit.

Cheers,
- Ira

On Mon, May 15, 2017 at 7:29 PM, Michael Sweet <[email-masked]> wrote:

> Ira,
>
> The order should match the tag values, so if system-attributes-tag ends up
> as 0x0a (next open slot) then it needs to come after all other attribute
> groups (at the end).
>
> FWIW, the resource-attributes-tag value will be 0x08 (from the original
> ipp-get-resources drafts) so resource attributes will come before document
> attributes (0x09) and system attributes (0x0a) but after all others.
>
>

---

From: Michael Sweet <[email-masked]>
Date: Mon, 15 May 2017 19:56:04 -0400

Ira,

> On May 15, 2017, at 7:36 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> Thanks.
> 
> AFAIK there will never be a Document attributes group in a System Service operation?

Certainly for any of the operations we are defining in the IPP System Service spec.

> Having the Resource attributes and then System attributes last in all the applicable