Subject: [IPP] Finishings and 'fold-letter' - how to support outward folding? Do we need a 'fold-letter-outward'?

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 24 Aug 2017 18:48:28 +0000

Hi there,

A question arose about the 'fold-letter' finishing type. For the purpose of this discussion, let us assume that 'fold-letter' is defined to use an "inward" fold for both of the folds, and so the Printer includes this in its "finishings-col-ready":

finishings-col-ready=
{
    finishing-template=fold-letter
    media-sheets-supported=1-3
    media-size-name=na_letter_8.5x11in
    folding=
    {
        folding-direction=inward
        folding-offset=8940
        folding-reference-edge=top
    }
    folding=
    {
        folding-direction=inward
        folding-offset=8940
        folding-reference-edge=top
    }
}

If the Printer supported both an "inward" and "outward" implementation of 'fold-letter', how would it appropriately represent this latter variant? Would the right thing to do be to add this as well?

{
    finishing-template=fold-letter-outward
    media-sheets-supported=1-3
    media-size-name=na_letter_8.5x11in
    folding=
    {
        folding-direction=outward
        folding-offset=8940
        folding-reference-edge=top
    }
    folding=
    {
        folding-direction=outward
        folding-offset=8940
        folding-reference-edge=top
    }
}

It seems like it should it have a discrete name. If the right thing to do is to register in our IANA registry 'fold-letter-outward' etc. let me know and I'll submit that.

Cheers,

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 25 Aug 2017 12:20:03 -0400

Smith,

> On Aug 24, 2017, at 2:48 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi there,
> 

Right now we don't differentiate between them for the standard finishing-template/finishings values.  What I would do is use one fold direction consistently as the "default" for 'fold-letter' and then have a vendor template name ('smiNNN-fold-letter-in/outward') for the opposite direction.

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Mon, 28 Aug 2017 11:48:51 +0000

> On Aug 25, 2017, at 10:20 AM, Michael Sweet <[email-masked]> wrote:
> 

OK so something like this in our case (our smallest SMI PEN is 11):

{
  finishing-template=smi11-fold-letter-outward

And then we would also put a string in our string catalog (en.strings or whatever) so that "smi11-fold-letter-outward" isn't shown to the user.

---

From: Michael Sweet <[email-masked]>
Date: Mon, 28 Aug 2017 09:27:12 -0400

Smith,

That looks about right...

> On Aug 28, 2017, at 7:48 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
>