Subject: [IPP] Fwd: Call For Adoption HTTPbis BCP56bis

From: Michael Sweet <[email-masked]>
Date: Thu, 12 Oct 2017 09:23:09 -0400

FYI, it looks like the HTTP WG will be updating this document...

> Begin forwarded message:
> 
> From: Patrick McManus <[email-masked]>
> Subject: Call For Adoption HTTPbis BCP56bis
> Date: October 11, 2017 at 1:51:06 PM EDT
> To: HTTP Working Group <[email-masked]>
> Resent-From: [email-masked]
> 
> Folks, I'm going to open up a 2 week call for adoption period to see if the group has consensus for adopting work on a bis version of BCP56 (aka RFC 3205; On the use of HTTP as a Substrate).
> 
> Mark introduced this work both on the general ART list and with a presentation at IETF 99.
> 
> His draft, which is the subject of the adoption call, can be found https://mnot.github.io/I-D/bcp56bis/ <https://mnot.github.io/I-D/bcp56bis/>
> 
> The ART discussion is archived here: https://www.ietf.org/mail-archive/web/art/current/msg00303.html <https://www.ietf.org/mail-archive/web/art/current/msg00303.html>
> 
> The presentation at IETF 99 is here:
> https://datatracker.ietf.org/meeting/99/materials/slides-99-httpbis-sessb-bcp56bis/ <https://datatracker.ietf.org/meeting/99/materials/slides-99-httpbis-sessb-bcp56bis/> (That's a pdf - trust your content-types!)
> 
> The minutes from IETF 99 are here: https://tools.ietf.org/wg/httpbis/minutes?item=minutes-99-httpbis-00.html <https://tools.ietf.org/wg/httpbis/minutes?item=minutes-99-httpbis-00.html>
> Personally, I think this is an important document to update, and contemporaneous efforts like JMAP and DOH illustrate the relevancy.
> 
> We'll leave the CfA open until October 27. I'm looking for arguments pro or con and especially expressions of interest in collaborating and reviewing the document. Thanks. Please weigh in.
> 
> -Patrick
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 12 Oct 2017 15:28:07 +0000

Hi Mike,

Can you give us the elevator pitch about this update? What value do you see it providing?

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Oct 12, 2017, at 7:23 AM, Michael Sweet <[email-masked]> wrote:
> 
>> From: Patrick McManus <[email-masked] <mailto:[email-masked]>>
>> To: HTTP Working Group <[email-masked] <mailto:[email-masked]>>
>> Resent-From: [email-masked] <mailto:[email-masked]>
>>

---

From: Michael Sweet <[email-masked]>
Date: Thu, 12 Oct 2017 12:03:41 -0400

Smith,

Basically, this is the best-practices document for how to use HTTP as the basis of other high level protocols like IPP.

Right now the current BCP is pretty light on details and looks down on such things, but I'm hoping we (I) can steer them towards some affirmation of how we've done things in IPP so that future versions of HTTP (and they are talking about that already, along with having a separate Model and Semantics RFC that governs all of the different versions) maintain the necessary semantics to allow IPP to work with them as well...

> On Oct 12, 2017, at 11:28 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi Mike,
> 
>>> His draft, which is the subject of the adoption call, can be found https://mnot.github.io/I-D/bcp56bis/
>>> 
>>> The ART discussion is archived here: https://www.ietf.org/mail-archive/web/art/current/msg00303.html
>>> 
>>> https://datatracker.ietf.org/meeting/99/materials/slides-99-httpbis-sessb-bcp56bis/ (That's a pdf - trust your content-types!)
>>> 
>>> The minutes from IETF 99 are here: https://tools.ietf.org/wg/httpbis/minutes?item=minutes-99-httpbis-00.html
>>>