Subject: [IPP] ippsample - ipptool Linux dependencies to support IPPS?

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Thu, 12 Oct 2017 20:28:48 +0000

Hi there,

Trying to get "ipptool" latest from the PWG's ippsample Github project to work using IPPS on Ubuntu 16.04, but it fails because the libraries aren't available. What libraries need to be present for TLS support to be built into ipptool?

Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Thu, 12 Oct 2017 20:12:40 -0400

Smith,

You need a few things; the following should cover it (and I should just make an INSTALL.md file for this):

    sudo apt-get install autoconf build-essential avahi-daemon avahi-utils libavahi-client-dev libgnutls28-dev libjpeg-dev libnss-mdns libpng-dev zlib1g-dev

For TLS the important one is "libgnutls28-dev".

> On Oct 12, 2017, at 4:28 PM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Hi there,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer