Subject: [IPP] Yet another update to IPP Presets posted

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 11 Oct 2017 04:07:48 +0000

Greetings,

Apologies for posting yet another draft, but I've updated it to more closely match the IPP Registration template and made a few other tweaks. The -rev is against the 2017-09-12 revision, not against yesterday's update. Please ignore yesterday's.

   https://ftp.pwg.org/pub/pwg/ipp/wd/tb-ipp-preset-20171010.pdf
   https://ftp.pwg.org/pub/pwg/ipp/wd/tb-ipp-preset-20171010.odt
   https://ftp.pwg.org/pub/pwg/ipp/wd/tb-ipp-preset-20171010-rev.pdf
   https://ftp.pwg.org/pub/pwg/ipp/wd/tb-ipp-preset-20171010-rev.odt

Cheers,
Smith

/**
    Smith Kennedy
    Wireless Architect - Client Software - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Wed, 11 Oct 2017 10:55:49 -0400

Smith,

Few comments on the -rev document:

- Section 1, line 77 you have:

    set of job template attributes and attribute values that are all applied together

  I think this can be simplified to:

    set of Job Template attributes that are applied together

  (attributes are name+value, no need to make the distinction, and "all" is unnecessary with "together")

- Section 2.3, lines 113-114: You can make a similar change in the terminology section

- Section 4.1 (line 191): Shouldn't this be a level 2 heading?

- Section 4.1.3: For continued discussion... :)

- Section 4.2, line 243: You say "A Client adds a Preset to a Printer ..." but it might be more accurate to say that "A Client updates the set of presets on a Printer ..." (see my previous comments on the subject)

Anyways, we should definitely discuss management of presets, and document this further so that it is clear how all of this is intended to work...

> On Oct 11, 2017, at 12:07 AM, Kennedy, Smith (Wireless Architect) <[email-masked]> wrote:
> 
> Greetings,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: "Kennedy, Smith (Wireless Architect)" <[email-masked]>
Date: Wed, 11 Oct 2017 15:16:58 +0000

Thanks Mike! I'll hold off on making these changes until the next revision but we can go over these in the call tomorrow.

On the subject of funny headings, this is an artifact of LibreOffice I have observed. If there are headings that seem off in a -rev, it is good to check the clean copy to see if the structure is correct.

> Anyways, we should definitely discuss management of presets, and document this further so that it is clear how all of this is intended to work...

All of the content on that subject has been added following email discussions or on conference calls where either you or Ira were absent. It will be good to have the 3 of us on a call to interactively pick that apart.

> On Oct 11, 2017, at 8:55 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
>