Subject: [IPP] Interest in developing an "IPP for Dummies" document?

From: Michael Sweet <[email-masked]>
Date: Thu, 30 Nov 2017 15:10:19 -0500

All,

I'm seeing a lot of questions from users of different IPP-based projects (CUPS, node.js, etc.) that show a fundamental lack of understanding of basic IPP concepts - URIs, attribute syntaxes (types), etc. - and I generally hesitate before pointing them at the various specifications because IPP is such a large, multi-headed beast.

Do people have any interest in working on an "IPP for Dummies" document that would provide a beginners (application developer's) guide to IPP?  A rough table-of-contents might be:

1. Introduction
   a. What is IPP? (short history)
   b. URIs
   c. Requests/Responses
   d. Attributes and Groups
   e. Attribute Syntaxes (types)
2. Print Jobs
   a. What are Print Jobs?
   b. Job Description Attributes
   c. Job Status Attributes
   d. Job Template Attributes
   e. Documents
3. Printers
   a. What are Printers?
   b. Printer Description Attributes
   c. Printer Status Attributes
   d. Printer Capabilities
4. Submitting Print Jobs
   a. CUPS API Examples
   b. Node.js API Examples
5. Checking Job and Printer Status
   a. CUPS API Examples
   b. Node.js API Examples
6. IPP Map
   (visual map of IPP specifications)

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Thu, 30 Nov 2017 21:45:34 +0000

Hi Mike,

I agree we need a document like this and support its creation, and volunteer to co-author. Others within HP have also expressed interest in contributing to it. I had hoped that the IPP Implementor's Guide v2 was going to provide some of this. But an "IPP Basics" document like what you describe below is really a better first starting point, which then may refer the reader to IPP Implementor's Guide v2. Perhaps the examples you discuss below should also be done using "ipptool" / "ippserver"?

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

> On Nov 30, 2017, at 1:10 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>

---

From: Paul Tykodi <[email-masked]>
Date: Thu, 30 Nov 2017 17:18:15 -0500

Hi Smith,

I also agree this is a good idea.

I think we should consider developing a 3D focused chapter as well.

I volunteer to generate some content for a potential 3D chapter in the event it is accepted as part of the document.

Best Regards,

/Paul

Sent from my iPhone

> On Nov 30, 2017, at 4:45 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hi Mike,
>

---

From: <[email-masked]>
Date: Thu, 30 Nov 2017 17:58:33 -0500

All,
Interesting project. We could argue the outline order a bit. Although a clear presentation the basics is necessary, IPP  as a way to interface with printers (lower case, hardcopy image-making device) has been around for ages and probably would not cause much excitement. Perhaps there would be more interest (and there certainly is more need) in aspects  where there is not much implementation (and  great potential); infra/cloud and scanning/image handling. And I wonder how much  interest there would be from application developers without first getting their managers aware of the product advantages?
Bill Wagner

From: Paul Tykodi
Sent: Thursday, November 30, 2017 5:18 PM
To: Kennedy, Smith (Wireless & Standards Architec)
Cc: PWG IPP WG Reflector
Subject: Re: [IPP] Interest in developing an "IPP for Dummies" document?

Hi Smith,

Best Regards,

/Paul

Sent from my iPhone

Smith

/**
    Smith Kennedy

All,

1. Introduction

Thoughts?