Subject: [IPP] Fwd: Zstd compression (FYI)

From: Michael Sweet <[email-masked]>
Date: Wed, 15 Nov 2017 08:33:09 -0500

and I am passing it on as well.

Some information on Zstd, which I hadn't heard of until this morning, which looks really interesting:

	http://facebook.github.io/zstd/ <http://facebook.github.io/zstd/>

> Begin forwarded message:
> 
> From: "Murray S. Kucherawy" <[email-masked]>
> Subject: Zstd compression (FYI)
> Date: November 15, 2017 at 2:57:47 AM EST
> To: [email-masked]
> Resent-From: Yves Lafon <[email-masked]>
> Resent-To: HTTP Working Group <[email-masked]>
> 
> I'd like to make this WG aware of a draft that's being processed in the ART area, namely draft-kucherawy-dispatch-zstd[1].  It describes a data compression algorithm and registers a related media type and content encoding.  The developers aren't seeking browser adoption at this point but since it is making entries in registries affecting in this area, I wanted to make it visible here.
> 
> It was discussed briefly in DISPATCH at IETF 100, and it was decided that it will be AD-sponsored.  There's no action item for HTTPBIS.  Just FYI.
> 
> Thanks,
> 
> -MSK
> 
> [1] https://datatracker.ietf.org/doc/draft-kucherawy-dispatch-zstd/ <https://datatracker.ietf.org/doc/draft-kucherawy-dispatch-zstd/>

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald <[email-masked]>
Date: Wed, 15 Nov 2017 08:49:23 -0500

Hi Mike,

Zstandard has provoked a lively discussion on IETF lists.  Noteworthy
comments included Harald Alvestrand objecting strongly to the use of
"standard" in the name (he's gotten lots of support for this comment)
and several cryptographers questioning why it's worthwhile, given that
it uses existing crypto primitives and it currently lacks good treatment
of the security considerations.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

On Wed, Nov 15, 2017 at 8:33 AM, Michael Sweet <[email-masked]> wrote:

> http://facebook.github.io/zstd/
>
>
> Begin forwarded message:
>
> *From: *"Murray S. Kucherawy" <[email-masked]>
> *Subject: **Zstd compression (FYI)*
> *Date: *November 15, 2017 at 2:57:47 AM EST
> *To: [email-masked]
> *Resent-From: *Yves Lafon <[email-masked]>
> *Resent-To: *HTTP Working Group <[email-masked]>
>
> I'd like to make this WG aware of a draft that's being processed in the
> ART area, namely draft-kucherawy-dispatch-zstd[1].  It describes a data
> compression algorithm and registers a related media type and content
> encoding.  The developers aren't seeking browser adoption at this point but
> since it is making entries in registries affecting in this area, I wanted
> to make it visible here.
>
> It was discussed briefly in DISPATCH at IETF 100, and it was decided that
> it will be AD-sponsored.  There's no action item for HTTPBIS.  Just FYI.
>
> Thanks,
>
> -MSK
>
> [1] https://datatracker.ietf.org/doc/draft-kucherawy-dispatch-zstd/
>
>

---

From: Michael Sweet <[email-masked]>
Date: Wed, 15 Nov 2017 10:38:54 -0500

Ira,

Yeah, the naming is unfortunate - perhaps the Facebook folks would be open to renaming it to "Znext" or something?  I didn't read far enough in to comment on any of the crypto/hash usage, but the new data compression technique is certainly novel.

> On Nov 15, 2017, at 8:49 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> On Wed, Nov 15, 2017 at 8:33 AM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>> From: "Murray S. Kucherawy" <[email-masked] <mailto:[email-masked]>>
>> To: [email-masked] <mailto:[email-masked]>
>> Resent-From: Yves Lafon <[email-masked] <mailto:[email-masked]>>
>> Resent-To: HTTP Working Group <[email-masked] <mailto:[email-masked]>>
>> 
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> 
>