Subject: [IPP] RFC: Possible (very short white paper/tech brief) guidance for how to report so-called multi-purpose trays?

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Nov 2017 10:02:35 -0500

All,

One question I regularly get from implementors is how to handle so-called "multi-purpose trays" which can function both as a tiny paper tray and as the manual feed source.  The question comes up because you don't report manually fed media in "media-col-ready" or "media-ready", but for these trays you can actually load media and tell the printer (via the built-in console) what media was loaded, just as if it was a dedicated paper tray.

My guidance has been the following:

1. The 'manual-feed' value of "media-source" requests that the Printer pause for user interaction (to insert the requested media) while 'by-pass-tray' requests that the Printer immediately print using the media from that source (pausing only when the tray is empty or loaded with a different media).

2. Implementations should report two values in the "media-source-supported" Printer Description attribute for so-called multi-purpose trays: 'manual-feed' and 'by-pass-tray'.

3. Likewise, implementations should report two values in the "printer-input-tray" Printer Description attribute, with "type=sheetFeedManual" for the 'manual-feed' source and "type=sheetFeedAutoRemovableTray" or "type=sheetFeedAutoNonRemovableTray" for the 'by-pass-tray' source, as applicable.

If there is consensus on this approach, I can write up a (short!) tech brief that we can publish to make it "official", and I can then point people to it...

(this should probably be more clearly specified in JPS3, but I have neither the time nor energy to tackle updating *that* document right now... :)

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 27 Nov 2017 11:21:32 -0500

and I've posted my proposed (best practice) white paper text here:

    http://ftp.pwg.org/pub/pwg/ipp/wd-sweet-mptray-20171127.docx
    http://ftp.pwg.org/pub/pwg/ipp/wd-sweet-mptray-20171127.pdf

> On Nov 27, 2017, at 10:02 AM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>