Subject: [IPP] First draft of IPP "save-password" whitepaper posted for review

From: "Kennedy, Smith (Wireless & Standards Architec)" <[email-masked]>
Date: Tue, 5 Dec 2017 17:17:38 +0000

Greetings,

I had an action item to create a whitepaper to define a new "save-password" attribute and related set of attributes to handle the scenario where we wanted basically an attribute equivalent to "job-password" but that would persist and be preserved even as a saved job. I have posted a first draft of this whitepaper for review:

https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20171205.pdf
https://ftp.pwg.org/pub/pwg/ipp/whitepaper/tb-savepassword-20171205.odt

I don't know that I will be able to review this Thursday but wanted to get it out there.

Cheers,

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 08 Dec 2017 08:43:39 -0500

Smith,

I just did a read of this draft and wanted to provide some feedback while it is fresh in my mind:

- Section 1: some mention of job-password being a Job Template attribute, but it is an operation attribute (which is correctly noted in subsequent sections
- Section 4.2: Any password attribute needs to be protected, so these should be operation attributes and not Job Template...
- Section 6: Will obviously need a lot of discussion of how to protect and handle the passwords.

Overall I'm still not sure about the use case for this, or how it would all work together.  Is this an extension of "job-save-disposition", where the password would be used for the saved document?  If so, I'd recommend that the attributes be called "job-save-password[-xxx]" to make that clearer, and add some discussion of that.

Also, how does a Client re-print the saved job?  Resubmit-Job with "document-password"?

> On Dec 5, 2017, at 12:17 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Greetings,
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer