Subject: Re: [IPP] Interest in developing an "IPP for Dummies" document?

From: "Zehler, Peter" <[email-masked]>
Date: Fri, 1 Dec 2017 12:55:49 +0000

Mike,
If you have no objection to a voice from the past, i'd like to work on an IPP for dummies document.  (I know of some managers that could use one.)  I'd like to see the first chapter include a discussion of why IPP instead of lpr or Port 9100.
Pete

Peter Zehler
Xerox Corp.
Global Development Group
800 Phillips Rd, 111-04A
Webster NY, 14580-9701
Email: [email-masked]
Office: +1 (585) 265-8755
Fax: +1 (585) 422-0238
Mobile: +1 (585) 329-9508
 
________________________________
From: ipp <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Thursday, November 30, 2017 5:58:33 PM
To: Paul Tykodi; Kennedy, Smith (Wireless & Standards Architec)
Cc: PWG IPP WG Reflector
Subject: Re: [IPP] Interest in developing an "IPP for Dummies" document?

All,
Interesting project. We could argue the outline order a bit. Although a clear presentation the basics is necessary, IPP  as a way to interface with printers (lower case, hardcopy image-making device) has been around for ages and probably would not cause much excitement. Perhaps there would be more interest (and there certainly is more need) in aspects  where there is not much implementation (and  great potential); infra/cloud and scanning/image handling. And I wonder how much  interest there would be from application developers without first getting their managers aware of the product advantages?
Bill Wagner

From: Paul Tykodi<mailto:[email-masked]>
Sent: Thursday, November 30, 2017 5:18 PM
To: Kennedy, Smith (Wireless & Standards Architec)<mailto:[email-masked]>
Cc: PWG IPP WG Reflector<mailto:[email-masked]>
Subject: Re: [IPP] Interest in developing an "IPP for Dummies" document?

Hi Smith,

I also agree this is a good idea.

I think we should consider developing a 3D focused chapter as well.

I volunteer to generate some content for a potential 3D chapter in the event it is accepted as part of the document.

Best Regards,

/Paul

Sent from my iPhone

On Nov 30, 2017, at 4:45 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Mike,

I agree we need a document like this and support its creation, and volunteer to co-author. Others within HP have also expressed interest in contributing to it. I had hoped that the IPP Implementor's Guide v2 was going to provide some of this. But an "IPP Basics" document like what you describe below is really a better first starting point, which then may refer the reader to IPP Implementor's Guide v2. Perhaps the examples you discuss below should also be done using "ipptool" / "ippserver"?

Smith

/**
    Smith Kennedy
    Wireless & Standards Architect - IPG-PPS
    Standards - IEEE ISTO PWG / Bluetooth SIG / Wi-Fi Alliance / NFC Forum / USB-IF
    Chair, IEEE ISTO Printer Working Group
    HP Inc.
*/

On Nov 30, 2017, at 1:10 PM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:

All,

I'm seeing a lot of questions from users of different IPP-based projects (CUPS, node.js, etc.) that show a fundamental lack of understanding of basic IPP concepts - URIs, attribute syntaxes (types), etc. - and I generally hesitate before pointing them at the various specifications because IPP is such a large, multi-headed beast.

Do people have any interest in working on an "IPP for Dummies" document that would provide a beginners (application developer's) guide to IPP?  A rough table-of-contents might be:

1. Introduction
  a. What is IPP? (short history)
  b. URIs
  c. Requests/Responses
  d. Attributes and Groups
  e. Attribute Syntaxes (types)
2. Print Jobs
  a. What are Print Jobs?
  b. Job Description Attributes
  c. Job Status Attributes
  d. Job Template Attributes
  e. Documents
3. Printers
  a. What are Printers?
  b. Printer Description Attributes
  c. Printer Status Attributes
  d. Printer Capabilities
4. Submitting Print Jobs
  a. CUPS API Examples
  b. Node.js API Examples
5. Checking Job and Printer Status
  a. CUPS API Examples
  b. Node.js API Examples
6. IPP Map
  (visual map of IPP specifications)

Thoughts?

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Fri, 01 Dec 2017 09:21:50 -0500

Pete,

For sure your participation would be greatly appreciated!  And I agree any introduction/history definitely needs to say something about past "protocols" and why they have been replaced.

> On Dec 1, 2017, at 7:55 AM, Zehler, Peter <[email-masked]> wrote:
> 
> Mike,

---

From: Michael Sweet <[email-masked]>
Date: Fri, 01 Dec 2017 09:26:16 -0500

Smith,

> On Nov 30, 2017, at 4:45 PM, Kennedy, Smith (Wireless & Standards Architec) <[email-masked]> wrote:
> 
> Hi Mike,
> 

I can see a use for both of those - ipptool to try out requests, ippserver for testing/development.

---

From: Michael Sweet <[email-masked]>
Date: Fri, 01 Dec 2017 09:30:45 -0500

Paul,

I hesitate to mix in 3D content in the same document (we can quickly make this into another huge, scary volume), but perhaps we can develop a separate 3D "book" in parallel - much of the content will be the same/similar anyways.

But I agree 100% about doing something for 3D as well.

> On Nov 30, 2017, at 5:18 PM, Paul Tykodi <[email-masked]> wrote:
> 
> Hi Smith,
> 
>>> On Nov 30, 2017, at 1:10 PM, Michael Sweet <[email-masked]> wrote:
>>> 
>>> All,
>>>

---

From: Michael Sweet <[email-masked]>
Date: Fri, 01 Dec 2017 09:44:30 -0500

Bill,

> On Nov 30, 2017, at 5:58 PM, [email-masked] wrote:
> 
> All,

I've been getting a lot of questions from application/framework developers on Linux (trying to modernize the Linux printing stack) as well as cloud service developers using things like Node.js to support printing.  In both cases we are talking about the client-side interactions with an IPP Printer (locally or in "the cloud"), with the developer unsure about how IPP works or how to accomplish their task.

What *I'm* envisioning is more of a high-level how-to guide for using IPP - that first chapter will get people needing to print (managers included) excited about IPP because a) it solves their problem and b) they know they will learn how to use it by reading the rest of the book.

If we expand the scope too far (particularly into areas that haven't been widely implemented) then it (IMHO) will make the material less compelling and harder to approach.

We don't need to document everything in one place.  We don't need to answer every question.  But we do need a way for new developers to get comfortable using IPP...

---

From: Michael Sweet <[email-masked]>
Date: Fri, 01 Dec 2017 10:16:31 -0500

I've setup a Github repository for this and any other informal documents we may want to develop:

    https://github.com/istopwg/pwg-books

Everyone that is associated with the istopwg organization should have write access - please let me know your Github account if you need access.

I'll push a directory with the initial outline below later today.  Since this isn't a formal technical publication of the PWG, I'd like to do the text of the book as a series of Markdown files for each chapter - these can be reviewed (with history) through the Github site, and can be "published" to HTML, PDF, and EPUB files using my HTMLDOC software (https://michaelrsweet.github.io/htmldoc) for ease of distribution/viewing.  For those not familiar with Markdown, here is the original post from Mark Gruber:

    https://daringfireball.net/projects/markdown/syntax

(HTMLDOC supports a subset of what is now known as "CommonMark")

> On Nov 30, 2017, at 3:10 PM, Michael Sweet <[email-masked]> wrote:
> 
> All,
>

---

From: Paul Tykodi <[email-masked]>
Date: Fri, 1 Dec 2017 10:18:25 -0500

Hi Mike,

I have been seeing the exact same issue in the 3D space.

If we are able to create a parallel 3D document, I can promote it via AMSC and ISO/IEC JTC1 efforts and then ask for feedback when developers start following the guidelines and building sample applications to test.

Thanks.

Best Regards,

/Paul

Sent from my iPhone

> On Dec 1, 2017, at 9:44 AM, Michael Sweet <[email-masked]> wrote:
> 
> Bill,
>