Subject: Re: gpsPolicyGroup class in qos info model

From: Mahadevan Iyer <[email-masked]>
Date: Tue, 12 Dec 2000 22:38:33 -0800 (PST)

--- John Strassner <[email-masked]> wrote:
> I think I understand in principle what you want to
> do, but
> just to be clear, is this a fair description:
> 
>   you want to be able to trim a tree of policy
>   information from consideration to be evaluated
>   efficiently; therefore, you want to add a
>   condition clause, defined by the admin, on a
>   high-level container, to do this
> 

This is correct.

> Assuming that this is correct, you still haven't
> addressed
> how you accommodate decision strategy and nested
> rules. In
> other words, are you proposing that you construct
> these new
> trimming rules INDEPENDENTLY of the actual structure
> of the
> rules below that containment point (e.g., taking
> into
> account their individual decision strategies,
> priorities,
> etc.)? How can you be sure that you are capturing
> the
> semantics and maintaining the correct execution
> order by
> your newly defined trimming rules?

This is the responsibility of the policy
administrator.
The exact same responsibility exists when creating
PolicyRuleInPolicyRule trees.
Isn't this true ?

Regards

__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

---

From: "John Strassner" <[email-masked]>
Date: Wed, 13 Dec 2000 11:34:51 -0800

No. The point of QPIM is to use gpsPolicyGroup and
qosPolicyGroup to develop specific containers that are used
to hold decision strategies, etc. that apply to objects in
their scope. Telling the administrator to try and build a
condition that captures the complex evaluation strategies
that are contained in containers below it and hoping that a
single condition can capture these complexities is, imho,
not achievable.

regards,
John
----- Original Message -----
From: "Mahadevan Iyer" <[email-masked]>
To: "John Strassner" <[email-masked]>; "Marcus Brunner"
<[email-masked]>; "Ron Cohen" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, December 12, 2000 10:38 PM
Subject: Re: gpsPolicyGroup class in qos info model