Subject: [Ledger] AGENDA - Community Call - Wed 24 August - 3pm UTC

From: Adrian Hope-Bailie <[email-masked]>
Date: Tue, 23 Aug 2016 09:10:49 +0200

Hi all,

We have our bi-weekly community call this Wednesday.
Dial in details at the bottom.

*Community Updates*
- Started using gitter:
--> https://gitter.im/interledger/Lobby
--> https://gitter.im/interledger/rfcs
--> https://gitter.im/interledger/java-crypto-conditions
--> https://gitter.im/interledger/java-ilp-core
- IETF mailing list ([email-masked] - https://www.ietf.org/mailman/
listinfo/ledger)

*Proposed crypto-condition changes*
- https://github.com/interledger/rfcs/issues/78
- https://github.com/interledger/rfcs/issues/86
- https://github.com/interledger/rfcs/issues/87
- Current plan is to keep the current CC stable and release a draft 01
representing the current state of all implementations. Then start work
towards a draft 02 which includes the changes mentioned above.

*Binary format status*
- Plan to encapsulate most of it in ilp-core, so everyone else doesn't have
to worry about it.
- We had previously thought that we would reimplement ILP in every
language. Now adopted a more nuanced view - need implementations in
JavaScript (browsers, web), C (support most languages through bindings;
embedded systems), Java (to support JVM), C# (to support .NET), Python
(large amount of interest). But not much more for now.
- Javascript and Java have started on GitHub looking for others

To join the meeting, go to:
https://bluejeans.com/795795755
(Try your iPhone or Android phone)

Just want to dial in? (http://bluejeans.com/numbers)
Enter Meeting ID: 795795755

Live scribe via IRC: irc.3w.org #interledger

Adrian

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 24 Aug 2016 16:31:10 +0300

*Binary format status*
> - Plan to encapsulate most of it in ilp-core, so everyone else doesn't 
> have to worry about it.
> JavaScript (browsers, web), C (support most languages through 
> bindings; embedded systems), Java (to support JVM), C# (to support 
> .NET), Python (large amount of interest). But not much more for now.
Hi Adrian,

C is notoriously unsuitable for security-sensitive code. As an outside 
observer, I would suggest that you look at alternatives. My favorite 
would be Go with a thin C shim on top. A more realistic alternative 
would be C++ with a C interface.

Thanks,
     Yaron

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Wed, 24 Aug 2016 15:39:29 +0200

Thanks Yaron!

I believe there is a Go implementation in the works from someone in the
community

On 24 August 2016 at 15:31, Yaron Sheffer <[email-masked]> wrote:

> observer, I would suggest that you look at alternatives. My favorite would
> be Go with a thin C shim on top. A more realistic alternative would be C++
> with a C interface.
>
> Thanks,
>     Yaron
>

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Fri, 26 Aug 2016 12:23:16 +0200

I have logged an issue for this:
https://github.com/interledger/interledger.github.io/issues/28

If anyone wants to have a stab at a PR feel free otherwise I'll try and put
something together this weekend.

On 26 August 2016 at 10:44, Manuel Polo <[email-masked]> wrote:

> Hi!
>
> Would be great to have an implementation(connectors,ledger plug-ins etc)
> and or initiatives table somewhere (interledger.org or at least github.com)
> to be aware of: language - repos - maintainer/s.
>
> What do you think?
>
> 2016-08-24 15:39 GMT+02:00 Adrian Hope-Bailie <[email-masked]>:
>
>> Thanks Yaron!
>>
> --
> Manuel Polo
> http://about.me/mrmx

---

From: Manuel Polo <[email-masked]>
Date: Fri, 26 Aug 2016 10:44:35 +0200

Hi!

What do you think?

-- 
Manuel Polo

http://about.me/mrmx

---

From: Manuel Polo <[email-masked]>
Date: Fri, 26 Aug 2016 12:42:07 +0200

Great Adrian! We'll submit a PR next week!

2016-08-26 12:23 GMT+02:00 Adrian Hope-Bailie <[email-masked]>:

> I have logged an issue for this: https://github.com/
> interledger/interledger.github.io/issues/28
>
> If anyone wants to have a stab at a PR feel free otherwise I'll try and
> put something together this weekend.
>
>> and or initiatives table somewhere (interledger.org or at least
>> github.com) to be aware of: language - repos - maintainer/s.
>>
>> What do you think?
>>

-- 
Manuel Polo

http://about.me/mrmx