Subject: edit-form and create-form link relations

From: Jan Algermissen <[email-masked]>
Date: Tue, 16 Oct 2012 10:33:23 +0200

Ioseb,

as discussed yesterday, here are a few final remarks on your draft.

From my POV the link relations are ready to be published then. Can you update and request formal registration?

Review of http://www.ietf.org/id/draft-ioseb-dzmanashvili-link-relation-07.txt

3.1 The "create-form" Link Relation 

- add 'Type' => The "create-form" Link Relation Type

- Suggested minor rewording

  When included in a response, the "create-form" link relation indicates a target resource
  that represents a form that can be used to append a new member to the link context.

3.1.1

- Suggested rewording

  If the form representation includes a submission URI this URI MUST be used
  to submit the form. The context URI SHOULD be used otherwise.

  If the form representation includes a submission method this method MUST be
  used for submit requests. HTTP's POST method SHOULD be used otherwise.

3.2 The "edit-form" Link Relation

- add 'Type'  => The "edit-form" Link Relation Type

- Suggested minor rewording
 
  When included in a response, the "edit-form" link relation indicates
  a target resource that represents a form that can be used for updating
  the context resource.

3.2.1

- Suggested rewording

  If the form representation includes a submission URI this URI MUST be used
  to submit the form. The context URI SHOULD be used otherwise.

  If the form representation includes a submission method this method MUST be
  used for submit requests. HTTP's PUT method SHOULD be used otherwise.

Jan

---

From: Ioseb Dzmanashvili <[email-masked]>
Date: Tue, 16 Oct 2012 22:36:43 +0400

Hi Jan, 

I applied all suggested changes and published new version: http://tools.ietf.org/html/draft-ioseb-dzmanashvili-link-relation-08

Please let me know if any other changes are required.

Best regards,
ioseb

On Tuesday, October 16, 2012 at 10:02 PM, Jan Algermissen wrote:

> Did that earlier today:
> 
> Jan
> 
> 
> 
> Begin forwarded message:
> 
> > From: Jan Algermissen <[email-masked] (mailto:[email-masked])>
> > Subject: edit-form and create-form link relations
> > Date: October 16, 2012 10:33:23 AM GMT+02:00
> > To: [email-masked] (mailto:[email-masked])
> > 
> > Ioseb,
> >