Subject: Use of describedby link relation

From: "Markus Lanthaler" <[email-masked]>
Date: Thu, 15 Nov 2012 13:58:26 +0100

Hi,

I have a question regarding the use of the describedby link relation.

In JSON-LD [1] we have something that we call a "context". Its purpose is
mainly to map terms to IRIs to allow their unambiguous identification. In a
JSON-LD document that context is stored in a "@context" property like so:

{
  "@context": {
    "name": "http://example.com/name"
  },
  "name": "Markus Lanthaler"
}

To allow developers to build on existing infrastructure, i.e., keep their
JSON documents unchanged but nevertheless allow them to link to such a
"context" we use a HTTP link header with the relation type "descibedby" [2]:

Link: <http://json-ld.org/contexts/person.jsonld>; rel="describedby";
type="application/ld+json"

We now got some complaints [3] that we are abusing "describedby" since a) we
are not linking to POWDER documents, and b) the way we use it doesn't match
the semantics of that link relation.

I would appreciate your opinion on that. Do you think we should mint a new
link relation or is it a sensible decision to use "describedby" for this!?

Thank you very much,
Markus

[1] http://json-ld.org/
[2]
http://json-ld.org/spec/latest/json-ld-syntax/#referencing-contexts-from-jso
n-documents
[3] https://github.com/json-ld/json-ld.org/issues/197

--
Markus Lanthaler
@markuslanthaler

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 21 Nov 2012 13:26:06 +1100

First of all, link relations are explicitly NOT linked to any particular media type -- so the argument that describedBy is exclusive to POWDER -- assuming that means a media type -- is misfounded.

Indeed, POWDER itself says:

> This is a generic relationship type that does not of itself imply that the link points to a POWDER document — that is done by the specific Media type.

The definition of describedBy is:

>   Refers to a resource providing information about the link's context.

That's it. This is quite vague; some relations are. 

Personally, it if were me, I'd want a relation type that is more concrete, but if describedBy works for you, go for it, I'd say.

Cheers,

On 15/11/2012, at 11:58 PM, Markus Lanthaler <[email-masked]> wrote:

> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

--
Mark Nottingham   http://www.mnot.net/

---

From: "Markus Lanthaler" <[email-masked]>
Date: Wed, 21 Nov 2012 10:09:16 +0100

> Personally, it if were me, I'd want a relation type that is more
> concrete, but if describedBy works for you, go for it, I'd say.

Thanks a lot Mark. Indeed that's what we decided to do. We will use an IRI
for the time being.

Cheers,
Markus

--
Markus Lanthaler
@markuslanthaler