Subject: NEW RELATION - transaction-participant

From: Guy Pardon <[email-masked]>
Date: Thu, 1 Jun 2017 14:52:32 +0200

Hi experts,

We’d like to add the following relation name:

   o  Relation Name: transaction-participant

   o  Description: URI of a service participating in a distributed HTTP/REST transaction and subject to two-phase commit termination

   o  Reference: https://www.atomikos.com/Blog/ACIDTransactionsAcrossMicroservices

Thank you!

Guy

Dr. Guy Pardon, CTO | Atomikos BVBA | http://www.atomikos.com
Phone: +32 15 61 30 55 | Twitter: @guypardon | Skype: guypardon
Default Timezone: CET (local time: http://www.timeanddate.com/worldclock/city.html?n=48)
The information in this email is confidential and only meant for the addressee(s). The content of this email is informal and will not be legally binding for Atomikos.

---

From: Jan Algermissen <[email-masked]>
Date: Thu, 01 Jun 2017 15:12:55 +0200

Guy,

On 1 Jun 2017, at 14:52, Guy Pardon wrote:

>    o  Description: URI of a service participating in a distributed 
> HTTP/REST transaction and subject to two-phase commit termination
>
>    o  Reference: 
> https://www.atomikos.com/Blog/ACIDTransactionsAcrossMicroservices
>
>

The idea sounds fine to me. I think the referenced documentation 
however, should probably be submitted as an I-D and at least mention the 
link relation type?

Jan

> Default Timezone: CET (local time: 
> http://www.timeanddate.com/worldclock/city.html?n=48)
> The information in this email is confidential and only meant for the 
> addressee(s). The content of this email is informal and will not be 
> legally binding for Atomikos.
>
>
>
> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

---

From: Guy Pardon <[email-masked]>
Date: Thu, 1 Jun 2017 15:16:42 +0200

Jan,

Thanks, we’re only doing a PoC / beta right now, the documentation will be updated after it works. What do you mean with “submitted as an I-D”?

Guy

On 01 Jun 2017, at 15:12, Jan Algermissen <[email-masked]> wrote:

Guy,

>   o  Reference: https://www.atomikos.com/Blog/ACIDTransactionsAcrossMicroservices

The idea sounds fine to me. I think the referenced documentation however, should probably be submitted as an I-D and at least mention the link relation type?

Jan

---

From: Jan Algermissen <[email-masked]>
Date: Thu, 01 Jun 2017 15:32:29 +0200

On 1 Jun 2017, at 15:16, Guy Pardon wrote:

> Jan,
>
> Thanks, we’re only doing a PoC / beta right now, the documentation 
> will be updated after it works. What do you mean with “submitted as 
> an I-D”?

https://www.ietf.org/id-info/

Jan

> however, should probably be submitted as an I-D and at least mention 
> the link relation type?
>
> Jan
>
>
>
>
>
>
>> Thank you!
>>
>> Guy
>>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 1 Jun 2017 15:42:40 +0200

> Thanks, we’re only doing a PoC / beta right now, the documentation will be updated after it works. What do you mean with “submitted as an I-D”?

If you're just doing a PoC, I'd recommend to just use an extension 
relation, as defined in

https://www.greenbytes.de/tech/webdav/rfc5988.html#extension-relation-types

Best regards, Julian