Subject: request to register "cite-as" relation type

From: Herbert Van de Sompel <[email-masked]>
Date: Tue, 10 Oct 2017 09:59:41 -0600

Dear

I would like to register the following relation type:

* Relation Name: cite-as

* Description: A link with the "cite-as" relation type indicates that the
link target is preferred over the link context for the purpose of
referencing.

* Reference: Van de Sompel, H., Nelson, M.L., Bilder, G., Kunze, J., and
Warner, S. (August 2017) cite-as: A Link Relation to Convey a Preferred URI
for Referencing. *https://datatracker.ietf.org/doc/draft-vandesompel-citeas/
<https://datatracker.ietf.org/doc/draft-vandesompel-citeas/>*

This request to register "cite-as" is the result of a prior attempt to
register "identifier". Significant concerns were voiced regarding
"identifier" and, as a result, the co-authors of the I-D decided to settle
on "cite-as", which was proposed during the discussions of "identifier".

The request to register "cite-as" on the basis of ID-00 is motivated by
ongoing adoption of various patterns for using link relation types in
scholarly communication, see http://signposting.org. As soon as "cite-as"
is registered:

- Existing implementations will be asked to change their use of
"identifier" to "cite-as"

- Documentation will be updated to reflect the change from "identifier" to
"cite-as" at http://signposting.org/identifier/

Greetings

Herbert Van de Sompel

-- 
Herbert Van de Sompel
Digital Library Research & Prototyping
Los Alamos National Laboratory, Research Library
http://public.lanl.gov/herbertv/
http://orcid.org/0000-0002-0715-6126

==

---

From: Peter Williams <[email-masked]>
Date: Tue, 10 Oct 2017 18:53:58 -0600

👍 `cite-as` is a valuable addition to the set of common links.

On Tue, Oct 10, 2017 at 9:59 AM, Herbert Van de Sompel <[email-masked]>
wrote:

> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations
>
>

---

From: "Jan Algermissen" <[email-masked]>
Date: Wed, 11 Oct 2017 11:40:28 +0200

> 👍 `cite-as` is a valuable addition to the set of common links.

Sorry, I am only seeing this discussion now.

How is this different from the already registered 'bookmark'?

https://www.w3.org/TR/html5/links.html#link-type-bookmark

Jan

>> for Referencing. 
>> *https://datatracker.ietf.org/doc/draft-vandesompel-citeas/

_____________________
Jan Algermissen
Solutions Engineering

---

From: Edward Summers <[email-masked]>
Date: Wed, 11 Oct 2017 06:55:07 -0400

> On Oct 11, 2017, at 5:40 AM, Jan Algermissen <[email-masked]> wrote:
> 

That does seem like a logical choice right? The core reason is that (weirdly) the HTML specification that defines rel=“bookmark” does not allow it to be used with a <link> element. For some recent discussion on this see:

    https://github.com/whatwg/html/issues/2899

//Ed

---

From: Michael Nelson <[email-masked]>
Date: Wed, 11 Oct 2017 09:09:23 -0400

Hi Peter,

Based on the link Ed provides below, various IETF emails, and other 
inputs, I wrote a blog post in late August that addresses the issue of the 
likely original semantics of "bookmark":

http://ws-dl.blogspot.com/2017/08/2017-08-26-relbookmark-also-does-not.html

TL;DR:  the intention & usege scenario of the rel="bookmark" is best 
understood as if it was actually named rel="right-click".

regards,

Michael

>    https://github.com/whatwg/html/issues/2899

----
Michael L. Nelson [email-masked] http://www.cs.odu.edu/~mln/
Dept of Computer Science, Old Dominion University, Norfolk VA 23529
+1 757 683 6393 +1 757 683 4900 (f)

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 11 Oct 2017 12:33:08 -0700

Hi Herbert,

That looks good. Are you planning to publish this as Informational through the Independent Submission Editor, or get it sponsored by a WG or AD

Cheers,

> On 10 Oct 2017, at 8:59 am, Herbert Van de Sompel <[email-masked]> wrote:
> 
> Dear
> 
> * Description: A link with the "cite-as" relation type indicates that the link target is preferred over the link context for the purpose of referencing.
> 
> * Reference: Van de Sompel, H., Nelson, M.L., Bilder, G., Kunze, J., and Warner, S. (August 2017) cite-as: A Link Relation to Convey a Preferred URI for Referencing. https://datatracker.ietf.org/doc/draft-vandesompel-citeas/
> 
> This request to register "cite-as" is the result of a prior attempt to register "identifier". Significant concerns were voiced regarding "identifier" and, as a result, the co-authors of the I-D decided to settle on "cite-as", which was proposed during the discussions of "identifier".
> 
> The request to register "cite-as" on the basis of ID-00 is motivated by ongoing adoption of various patterns for using link relation types in scholarly communication, see http://signposting.org. As soon as "cite-as" is registered:
> 
> - Existing implementations will be asked to change their use of "identifier" to "cite-as"
> 
> - Documentation will be updated to reflect the change from "identifier" to "cite-as" at http://signposting.org/identifier/
> 
> Greetings
> 
> Herbert Van de Sompel
> 
> -- 
> Herbert Van de Sompel

--
Mark Nottingham   https://www.mnot.net/

---

From: Herbert Van de Sompel <[email-masked]>
Date: Wed, 11 Oct 2017 14:49:52 -0600

On Wed, Oct 11, 2017 at 1:33 PM, Mark Nottingham <[email-masked]> wrote:

> Hi Herbert,
>
> That looks good. Are you planning to publish this as Informational through
> the Independent Submission Editor, or get it sponsored by a WG or AD
>
>
I had thought independent submission, if acceptable.

Greetings

Herbert

> > * Description: A link with the "cite-as" relation type indicates that
> the link target is preferred over the link context for the purpose of
> referencing.
> >
> for Referencing. https://datatracker.ietf.org/
> doc/draft-vandesompel-citeas/
> >
> > - Documentation will be updated to reflect the change from "identifier"
> to "cite-as" at http://signposting.org/identifier/
> >
> > Greetings
> >
> > Herbert Van de Sompel
> >
> > --
> > Herbert Van de Sompel

==

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Oct 2017 13:14:34 -0700

OK. Normally, the registration is made as part of the publication process, in the case of RFCs; I don't think we'll have any issues approving this registration, given the discussion we've had.

We can register it earlier, if there's a need. However, we generally prefer to do the registration when the document is published, in case there's a last-minute change, or the document doesn't make it for some reason.

Do you need registration before the document is published?

Cheers,

> On 11 Oct 2017, at 1:49 pm, Herbert Van de Sompel <[email-masked]> wrote:
>

---

From: Herbert Van de Sompel <[email-masked]>
Date: Thu, 12 Oct 2017 14:22:48 -0600

On Thu, Oct 12, 2017 at 2:14 PM, Mark Nottingham <[email-masked]> wrote:

> OK. Normally, the registration is made as part of the publication process,
> in the case of RFCs; I don't think we'll have any issues approving this
> registration, given the discussion we've had.
>
> We can register it earlier, if there's a need. However, we generally
> prefer to do the registration when the document is published, in case
> there's a last-minute change, or the document doesn't make it for some
> reason.
>
>
Understood.

> Do you need registration before the document is published?
If possible, we would like that indeed because there are operational and
ongoing implementations of the intended relation type. These have, thus
far, used "identifier" as per the discussion that was had here. But I would
like to be able to get in touch asap with known developers & update the
recommendations at http://signposting.org regarding the change from
"identifier" to "cite-as". I am pretty sure that developers would
appreciate knowing that the relation type will not change anymore beyond
the current change from "identifier" to "cite-as". Registration of
"cite-as" would significantly help with that regard.

Cheers

Herbert

> > That looks good. Are you planning to publish this as Informational
> through the Independent Submission Editor, or get it sponsored by a WG or AD
> >
> >
> > > * Reference: Van de Sompel, H., Nelson, M.L., Bilder, G., Kunze, J.,
> and Warner, S. (August 2017) cite-as: A Link Relation to Convey a Preferred
> URI for Referencing. https://datatracker.ietf.org/
> > > The request to register "cite-as" on the basis of ID-00 is motivated
> by ongoing adoption of various patterns for using link relation types in
> > > - Documentation will be updated to reflect the change from
> "identifier" to "cite-as" at http://signposting.org/identifier/
> > >
> > > Greetings
> > >
> > > Herbert Van de Sompel
> > >
> > > --
> > > Herbert Van de Sompel

==

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 13 Oct 2017 18:53:14 +0200

A nice "happiana" test case for 5988bis.

On 12 October 2017 at 22:22, Herbert Van de Sompel <[email-masked]> wrote:
> ongoing implementations of the intended relation type. These have, thus far,
> used "identifier" as per the discussion that was had here. But I would like
> to be able to get in touch asap with known developers & update the
> "identifier" to "cite-as". I am pretty sure that developers would appreciate
> knowing that the relation type will not change anymore beyond the current
> change from "identifier" to "cite-as". Registration of "cite-as" would
> significantly help with that regard.
>
> Cheers
>
> Herbert
>
>
>>
>> Cheers,
>>
>>
>> > > URI for Referencing.
>> > > https://datatracker.ietf.org/doc/draft-vandesompel-citeas/
>> > >
>> > > scholarly communication, see http://signposting.org. As soon as "cite-as" is
>> > > registered:
>> > >

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 25 Oct 2017 15:36:48 +1100

Hi Herbert,

That sounds reasonable; a bit chicken-and-egg, but I think the relation name is specific enough where it's pretty low risk.

Since RFC8288 just got published, would you mind out trying out our new process by filing an issue over here?

  https://github.com/link-relations/registry/

Cheers,

> On 13 Oct 2017, at 7:22 am, Herbert Van de Sompel <[email-masked]> wrote:
> 
> On Thu, Oct 12, 2017 at 2:14 PM, Mark Nottingham <[email-masked] <mailto:[email-masked]>> wrote:
> If possible, we would like that indeed because there are operational and ongoing implementations of the intended relation type. These have, thus far, used "identifier" as per the discussion that was had here. But I would like to be able to get in touch asap with known developers & update the recommendations at http://signposting.org <http://signposting.org/> regarding the change from "identifier" to "cite-as". I am pretty sure that developers would appreciate knowing that the relation type will not change anymore beyond the current change from "identifier" to "cite-as". Registration of "cite-as" would significantly help with that regard.
> 
> Cheers
> 
> Herbert
> 
>  
> Cheers,
> 
> 
> > On 11 Oct 2017, at 1:49 pm, Herbert Van de Sompel <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > On Wed, Oct 11, 2017 at 1:33 PM, Mark Nottingham <[email-masked] <mailto:[email-masked]>> wrote:
> > Hi Herbert,
> >
> > > On 10 Oct 2017, at 8:59 am, Herbert Van de Sompel <[email-masked] <mailto:[email-masked]>> wrote:
> > >
> > > Dear
> > >
> > > * Reference: Van de Sompel, H., Nelson, M.L., Bilder, G., Kunze, J., and Warner, S. (August 2017) cite-as: A Link Relation to Convey a Preferred URI for Referencing. https://datatracker.ietf.org/doc/draft-vandesompel-citeas/ <https://datatracker.ietf.org/doc/draft-vandesompel-citeas/>
> > >
> > > The request to register "cite-as" on the basis of ID-00 is motivated by ongoing adoption of various patterns for using link relation types in scholarly communication, see http://signposting.org <http://signposting.org/>. As soon as "cite-as" is registered:
> > >
> > > - Documentation will be updated to reflect the change from "identifier" to "cite-as" at http://signposting.org/identifier/ <http://signposting.org/identifier/>
> > >
> > > Greetings
> > >
> > > Herbert Van de Sompel
> > >
> > > --
> > > Herbert Van de Sompel
> > > http://public.lanl.gov/herbertv/ <http://public.lanl.gov/herbertv/>
> > > http://orcid.org/0000-0002-0715-6126 <http://orcid.org/0000-0002-0715-6126>
> > >
> > > ==
> > > [email-masked] <mailto:[email-masked]>
> > > https://www.ietf.org/mailman/listinfo/link-relations <https://www.ietf.org/mailman/listinfo/link-relations>
> >
> > --
> > Mark Nottingham   https://www.mnot.net/ <https://www.mnot.net/>
> >
> >
> >
> >
> > --
> > Herbert Van de Sompel
> > http://public.lanl.gov/herbertv/ <http://public.lanl.gov/herbertv/>
> > http://orcid.org/0000-0002-0715-6126 <http://orcid.org/0000-0002-0715-6126>
> >
> > ==
> 
> --
> Mark Nottingham   https://www.mnot.net/ <https://www.mnot.net/>
> 
> 
> 
> 
> -- 
> Herbert Van de Sompel
> http://public.lanl.gov/herbertv/ <http://public.lanl.gov/herbertv/>
> http://orcid.org/0000-0002-0715-6126 <http://orcid.org/0000-0002-0715-6126>
> 
> ==

---

From: Herbert Van de Sompel <[email-masked]>
Date: Wed, 25 Oct 2017 09:14:58 -0600

On Tue, Oct 24, 2017 at 10:36 PM, Mark Nottingham <[email-masked]> wrote:

> Hi Herbert,
>
> That sounds reasonable; a bit chicken-and-egg, but I think the relation
> name is specific enough where it's pretty low risk.
>
Done. Issue at https://github.com/link-relations/registry/issues/1

Cheers

Herbert

>> OK. Normally, the registration is made as part of the publication
>> process, in the case of RFCs; I don't think we'll have any issues approving
>> this registration, given the discussion we've had.
>>
>> URI for Referencing. https://datatracker.ietf.org/d
>> oc/draft-vandesompel-citeas/
>> > >
>> > > This request to register "cite-as" is the result of a prior attempt
>> to register "identifier". Significant concerns were voiced regarding
>> scholarly communication, see http://signposting.org. As soon as
>> "cite-as" is registered:
>> > >

==