Subject: Re: [lisp] #27: ETR may claim a larger prefix than is delegated to it

From: Yakov Rekhter <[email-masked]>
Date: Mon, 4 Apr 2011 07:36:36 -0700

Dino,

> > Dino,
> >
> >> We did in -11. Here is the text at the end of section 12.
> >>
> >>    There is a potential security risk implicit in the fact that ETRs
> >>    generate the EID prefix to which they are responding.  In  
> >> theory, an
> >>    ETR can claim a shorter prefix than it is actually responsible  
> >> for.
> >>    Various mechanisms to ameliorate or resolve this issue will be
> >>    examined in the future, [LISP-SEC].
> >
> > The text should elaborate a bit on what  is exactly the "potential
> > security risk", and specifically what are some of the implications
> > of that risk.
> 
> "ETR can claim a shorter prefix than it is actually responsible for".

That still does not describe the implications of that risk.

> > Also, replace "In theory" with "Thus" (as the ETR can do this not just
> > "in theory", but in practice as well).
> 
> In practice the implementation test mask-lengths and don't install  
> coarse routes.

Please point me to the text in the draft that specifies how an
implementation can determine whether a route is "coarse".

Yakov.

> >>
> >> On Mar 30, 2011, at 8:18 AM, lisp issue tracker wrote:
> >>
> >>> #27: ETR may claim a larger prefix than is delegated to it
> >>>
> >>>
> >>> Comment(by yakov@…):
> >>>
> >>> If the base LISP spec is not going to have additional mechanisms to
> >>> address over-claiming, then I would suggest to add to the base LISP
> >>> spec
> >>> some text that would just describe the issue of over-claiming, and
> >>> state
> >>> that handling this issue is outside the scope of the document.
> >>>
> >>> -- 
> >>> ----------------------------------
> >>> +-----------------------------------------
> >>> Reporter:  hartmans-ietf@…        |        Owner:
> >>>   Type:  technical              |       Status:  resolved
> >>> Priority:  major                  |    Component:  draft-ietf-lisp
> >>> Severity:  -                      |   Resolution:  fixed
> >>> Keywords:                         |
> >>> ----------------------------------
> >>> +-----------------------------------------
> >>>
> >>> Ticket URL: <http://trac.tools.ietf.org/wg/lisp/trac/ticket/27#comment 
> >>> :5
> >>>>
> >>> lisp <http://tools.ietf.org/lisp/>
> >>> LISP WG document issues
> >>> _______________________________________________
> >>> lisp mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/lisp
> >>
> >>
> 
>

---

From: Dino Farinacci <[email-masked]>
Date: Mon, 4 Apr 2011 11:10:07 -0700

> That still does not describe the implications of that risk.

The security section talks about this risk.

> implementation can determine whether a route is "coarse".

See the security section.

Dino

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 4 Apr 2011 11:35:13 -0700

Dino,

> >>>>   generate the EID prefix to which they are responding.  In theory, an
> >>>>   ETR can claim a shorter prefix than it is actually responsible for.

Here is from the Security Considerations section of -11:

   There is a potential security risk implicit in the fact that ETRs
   generate the EID prefix to which they are responding.  In theory, an
   ETR can claim a shorter prefix than it is actually responsible for.
   Various mechanisms to ameliorate or resolve this issue will be
   examined in the future, [LISP-SEC].

The above text said *nothing* about the implications of the risk.

The above text said *nothing* about how an implementation can determine
whether a route is "coarse".

Yakov.