Subject: [lisp] gleaned mappings

From: Ronald Bonica <[email-masked]>
Date: Fri, 22 Jul 2011 15:48:02 -0400

Folks,

In Section 4.1 of the draft-ietf-lisp you say:

   In order to defer the need for a mapping lookup in the reverse
   direction, an ETR MAY create a cache entry that maps the source EID
   (inner header source IP address) to the source RLOC (outer header
   source IP address) in a received LISP packet.  Such a cache entry is
   termed a "gleaned" mapping and only contains a single RLOC for the
   EID in question.  More complete information about additional RLOCs
   SHOULD be verified by sending a LISP Map-Request for that EID.  Both
   ITR and the ETR may also influence the decision the other makes in
   selecting an RLOC.  See Section 6 for more details.

Has anyone thought through the security implications and possible unexpected side effects of these "gleaned" mappings?

                                           Ron

---

From: Dino Farinacci <[email-masked]>
Date: Fri, 22 Jul 2011 14:46:45 -0700

The spec says that gleanings are verified by sending a Map-Request to the mapping database system.

Dino

On Jul 22, 2011, at 12:48 PM, Ronald Bonica wrote:

> _______________________________________________
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp

---

From: Ronald Bonica <[email-masked]>
Date: Sun, 24 Jul 2011 10:21:05 -0400

Is that a SHOULD or a MUST? From the text quoted below, I assume that it is a SHOULD.

                                          Ron

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: Friday, July 22, 2011 5:47 PM
> To: Ronald Bonica
> Cc: [email-masked]
> Subject: Re: [lisp] gleaned mappings
> 
> > Has anyone thought through the security implications and possible
> unexpected side effects of these "gleaned" mappings?
> >
> >                                           Ron
> >
> >

---

From: Dino Farinacci <[email-masked]>
Date: Sun, 24 Jul 2011 11:07:05 -0700

> Is that a SHOULD or a MUST? From the text quoted below, I assume that it is a SHOULD.

It is a SHOULD because in controlled/trusted environments we don't want to require the overhead of a verifying Map-Request.

Dino

---

From: Damien Saucez <[email-masked]>
Date: Sun, 24 Jul 2011 15:40:40 -0400

Hello,

> Has anyone thought through the security implications and possible unexpected side effects of these "gleaned" mappings?

Gleaning can be used to leverage many attacks (see draft-ietf-lisp-threats). In
this doc, we also provide a section related only to security issues with
gleaning (Sec 7.3)

Damien Saucez

---

From: Ronald Bonica <[email-masked]>
Date: Sun, 24 Jul 2011 18:51:23 -0400

Damien,

That's a very reasonable answer. Maybe Section 4.1 of the draft-ietf-lisp should include a reference to Section 7.3 of draft-ietf-list-threats?

                                 Ron

> From: Damien Saucez [mailto:[email-masked]]
> Sent: Sunday, July 24, 2011 3:41 PM
> To: Ronald Bonica
> Cc: [email-masked]