Subject: RE: Geo pros and cons

From: "Tony Li" <[email-masked]>
Date: Wed, 2 Apr 2003 10:39:54 -0800

Marcelo,

Yes, there are regions where geo addressing makes sense.  Here
in the SF bay area, where it's hard not to trip over all of 
the fiber that we have lying around, it would play out
beautifully.  Theoretically.  

However, even in this location, where we have multiple 
interconnect points, we can observe that the local ISPs do
not choose to connect at all of the interconnects.  Some
are at Fix-W, some at Equinix, some at PAIX, etc....  Even
in this environment we are not yet at the point where geo
addressing would not require us to force particular links to
be installed.

I dunno about you, but I don't like pushing string.

Tony

|    -----Original Message-----
|    From: marcelo bagnulo [mailto:[email-masked]] 
|    Sent: Wednesday, April 02, 2003 7:14 AM
|    To: Tony Li
|    Cc: Iljitsch van Beijnum; [email-masked]
|    Subject: RE: Geo pros and cons
|    
|    
|    Hi Tony,
|    
|    [...]
|    > As we concluded many years ago: for addressing to scale, it has
|    > to match the topology.
|    
|    Fully agree.
|    I would say that the question is if topology matches 
|    geography or not.
|    
|    I have heard many claims that the Internet is becoming a dense
|    interconnection mesh. If this is true, it should be easy 
|    to determine
|    geographical areas that are interconnected, so geo 
|    aggregation works
|    without the need of more specific routes.
|    
|    I think that this is certainly not the case for all geo 
|    locations, but i
|    would say that it is probably the case for some locations 
|    as big cities
|    where a lot of users reside. Wouldn't geo addressing be 
|    suitable for
|    this situations?
|    
|    I am not aware of any analysis of how dense is the 
|    interconnection in
|    geo areas, but i would say that this input is important 
|    when considering
|    geo addressing. Does anyone have information about this?
|    
|    Thanks, marcelo
|    
|    
|    >   If addressing does not match the topology,
|    > then additional information in the form of longer 
|    prefixes must be
|    > advertised into the routing subsystem.  Ergo, if one 
|    chooses geographic
|    > address, one must force only geographically based links. 
|     Anything
|    > else destroys the aggregatability of the address 
|    assignment.  Since
|    > we, as IETF members, cannot decree where folks will connect, geo 
|    > addressing is a nice theorectical goal which is unimplementable.
|    > 
|    > Regards,
|    > Tony
|    -- 
|    marcelo bagnulo <[email-masked]>
|    uc3m
|    
|

---

From: "Tony Hain" <[email-masked]>
Date: Wed, 2 Apr 2003 11:29:32 -0800

Tony Li wrote:
> Marcelo,
> 
> Yes, there are regions where geo addressing makes sense.  
> Here in the SF bay area, where it's hard not to trip over all of 

You miss the point that the ISPs with the customers demanding PI space
would be the ones that would need to connect to the designated geo
interconnects. This aligns the economics with those creating the need.

Tony

---

From: marcelo bagnulo <[email-masked]>
Date: 03 Apr 2003 11:31:10 +0200

Hi Tony

> addressing would not require us to force particular links to

This is my question. do you have some data about the real topology that
indicates that even in areas where the interconnection is dense there
are still unconnected peers?

I agree with you in this point and I am certainly not suggesting forcing
the existence of links, just some sort of opportunistic usage of geo
aggregation. In areas where the interconnection exists, evaluate the
possibility of using geo addressing. If within the geo area the
interconnection is partitioned, just don't use it

Regards, marcelo 
-- 
marcelo bagnulo <[email-masked]>
uc3m

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 3 Apr 2003 12:38:00 +0200

On donderdag, apr 3, 2003, at 11:31 Europe/Amsterdam, marcelo bagnulo 
wrote:

> I am certainly not suggesting forcing

No, multihomers should (nearly) always use geo addresses, even if they 
can't be aggregated at that point. Then, when the network topology 
changes so that aggregation becomes possible, the end-users don't have 
to renumber.

Also note that there is no need to have areas of a fixed size. If you 
can't aggregate within Germany because the east and the west are still 
partitioned, you can at least aggregate at the Europe or western Europe 
level and spare the rest of the world from having to carry all German 
/48s.