Subject: RE: geo short vs long term? [Re: Geo pros and cons]

From: "Christian Huitema" <[email-masked]>
Date: Sun, 6 Apr 2003 11:27:43 -0700

The lessons are pretty clear. I remember a time, not so long ago, when the shortest path from France to the UK actually was through Princeton, and the shortest path from some parts of France to other parts was through either Amsterdam or Geneva. The reality is that network topology is primarily driven by network economics, which themselves are only modestly driven by geography. 
 
In theory, it seems easier to lay fiber over short distances, but this is one of those cases where the difference between theory and practice is even greater in practice than in theory. In practice, you get into things like right of ways that prevent crossing streets, traffic pattern that are not local, satellites that don't particularly care about imediate proximity, or the simple fact that laying fiber accross a body of water is simpler that doing the same accross a mountain ridge. Then, you get competition between providers, and all sorts of non technical reasons such as trust, business affinity, etc. 
 
By the way, these non technical reasons apply also to various "virtual addressing" schemes that propose to use a provider independent overlay on top of a provider addressed network. Any kind of virtual aggregation is much more likely to be centered on business relations than on geography.

________________________________

From: Iljitsch van Beijnum [mailto:[email-masked]]
Sent: Sun 4/6/2003 10:40 AM
To: Randy Bush
Cc: Joe Abley; [email-masked]
Subject: Re: geo short vs long term? [Re: Geo pros and cons]

On zondag, apr 6, 2003, at 15:48 Europe/Amsterdam, Randy Bush wrote:

>> Trying to get something right that was done wrong in the past isn't
>> "repeating".

> not taking lessons from history and physical reality is naive at best,
> and dangerous at worst.

Is it really that hard to let go of preconceived notions?

The only "lessons from history" I can find are discussions that went
nowhere because neither party bothered to get into enough detail to see
if something useful could be done or not. Physical reality is that
every meter of fiber costs money. There are only two cost-effective
ways to connect networks: over the shortest possible distances, or by
aggregating as much traffic and as many logical connections over a
single circuit as possible. Both allow good geographical aggregation.

---

From: Kurt Erik Lindqvist <[email-masked]>
Date: Mon, 7 Apr 2003 22:53:34 +0200

> In theory, it seems easier to lay fiber over short distances, but this 
> is one of those cases where the difference between theory and practice 
> is even greater in practice than in theory. In practice, you get into 
> things like right of ways that prevent crossing streets, traffic 
> pattern that are not local, satellites that don't particularly care 
> about imediate proximity, or the simple fact that laying fiber accross 
> a body of water is simpler that doing the same accross a mountain 
> ridge. Then, you get competition between providers, and all sorts of 
> non technical reasons such as trust, business affinity, etc.
>

 From my experience in building pan-continental networks, traffic tend 
to be very optimized within the network. Where it leaves is as you say 
a completely different question.

- kurtis -

---

From: George Michaelson <[email-masked]>
Date: Tue, 8 Apr 2003 12:09:37 +1000

On Sun, 6 Apr 2003 11:27:43 -0700 "Christian Huitema"
<[email-masked]> wrote:

>  
> By the way, these non technical reasons apply also to various "virtual
> addressing" schemes that propose to use a provider independent overlay on top
> of a provider addressed network. Any kind of virtual aggregation is much more
> likely to be centered on business relations than on geography.

Christian, as a confessed partisan supporter of some aspects of geographic
addressing I think I can argue that virtual aggregation by layered/overlay
networks is *neutral* for both business relations-based networking and
geographic address assignment models.

Can you be more explicit why overlay models favour one schema for address
deployment more than another? 

The AP region has sub-registries under the regional registry which do, in
practice hand out resource along economic/national boundaries. I do not think we
should be arguing that *no* national/geo takes place, it clearly does. Maybe we
should be asking more direct questions about the impact and effects. Layer-9
stuff reaching down into layer-3 and 2?

There might be valid issues/concerns in the effects it has on connectivity and
vice-versa, and equally valid observations to be made about the net effects on
routing table complexity.

I am probably over-optimistic about the benefits. But can I suggest that some of
the opponents are equally over pessimistic?

cheers
	-George

-- 
George Michaelson       |  APNIC
Email: [email-masked]    |  PO Box 2131 Milton QLD 4064
Phone: +61 7 3367 0490  |  Australia
  Fax: +61 7 3367 0482  |  http://www.apnic.net

---

From: Michael Richardson <[email-masked]>
Date: Tue, 08 Apr 2003 15:27:45 -0400

>>>>> "George" == George Michaelson <[email-masked]> writes:
    George> should be asking more direct questions about the impact and
    George> effects. Layer-9 
    George> stuff reaching down into layer-3 and 2?

  A question: assuming no installed base, and a layer-9 that can be mutable
in any fashion we want,  (I.e. we live on a planet with a uniform,
homogeneous landmass, with a uniform distribution of multihomers), is there a
multihoming solution within the constraints of our requirements that we can
agree upon? 

  This is a serious question. 

  Now, if there is such a solution, can we adequately describe the boundaries
of its applicability? 

]       ON HUMILITY: to err is human. To moo, bovine.           |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another Debian GNU/Linux using, kernel hacking, security guy"); [

---

From: Sean Doran <[email-masked]>
Date: Wed, 16 Apr 2003 04:15:36 +0100

On Tuesday, Apr 8, 2003, at 20:27 Europe/London, Michael Richardson 
wrote:

> is there a multihoming solution within the constraints of our 
> requirements that we can
> agree upon?
>

The only honest answer is: no, not yet.

The problem is not exclusive to the "we can agree upon" part of your 
question, either.

Sorry,

	Sean. (serious answer)