Subject: RE: geo short vs long term? [Re: Geo pros and cons]

From: "Tony Li" <[email-masked]>
Date: Thu, 17 Apr 2003 10:26:58 -0700

|    In any multiaddressing scheme, there must be a point where 
|    a single 
|    "handle", be it an address, an FQDN, a control block or 
|    what have you, 
|    is tied to two or more paths through the network. There 
|    are many ways 
|    to do this:
|    
|    - let the applications handle it (SMTP, DNS)
|    - let the network layer handle it (MIP)
|    - let the transport layer handle it (SCTP)
|    - let a middlebox or border router handle it (MHAP)
|    
|    GSE isn't easily classified here as transport, network and border 
|    routers all need to play their part.

?  GSE would require the middlebox to handle it, plus changes to DNS
and modifications to transport protocols to use only the identifier
as part of the pseudoheader.

Tony

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 17 Apr 2003 19:45:36 +0200

> as part of the pseudoheader.

Ignoring the DNS for a moment... I think the original GSE called for 
the border routers to rewrite packets, but this could nearly as easily 
happen in a middlebox, or even in the host itself.

I guess it would be possible to do this without changing the network 
layer but I wouldn't bet on it.