Subject: RE: geo short vs long term? [Re: Geo pros and cons]

From: "Tony Li" <[email-masked]>
Date: Thu, 17 Apr 2003 10:59:29 -0700

|    Ignoring the DNS for a moment... I think the original GSE 
|    called for 
|    the border routers to rewrite packets, but this could 
|    nearly as easily 
|    happen in a middlebox, or even in the host itself.

While those locations are not impossible, the most natural place
for it is in the border router or the provider edge router.

|    I guess it would be possible to do this without changing 
|    the network 
|    layer but I wouldn't bet on it.

I don't believe that it's a requirement to change the syntax
of the network layer header.  The semantics, of course, must 
change.  IMHO, this is a good thing.

Tony

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Thu, 17 Apr 2003 20:19:06 +0200

> for it is in the border router or the provider edge router.

So how would intra-site routing work? By clearing the 45 routing bits 
when the packet arrives at the edge?

> |    the network layer but I wouldn't bet on it.

> change.  IMHO, this is a good thing.

Why is this good?

In earlier discussions, I think we (that is, at least some of us) 
reached the conclusion that a 16+16 mechanism, where we have something 
that looks enough like a regular IPv6 unicast address to be forwarded 
by existing routers, would be similar in nature, but easier to deploy 
than 8+8 and presumably also 5.625+6.375.