Subject: Fwd: [Ans-research] IRTF ANS Meeting Announcement

From: S Woodside <[email-masked]>
Date: Sat, 31 May 2003 23:59:39 -0400

I'm curious if a large adhoc network would have special multihoming 
requirements that multi6 might consider? Put together, scalable adhoc 
networks with the ability to multihome in a decentralized manner would 
be a very desirable technology for building flexible wireless networks 
for last-mile (urban) / last 15 miles (rural) access.

simon

Begin forwarded message:

> From: Elizabeth Belding-Royer <[email-masked]>
> Date: Thu May 29, 2003  8:11:49  PM America/Montreal
> To: [email-masked], [email-masked]
> Cc: [email-masked], [email-masked]
> Subject: [Ans-research] IRTF ANS Meeting Announcement
>
> Hi,
>
> The first meeting of the new IRTF Ad hoc Network Scalability (ANS)
> research group will occur this Sunday at the Mobihoc conference
> hotel.  Included is the agenda for this meeting.  This is a somewhat
> fluid agenda as we are still finalizing the speakers.  However,
> the meeting will definitely start at 7pm Sunday evening.  We look
> forward to seeing many of you at the meeting.
>
> Scott and Elizabeth
>
> *****************************************************************
>
>
> Date: Sunday, June 1, 2003
> Time: 7-10pm
> Location: Sheraton Barcelo Hotel (Mobihoc hotel)
>   I don't have the exact room at the moment - an email will be
>   sent later with that information.
>
>
> Scott and Elizabeth (10 min)
>   - Welcome
>   - Overview of research group charter, objectives
>
> Scott and Elizabeth (30 min)
>   - Recap of mailing list discussion on direction of research group
>   - Group discussion on direction/objectives
>
> Presentations
>
>  * Zygmunt Haas (20 min)
>    - Hybridization and Adaptivity as Means to Scalability
>    - Scalability Bounds in Wireless Networks
>
>  * Joe Macker (15 min)
>    - Link state scaling approaches
>
>  * Mario Gerla (15 min)
>    - Routing approaches and scalability metrics.
>
>  * Radha Poovendran (15 min)
>    - Greedy Perimeter Routing
>
>  * Christian Bettstetter (15 min)
>    - Interconnection of Ad hoc Networks to IPv6 Networks
>
> Open Forum for Discussions (1 hour)
>
>
>
>
> _______________________________________________
> Ans-research mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ans-research
>
>

--
      anti-spam: do not post this address publicly
www.simonwoodside.com -- 99% Devil, 1% Angel

---

From: Pekka Savola <[email-masked]>
Date: Sun, 1 Jun 2003 09:09:57 +0300 (EEST)

> for last-mile (urban) / last 15 miles (rural) access.

Perhaps it would be best to first try to figure out how single-homed 
internet connectivity would work :-).

But really, it's still a question on how you delegate the information 
about prefixes and choose your subnets.

For the multihomed case with multiple PA prefixes, I guess this would mean 
that every MANET node would have a fixed, unique-in-the-MANET site 
identifier (or multiple of them).  This could be used for delegating 
addresses and ensuring multiple nodes don't get weird ideas which parts of 
/48's they could use.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: S Woodside <[email-masked]>
Date: Sun, 1 Jun 2003 03:42:08 -0400

> internet connectivity would work :-).

This is done, fortunately, for a small mesh at least. Unfortunately, 
the system uses centralized management to configure which (single) 
gateway each node uses (the system is meshAP, the management is called 
wiana). I don't think management is necessary though. AODV should be 
capable of handling single-homing by having the gateway node route all 
of the external packets. The existing adhoc protocol would handle the 
rest.

> addresses and ensuring multiple nodes don't get weird ideas which 

Starting with a simplistic analysis, the nodes would not know the MANET 
is multihomed. The gateways could each all advertise the external 
network. It's possible that a MANEt protocol would be able to handle 
this, if it selects (for example) the first path that returns a route. 
In that case nodes would probably route to the outside through the 
closest gateway node.

Or, the gateway nodes could discover each other and set up tunnels over 
the MANET to coordinate which sections of the external network they 
will each advertise in the MANET. That will add overhead and complexity.

Or, I think what you're saying is, that each NODE would know about all 
of the gateways, and which prefix they have, and make its own decisions 
about which to use. That would require some additional information in 
the MANET protocol to essentially separate identity and locator, to 
allow multiple gateway nodes to advertise the same identities, but with 
different locators.

(if I'm not totally confused. I just read RFC 2101)

simon