Subject: RE: Source address selection in IPv6 multihomed multi-addressed sites

From: "Christian Huitema" <[email-masked]>
Date: Thu, 17 Jul 2003 07:31:36 -0700

I certainly did not say that the choice should be handled "by default in the IP layer". I said that it is typically handled by the TCP-IP stack, after the application binds to ANY. But TCP-IP stack != IP layer. The IP layer only starts operating when both source and destination have been chosen..

________________________________

From: [email-masked] on behalf of Brian E Carpenter
Sent: Thu 7/17/2003 2:22 AM
To: [email-masked]
Subject: Re: Source address selection in IPv6 multihomed multi-addressed sites

Kenji Ohira wrote:
...
> First of all, I think that source address selection should be made by each
> application/transport layer.

As I and Keith Moore and Christian Huitema have been trying to say,
this is not realistic as a general case. In some special cases we can
expect upper layers to be able to do this, but it has to be handled
by default in the IP layer.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 Jul 2003 20:08:33 +0200

Christian,

I'm sorry to have over-interpreted what you said. I should probably
have written "...should be handled by default below the socket API."

   Brian