Subject: [multimob] PMIP MC handover -- some thoughts

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 19 Jan 2012 10:32:01 -0600

Hi all,

It is time to discuss our fast handover charter item and the proposed
approaches.

I copied below what Marco wrote on the list on Sept. 7, 2011.
To Marco's points, I am adding one more as the last one below.

I think that there is consensus on these points.

- Why FHO-like forwarding between MAGs is beneficial for multicast?
  It puts assumptions on inter-MAG operation and introduces overhead which
  should be justified.

- Does performance really benefit from forwarding? What's a typical use case:
  Video broadcast, for example. Streaming applications may have some
  buffered packets on the player. How does packet drop during handover
  impact QoE compared to FHO-like forwarded MC packets? I guess they
  have to be buffered at the target MAG before they can be delivered to
  the MN, so latency is introduced whereas only packet drop is reduced.

- Is packet re-ordering an issue (forwarded packets between MAGs vs direct
  packets)? Well, RTP may help on the player if it’s used. Or is re-ordering
  resolved on the MAG by means of scheduled delivery to the MN?

- Maybe CTX of multicast context is sufficient. Proactive CTX may help.
  Whereas the benefit of reactive CTX needs to be compared against the
  performance of the Multimob base approach for PMIPv6

- If forwarding between MAGs is adopted, we may consider it optional

- If forwarding between MAGs is not really beneficial, what is the
right way for CTX?
  2 approaches are being discussed: inter-MAG CTX (as per RFC4067) and
  CTX via LMA. Can we assume efficient paths between MAGs in operator
  networks? CTX via LMA puts less assumptions on SAs between MAGs and
  link characteristics between MAGs. In particular beneficial when LMA
  stores some multicast context.

- Transferring context assumes that multicast state can be established
at the proxy/querier
without receiving corresponding join messages from MNs. This is an
extension to MLD.

Regards,

Behcet

---

From: <[email-masked]>
Date: Tue, 31 Jan 2012 17:25:40 +0100

Hi Behcet,
I think you have already summarized some comments from our discussion in September (e.g. by Luis). Good point added regarding required MLD extension ... Thanks!
I'll try to add my thoughts - hopefully not doubling too much from last year's arguments - please see below:

Best regards
Dirk

Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Behcet Sarikaya
Gesendet: Donnerstag, 19. Januar 2012 17:32
An: [email-masked]
Betreff: [multimob] PMIP MC handover -- some thoughts

Hi all,

> Dirk: Right - the expected performance improvement is not for free in terms of complexity and protocol extensions (incl. MLD). Thus we have to argue with dedicated services which benefit from disruption-free mobile multicast receiption and may be asked for in large amount  so that multicast will be economically viable

> Dirk: Agreed - the buffered content is received with delay, but since in pure multicast it would be lost to the mobile receiver otherwise, this is a gain.
Thanks to increased processing power and storage capacity at handhelds the streamed IP Video is either already buffered at the terminal so a medium delay might be unnoticeable to the consumer (or he is anyway storing the video content for later consumption since on the move he cannot focus on viewing).
But other broad- or multicast services like large scale synchronisation (social network data, anti virus sw updates, newsfeed distribution, ...) demand mainly error-free delivery rather than real-time character

- Is packet re-ordering an issue (forwarded packets between MAGs vs direct
  packets)? Well, RTP may help on the player if it's used. Or is re-ordering
  resolved on the MAG by means of scheduled delivery to the MN?

> Dirk: Yes, and if the actual serving MAG is controling forwarding from previous one the direct packets will be correspondingly postponed

> Dirk: Again this depends on the application/use case - base Multimob does not care for lost packets during handover, right?

> Dirk: I tend to agree with Luis - subscription forwarding is more important than content forwarding

> Dirk: agree that LMA-MAG can already be assumed as established whereas for inter-MAG tunnel we need to set up. But if MAGs are owned by same operator and we think of a future scenario: LMAs may be quite centralized to save deployment and operational costs - so the delay and burden of processing all multicast contexts might be great. On the other hand future base stations (e.g. 3GPPs LTE-Advanced, but perhaps also 802.11..?) need direct links to synchronize and exchange link state information anyway (e.g. for Coordinated multi-point (CoMP), Multicell MIMO) so they could be re-used ...

> Dirk: I am afraid you are right  - unless it is possible for the pMAG or LMA to act on behalf the MN and kind of 'spoof the MN join message' ...? ;-)

Regards,

Behcet
_______________________________________________
multimob mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multimob