Subject: [multimob] I-D Action: draft-ietf-multimob-fast-handover-00.txt

From: [email-masked]
Date: Tue, 22 May 2012 07:30:28 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Multicast Mobility Working Group of the IETF.

	Title           : PMIPv6 multicast handover optimization by the Subscription Information Acquisition through the LMA (SIAL)
	Author(s)       : Luis M. Contreras
                          Carlos J. Bernardos
                          Ignacio Soto
	Filename        : draft-ietf-multimob-fast-handover-00.txt
	Pages           : 37
	Date            : 2012-05-22

   This document specifies a multicast handover optimization mechanism
   for Proxy Mobile IPv6 to accelerate the delivery of multicast traffic
   to mobile nodes after handovers.  The mechanism is based on speeding
   up the acquisition of mobile nodes' active multicast subscriptions
   information by the mobile access gateways.  To do that, extensions to
   the current Proxy Mobile IPv6 protocol are proposed.  These
   extensions are not only applicable to the base solution for multicast
   support in Proxy Mobile IPv6, but also can be applied to other
   solutions envisioned as possible architectural evolutions of it.
   Furthermore, they are also independent of the role played by the
   mobile access gateway within the multicast network (either acting as
   multicast listener discovery proxy or multicast router).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-multimob-fast-handover-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-multimob-fast-handover-00.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-multimob-fast-handover/

---

From: LUIS MIGUEL CONTRERAS MURILLO <[email-masked]>
Date: Tue, 22 May 2012 16:56:47 +0200

Dear colleagues,

We have produced the -00 version of the WG draft on fast handover.

Some comments received on the list have not been yet addressed so far, but our intention is to include the following material in -01 version once discussed/agreed on the list:

.- Hitoshi's comments regarding MLD filter information: we plan to include the MLD filter information on the messages to help the nMAG to get knowledge of the MN's on-going subscription. The original idea of the draft was to optimize (if possible) the information passed among entities by transferring the minimal information to help during the handover process. In our opinion it is worthy to explore that way, but including the MLD filter information can be seen as the regular solution.

.- Hitoshi's comment on message format conforming RFC3810: this is linked with the comment above, and it would be addressed, as well.

.- Hitoshi's comment on RAMS acronym: we have already changed from RAMS to SIAL = Subscription Information Acquisition through the LMA to avoid confusion with RAMS meaning on the context of the AVT, and to better address the nature of the solution, providing space to further solutions based on MAG to MAG direct communication.

.- Dirk's comment on performance evaluation: we are open to include some comparison to RFC6224 as guideline for solution deployment.

Apologies if we have left some comment not yet covered.

Of course, any new comment is more than welcome.

Thanks in advance,

Best regards,

Luis

-----Mensaje original-----
De: [email-masked] [mailto:[email-masked]] En nombre de [email-masked]
Enviado el: martes, 22 de mayo de 2012 16:30
Para: [email-masked]
CC: [email-masked]
Asunto: [multimob] I-D Action: draft-ietf-multimob-fast-handover-00.txt

_______________________________________________
multimob mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/multimob

Este mensaje se dirige exclusivamente a su destinatario. Puede consultar nuestra política de envío y recepción de correo electrónico en el enlace situado más abajo.
This message is intended exclusively for its addressee. We only send and receive email on the basis of the terms set out at
http://www.tid.es/ES/PAGINAS/disclaimer.aspx

---

From: <[email-masked]>
Date: Wed, 30 May 2012 10:02:09 +0200

Dear Luis, all
Sorry for my delayed response. I am fine with your porposal, thanks for that. As suggested
I'd like to propose some text for an annex on performance comparison between both proactive, reactive SIAL and RFC 6224 in terms of amount and length (# of Bytes) of messages exchanged between MN and MAG, and between MAG and LMA, and the impact on expected end-to-end delay (between service stop at start of HO and service resumption at HO completion) for different typical messsage exchange delays on MN-MAG and MAG-LMA path (same for LMA-pMAGand LMA-nMAG). Hope this is what you also had in mind, otherwise please correct me.
As a first approach I would assume
- 4 msgs with 84 bytes length on MN-MAG and 3 msgs with 64 B on LMA-MAG for RFC 6224,
- 2 msgs with 92 bytes length on MN-MAG and 5 msgs with 65.2 B on LMA-MAG for proactive SIAL,
- 2 msgs with 92 bytes length on MN-MAG and 5 msgs with 76 B on LMA-MAG for reactive SIAL.
(I'll have to check whether those data are still valid since I compiled them some time ago)

Corresponding to your paper (Contreras L. M., Bernardos, C. J., and I. Soto, "RAMS: A Protocol Extension to PMIPv6 for Improving Handover Performance of Multicast Traffic", Journal of Wireless Mobile Networks, Ubiquitous Computing, and Dependable Applications, Vol. 2, No. 2, pp. 67-82, 2011) I would suggest to consider an average MN-MAG delay of 65.3 ms (UTRAN) and the backhaul (MAG-LMA) delay of 5 ms.
However for LTE also lower RAN delay of 5 ms could be assumed.
Do you think that makes sense?
Best regards
Dirk

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von LUIS MIGUEL CONTRERAS MURILLO
Gesendet: Dienstag, 22. Mai 2012 16:57
An: [email-masked]
Betreff: Re: [multimob] I-D Action: draft-ietf-multimob-fast-handover-00.txt

Dear colleagues,

Thanks in advance,

Best regards,

Luis