Subject: Re: [multimob] Direct Multicast Routing & the Deployment of PIM-SM(Juan Liu)

From: [email-masked]
Date: Thu, 2 Aug 2012 10:27:04 +0800

Hi Thomas,
Please see inline: 

[email-masked] 写于 2012/08/02 07:02:01:

> If you have received this digest without all the individual message
> attachments you will need to update your digest options in your list
> subscription.  To do so, go to 
> 
> https://www.ietf.org/mailman/listinfo/multimob
> 
> Click the 'Unsubscribe or edit options' button, log in, and set "Get
> MIME or Plain Text Digests?" to MIME.  You can set this option
> globally for all the list digests you receive at this point.
> 
> 
> 
> Send multimob mailing list submissions to
>    [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    https://www.ietf.org/mailman/listinfo/multimob
> or, via email, send a message with subject or body 'help' to
>    [email-masked]
> 
> You can reach the person managing the list at
>    [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of multimob digest..."
> 
> 
> Today's Topics:
> 
>    1.  Direct Multicast Routing & the Deployment of PIM-SM
>       (Thomas C. Schmidt)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Wed, 01 Aug 2012 16:01:56 -0700
> From: "Thomas C. Schmidt" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Subject: [multimob] Direct Multicast Routing & the Deployment of
>    PIM-SM
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-15; format=flowed
> 
> Hi all,
> 
> after Monday's presentation of PIM deployment options 
> (draft-ietf-multimob-pmipv6-source), there was the discussion on further 

> optimization options. In detail, the idea was raised to reach MNs not 
> via their (permanent) HNP advertisements at the LMA, but directly at 
> their current MAGs. The latter would require a dynamic unicast routing 
> protocol in the access network.
In order that multicast traffic reach MNs directly via MAG-MAG tunnel not
via LMA-MAG tunnel,MRIB can be constructed using route from the tunnel 
between MAGs(draft-liu-multimob-pmipv6-multicast-ro).
> 
> I promised to talk to Sri about this (underlying unicast) approach. As 
> expected, Sri emphasized that the PMIP WGs intentionally do *not* 
> consider this a working option. The reason is that node mobility 
> typically is more intense and faster than unicast routing dynamics. 
> Advertising MN's HNPs throughout the access network would cause route 
> pollution and convergence problems and quickly lead to inconsistencies. 
> For the unicast case, this is the equivalent of pushing multicast 
> mobility management into multicast routing, which we equally avoid.
About the working option you talk with Sri,does it refer to direct routing 
via MAGs,
which in PMIP WG unicast routing through MAG-MAG tunnel is an acceptable 
optimization
options for PMIPv6 routing. Hope i'm not wrong about this.
I agree that advertising MN's HNPs throughout the access network would 
cause various 
problems, which our draft does not involve.
> 
> Consequently, the deployment of PIM-SM in the access network (at MAGs) 
> cannot be better than presented: The (MRIB) route to a (non-local) MN 
> must be via its corresponding LMA, and we actually do not gain anything 
> over the Proxy approach when using PIM-SM at MAGs. On the contrary, as 
> we discussed on Monday, the PIM self-organization (phase transitions) 
> will produce significant overhead for mobile sources (with likely 
> convergence issues) why I would not opt for using PIM-SM other than in 
> Phase 1.
I agree that phase2 and phase3 of PIM-SM cause significant signaling 
overhead for mobile
source. But in case phase2 and phase3 carry out our draft can be a 
optimization
option for phase3.
Besides our draft mainly focus on PIM-SSM scenario.

What do you think,Thomas. Hope to work with you.
Best regards,
Juan Liu
> 
> Cheers,
> 
> Thomas
> -- 
> 
> Prof. Dr. Thomas C. Schmidt
> ? Hamburg University of Applied Sciences                   Berliner Tor 
7 ?
> ? Dept. Informatik, Internet Technologies Group    20099 Hamburg, 
Germany ?
> ? http://www.haw-hamburg.de/inet                   Fon: 
+49-40-42875-8452 ?
> ? http://www.informatik.haw-hamburg.de/~schmidt    Fax: 
+49-40-42875-8409 ?
> 
> 
> ------------------------------
> 
> _______________________________________________
> multimob mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multimob
> 
> 
> End of multimob Digest, Vol 63, Issue 2
> ***************************************
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Wed, 01 Aug 2012 19:45:40 -0700

Hi Juan Liu,

please see inline.

> between MAGs(draft-liu-multimob-pmipv6-multicast-ro).

The scenario of your draft is a completely different one: If I
understood correctly, you distribute traffic in an overlay. (construct a
mesh of tunnels between MAGs, inquire routes to MNs via an LMA-based
on-demand search and then select the proper tunnel for forwarding).

This is different from what we refer to by the term "direct (or
localized) routing".

> About the working option you talk with Sri,does it refer to direct 
> routing via MAGs,

We didn't talk about overlay solutions. We just addressed the
straight-forward deployment of dynamic unicast routing protocols like
iBGP or OSPF. So nothing was said about your draft.

Best regards,

Thomas

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °