Subject: Re: [multimob] Direct Multicast Routing & the Deployment of PIM-SM(Juan Liu)

From: [email-masked]
Date: Thu, 2 Aug 2012 13:17:02 +0800

Hi Thomas,

Thank you for your answer, please see inline:

[email-masked] 写于 2012/08/02 10:45:44:

> If you have received this digest without all the individual message
> attachments you will need to update your digest options in your list
> subscription.  To do so, go to 
> 
> https://www.ietf.org/mailman/listinfo/multimob
> 
> Click the 'Unsubscribe or edit options' button, log in, and set "Get
> MIME or Plain Text Digests?" to MIME.  You can set this option
> globally for all the list digests you receive at this point.
> 
> 
> 
> Send multimob mailing list submissions to
>    [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    https://www.ietf.org/mailman/listinfo/multimob
> or, via email, send a message with subject or body 'help' to
>    [email-masked]
> 
> You can reach the person managing the list at
>    [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of multimob digest..."
> 
> 
> Today's Topics:
> 
>    1. Re:  Direct Multicast Routing & the Deployment of   PIM-SM(Juan
>       Liu) (Thomas C. Schmidt)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Wed, 01 Aug 2012 19:45:40 -0700
> From: "Thomas C. Schmidt" <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [multimob] Direct Multicast Routing & the Deployment of
>    PIM-SM(Juan Liu)
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=GB2312
> 
> Hi Juan Liu,
> 
> please see inline.
> 
> On 01.08.2012 19:27, [email-masked] wrote:
> 
> >> Message: 1
> >> Date: Wed, 01 Aug 2012 16:01:56 -0700
> >> From: "Thomas C. Schmidt" <[email-masked]>
> >> To: "[email-masked]" <[email-masked]>
> >> Subject: [multimob] Direct Multicast Routing & the Deployment  of
> >>    PIM-SM
> >> Message-ID: <[email-masked]>
> >> Content-Type: text/plain; charset=ISO-8859-15; format=flowed
> >>
> >> Hi all,
> >>
> >> after Monday's presentation of PIM deployment options
> >> (draft-ietf-multimob-pmipv6-source), there was the discussion on 
further
> >> optimization options. In detail, the idea was raised to reach MNs not
> >> via their (permanent) HNP advertisements at the LMA, but directly  at
> >> their current MAGs. The latter would require a dynamic unicast 
routing
> >> protocol in the access network.
> 
> > In order that multicast traffic reach MNs directly via MAG-MAG tunnel 
not
> > via LMA-MAG tunnel,MRIB can be constructed using route from the tunnel
> > between MAGs(draft-liu-multimob-pmipv6-multicast-ro).
> 
> The scenario of your draft is a completely different one: If I
> understood correctly, you distribute traffic in an overlay. (construct a
> mesh of tunnels between MAGs, inquire routes to MNs via an LMA-based
> on-demand search and then select the proper tunnel for forwarding).
Yes, you are right.
> 
> This is different from what we refer to by the term "direct (or
> localized) routing".
This is somewhat similar to LR solution in the sense of routing via
MAG-MAG tunnel.
> 
> >>
> >> I promised to talk to Sri about this (underlying unicast) approach. 
As
> >> expected, Sri emphasized that the PMIP WGs intentionally do *not*
> >> consider this a working option. The reason is that node mobility
> >> typically is more intense and faster than unicast routing dynamics.
> >> Advertising MN's HNPs throughout the access network would cause route
> >> pollution and convergence problems and quickly lead to 
inconsistencies.
> >> For the unicast case, this is the equivalent of pushing multicast
> >> mobility management into multicast routing, which we equally avoid.
> 
> > About the working option you talk with Sri,does it refer to direct 
> > routing via MAGs,
> > which in PMIP WG unicast routing through MAG-MAG tunnel is an 
acceptable 
> > optimization
> > options for PMIPv6 routing. Hope i'm not wrong about this.
> 
> We didn't talk about overlay solutions. We just addressed the
> straight-forward deployment of dynamic unicast routing protocols like
> iBGP or OSPF. So nothing was said about your draft.
Now i see :)

Then will it be possible to adopt our overlay solution as the optimization 

option with your draft?

Best regards,
Juan Liu

> 
> Best regards,
> 
> Thomas
> 
> -- 
> 
> Prof. Dr. Thomas C. Schmidt
> ? Hamburg University of Applied Sciences                   Berliner Tor 
7 ?
> ? Dept. Informatik, Internet Technologies Group    20099 Hamburg, 
Germany ?
> ? http://www.haw-hamburg.de/inet                   Fon: 
+49-40-42875-8452 ?
> ? http://www.informatik.haw-hamburg.de/~schmidt    Fax: 
+49-40-42875-8409 ?
> 
> 
> ------------------------------
> 
> _______________________________________________
> multimob mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multimob
> 
> 
> End of multimob Digest, Vol 63, Issue 4
> ***************************************
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Wed, 01 Aug 2012 23:01:47 -0700

Hi Juan Liu,

thanks - please see inline.

On 01.08.2012 22:17, [email-masked] wrote:

>> >> (draft-ietf-multimob-pmipv6-source), there was the discussion  on further
>> >> their current MAGs. The latter would require a dynamic unicast  routing
>> > In order that multicast traffic reach MNs directly via MAG-MAG  tunnel not
>> >> I promised to talk to Sri about this (underlying unicast)  approach.  As
>> >> pollution and convergence problems and quickly lead to inconsistencies.
>> > which in PMIP WG unicast routing through MAG-MAG tunnel is an  acceptable
>> > optimization

Please allow some time to study your proposal in detail. We'll try to 
provide a review soon.

Best regards,

Thomas

>> ? Hamburg University of Applied Sciences           Berliner Tor 7 ?
>> ? Dept. Informatik, Internet Technologies Group    20099  Hamburg, Germany ?
>> ? http://www.haw-hamburg.de/inet         Fon: +49-40-42875-8452 ?
>> ? http://www.informatik.haw-hamburg.de/~schmidt    Fax:  +49-40-42875-8409 ?
>>
>>

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: [email-masked]
Date: Thu, 2 Aug 2012 14:28:48 +0800

Hi Thomas,

Many thanks.
We will be very willing to improve our document accoring to your comments.
Look forward to coorperate with you.

Best Regards,
Juan Liu

"Thomas C. Schmidt" <[email-masked]> 写于 2012/08/02 

further
routing
inconsistencies.
acceptable
> > ZTE Information Security Notice: The information contained in this
> mail (and any attachment transmitted herewith) is privileged and 
> confidential and is intended for the exclusive use of the 
> addressee(s).  If you are not an intended recipient, any disclosure,
> reproduction, distribution or other dissemination or use of the 
> information contained is strictly prohibited.  If you have received 
> this mail in error, please delete it and notify us immediately.
> >
> >
> >