Subject: Re: [multimob] Adoption of HO drafts incl. draft-schmidt-multimob-fmipv6-pfmipv6-multicast

From: "Thomas C. Schmidt" <[email-masked]>
Date: Wed, 01 Aug 2012 13:18:52 -0700

Hi Hitoshi,

you basically re-raise discussions again from more than two years ago: 
We have given credit to previous work on the subject, which albeit never 
has been more than a rough sketch.

The key fact is that draft-schmidt-multimob-fmipv6-pfmipv6-multicast is 
the only fully worked out solutions for Handover Acceleration so far, 
and more importantly, it has been finished and ready for progress since 
*2010*.

The typical goal of an IETF working group is to progress mature 
documents that are of good technical quality and on charter ... not 
doing so may may of course have political or personal reasons ...

Cheers,

Thomas

On 31.07.2012 22:01, Hitoshi Asaeda wrote:
> Thomas,
>
>>> We did have, apart from
>>> draft-schmidt-multimob-fmipv6-pfmipv6-multicast, several other
>>> multicast handover solution drafts such as:
>>> http://tools.ietf.org/html/draft-vonhugo-multimob-cxtp-extension-01
>>
>> This draft basically uses the context transfer protocol (RFC4067) to
>> carry multicast state between ARs/MAGs. No full handover operations
>> have been specified.
>
> It is because this draft inherits the basic operation from rfc4067 and
> hence no need to repeat to write it. The main aim of this draft is to
> define the message format for multicast context transfer with CXTP.
> Of course, if something is missing and required to clarify in the
> document, the authors will try to improve the document quality, I
> believe.
>
>> At the unicast side, RFC4067 is a predecessor of the more advanced
>> Fast Handover Protocols does not apply to unicast handover
>> management.... IMO it does not make much sense to consider this rather
>> elementary approach any further.
>>
>>> http://tools.ietf.org/html/draft-hui-multimob-fast-handover-04
>>>
>>
>> This draft is - if you want so - a competitor to
>> draft-schmidt-multimob-fmipv6-pfmipv6-multicast, but has never been
>> worked out (as have several other attempts in the past). If this
>> document was to be advanced, it had to rewrite (or copy ??) 80 % of
>> our draft, which is not a proper way to treat authorship.
>
> The -00 version of draft-hui was published on June 29, 2009.
> Your -00 draft was published on March 01, 2010.
> (I just tell the fact.)
>
>>> If we decide to accept more than one handover solution then we
>>> probably need to consider all of them for possible WG adoption.
>>
>> I don't understand your thinking here: it is perfectly normal that
>> there are competing approaches and the idea of the IETF discussion is
>> to have the best solution win. From the performance side, and from
>> protocol systematics (cooperation with unicast),
>> draft-schmidt-multimob-fmipv6-pfmipv6-multicast is clearly the best
>> solution for fast handover operations - this comparison includes the
>> adopted draft "fast handover from transient binding".
>
> If only one HO document is needed, then since this WG has already been
> working for SIAL proposal, other documents (including yours) related
> to HO are not needed, are they?
>
> Furthermore I don't think all mobile operators in the world adpot only
> FPMIPv6 as their business. So, if other idea is useful and technically
> correct, documenting it is reasonable.
>
> This is just my feeling.
>
> Regards,
> --
> Hitoshi Asaeda
> _______________________________________________
> multimob mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/multimob
>

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: <[email-masked]>
Date: Thu, 9 Aug 2012 10:04:49 +0000

Hi Behcet, Hi all,

I agree that we should be open for the WG adoption of more than one individual drafts that are focussing in the multicast handover optimization.  Furthermore, I also agree to investigate whether more individual drafts could be accepted as WG drafts in the area of handover optimization.
However, during the multimob meting in Vancouver, positive votes/opinions have already been expressed for the adoption of the draft-schmidt-multimob-fmipv6-pfmipv6-multicast as a WG multimob draft.
Therefore, it can be somehow deduced that the draft-schmidt-multimob-fmipv6-pfmipv6-multicast can at this moment, already be adopted as a WG multimob draft.

The next step will then be to investigate which other multicast handover optimization  individual drafts can also be adopted as a multimob WG multimob draft.

Best regards,
Georgios

________________________________________
Van: [email-masked] [[email-masked]] namens Behcet Sarikaya [[email-masked]]
Verzonden: dinsdag 31 juli 2012 22:31
Aan: [email-masked]
Onderwerp: [multimob] Adoption of HO drafts incl.       draft-schmidt-multimob-fmipv6-pfmipv6-multicast

Hi all,
There is an issue that we missed in Monday Multimob session that I
would like to bring to attention:

We did have, apart from

These are the documents that are still active. There could be others
that are no longer active.

What do you think?

Regards,

Behcet

---

From: "Rajeev Koodli (rkoodli)" <[email-masked]>
Date: Tue, 14 Aug 2012 17:31:51 +0000

Hi Behcet,

Shouldn't the WG first discuss these IDs, just as draft-schmidt-* has been discussed several times and presented (most recently at IETF84)?

Specifically, I do not understand your comment below:

"We did have, apart from

draft-schmidt-multimob-fmipv6-pfmipv6-multicast, several other
multicast handover solution drafts such as:.."

IMO, each ID should be discussed on its own and the WG should decide about the next steps.

Thanks.

-Rajeev

Hi all,

We did have, apart from

What do you think?

Regards,

Behcet