Subject: [netmod] iana iftype in yang

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 31 Mar 2011 15:32:48 +0200

Hi,

during the WG session, there was a motion to use the existing ifType
enumerations in YANG instead of identities. We have meanwhile spoken
to IANA to better understand how the procedures work and how a YANG
version of the IANA ifType can be created and maintained. We also
consulted with Dan Romascanu, who is the current expert for ifType
assignments and as a matter of convenience also our AD. ;-)

Here is the current understanding and the proposed line of action.
The IANA ifType registry got established in RFC 1573. The registry
itself is maintained in http://www.iana.org/assignments/smi-numbers.
In addition, IANA updates http://www.iana.org/assignments/ianaiftype-mib
whenever assignments are made (in a manual process). What we are going
to ask them to do is to maintain in addition a YANG module as another
"view" on the registry. IANA told us this is not a big deal.

To get this established, though, we need to have a document that
specifies that this needs to be maintained and this document needs to
include an initial version of the iftype YANG module. Since this is
rather long, we prefer to create a separate Internet-Draft that
establishes the YANG version of the ifType registry by specifying the
necessary IANA rules and providing the initial version.

If there are any concerns about this way forward, please let us know
within the next week.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: David Spakes <[email-masked]>
Date: Thu, 31 Mar 2011 10:12:52 -0400 (EDT)

I think this is the right approach.  I can't think of any concerns at
this time.

-dss

On Thu, 31 Mar 2011, Juergen Schoenwaelder wrote:

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

-------------------------------------------------------------
 David Spakes                       email:   [email-masked]
 SNMP Research                      voice:   +1 865 573 1434
 3001 Kimberlin Heights Road          fax:   +1 865 573 9197
 Knoxville, TN  37920-9716  USA      http://www.snmp.com
-------------------------------------------------------------

---

From: Brian Hedstrom <[email-masked]>
Date: Thu, 31 Mar 2011 09:06:12 -0600

Hi Juergen,

To better understand this approach, will the NETMOD WG create a new YANG data type that mimics the IANAifType SNMP Textual Convention?
And then the Interfaces Config YANG Module will just import that data type?

Will this YANG Data Type be defined in a new RFC or existing RFC that already defines YANG standard data types?

What will be the process for updating the YANG data type each time IANA adds a new ifType enum value?  Will this deprecate that RFC each time this happens?  Or will the NETMOD WG queue up several new ifTypes from IANA and then add them all at once to a newer RFC that deprecates the prior RFC?

Thanks for clarifying,

Brian Hedstrom
Senior Architect, Business & Operational Support Systems
CableLabs, Inc.
858 Coal Creek Circle
Louisville, CO 80027
Direct: 303.661.3829
eFax: 303.664.8120
AIM: brzahedstrom
Skype IM: brian.hedstrom 
[email-masked] 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Thursday, March 31, 2011 7:33 AM
To: [email-masked]
Subject: [netmod] iana iftype in yang

Hi,

during the WG session, there was a motion to use the existing ifType enumerations in YANG instead of identities. We have meanwhile spoken to IANA to better understand how the procedures work and how a YANG version of the IANA ifType can be created and maintained. We also consulted with Dan Romascanu, who is the current expert for ifType assignments and as a matter of convenience also our AD. ;-)

Here is the current understanding and the proposed line of action.
The IANA ifType registry got established in RFC 1573. The registry itself is maintained in http://www.iana.org/assignments/smi-numbers.
In addition, IANA updates http://www.iana.org/assignments/ianaiftype-mib
whenever assignments are made (in a manual process). What we are going to ask them to do is to maintain in addition a YANG module as another "view" on the registry. IANA told us this is not a big deal.

To get this established, though, we need to have a document that specifies that this needs to be maintained and this document needs to include an initial version of the iftype YANG module. Since this is rather long, we prefer to create a separate Internet-Draft that establishes the YANG version of the ifType registry by specifying the necessary IANA rules and providing the initial version.

If there are any concerns about this way forward, please let us know within the next week.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 31 Mar 2011 17:17:03 +0200

> And then the Interfaces Config YANG Module will just import that data type?

yes
 
> Will this YANG Data Type be defined in a new RFC or existing RFC that already defines YANG standard data types?

There will be an RFC that defines the initial version of the type and
once published updates will handled by IANA as they do already for the
IANA ifType.

> What will be the process for updating the YANG data type each time IANA adds a new ifType enum value?  Will this deprecate that RFC each time this happens?  Or will the NETMOD WG queue up several n…

IANA will provide the IANA maintained YANG module, pretty much as IANA
provides the IANA maintained SMIv2 module. You request a new ifType as
you do now. Once the request is approved, the registry is updated as
well as the SMIv2 module and the YANG module. No need for new RFCs nor
is there any WG involvement. IANA takes care.

/js