Subject: [netmod] Comments on draft-bjorklund-netmod-interfaces-cfg-00

From: Brian Hedstrom <[email-masked]>
Date: Mon, 21 Mar 2011 11:15:19 -0600

Netmod Working Group:
I have some review comments on the draft:
http://www.ietf.org/id/draft-bjorklund-netmod-interfaces-cfg-00.txt

1. ifLinkUpDownTrapEnable should be added into the config module.
2. ifAlias should be added into the config module, but perhaps not made mandatory
3. Is there any value in adding ifPromiscuousMode as an optional leaf for some implementations?
4. The Security Considerations section should be populated or listed as no security impacts.
5. For Appendix A could you also include an example YANG Data Tree instance showing the NETCONF YANG payload?
6. Should this module have any mapping into the ENTITY-MIB (entPhysicalIndex)?
7. Can implementations still use the IANI ifTypes with this Module for the type leaf?
8. Could this Module be used to make run time Control (actionable) changes?  If so, what about admin-status
supporting the "testing" enumeration?

Thanks,
Brian Hedstrom
CableLabs

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 25 Mar 2011 12:21:44 +0100 (CET)

Hi Brian,

Thank you for your comments.  See answers inline.

> 1. ifLinkUpDownTrapEnable should be added into the config module.

Yes, this is probably a good idea.

> 2. ifAlias should be added into the config module, but perhaps not

Why do you think this object is needed?  Why isn't the name enough?
It seems some vendors map this object to a "description" field in
their CLI.  But that isn't really the intention of this object.

>    leaf for some implementations? 

I'm not sure if this object is intended to be config, i.e. if the
value of this object is stored in non-volatile memory.

> 4. The Security Considerations section should be populated or listed

Yes, this section will be written, if the WG adopts this document.

> 5. For Appendix A could you also include an example YANG Data Tree
>    instance showing the NETCONF YANG payload?

Ok.

> 6. Should this module have any mapping into the ENTITY-MIB

I don't think so.  In the ENTITY-MIB, you can have pointer to
interfaces.  I think that is sufficient for now.  (Maybe we will see a
YANG module for entities in the future).

> 7. Can implementations still use the IANI ifTypes with this Module

No.  This module does not use a centrally administered enumeration for
type identification.  Instead, it uses YANG identities.  It is
expected that interface type specific modules define their own
identities.

Maybe there is a need for identities that don't have an associated
type specific module?  Maybe we could define an 'other' identity, and
also add a leaf 'iana-if-type' for such interfaces.

>    supporting the "testing" enumeration?

This is currently not in scope, but it is up to the WG to decide.  Do
you think that this would be useful?  Are you seeing that the
ifAdminStatus value 'testing' is being used?

/martin