Subject: [netmod] yangstrip tool

From: Brian Hedstrom <[email-masked]>
Date: Wed, 4 May 2011 09:22:39 -0600

NETMOD WG,
We have the smistrip tool that will extract MIBs from RFCs as part of libsmi.
Do we have a yangstrip tool that will extract YANG modules from RFCs?

Thanks,

Brian Hedstrom
Senior Architect, Business & Operational Support Systems
CableLabs, Inc.
858 Coal Creek Circle
Louisville, CO 80027
Direct: 303.661.3829
eFax: 303.664.8120
AIM: brzahedstrom
Skype IM: brian.hedstrom
[email-masked]<mailto:[email-masked]>

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 04 May 2011 22:59:25 +0200 (CEST)

Hi,

> Do we have a yangstrip tool that will extract YANG modules from RFCs?

There is a tool called 'rfcstrip' which is based on smistrip, that can
extract YANG modules from RFCs and I-Ds.  It is available at
http://www.yang-central.org/twiki/bin/view/Main/YangTools.

I think it is based on an old version of smistrip, and it might need
some updates in the MIB extracion parts, but it works just fine for
YANG modules.

/martin