Subject: Re: [netmod] comments on draft-ietf-netmod-routing-cfg-01

From: Martin Bjorklund <[email-masked]>
Date: Fri, 02 Dec 2011 12:58:14 +0100 (CET)

Hi,

Ladislav Lhotka <[email-masked]> wrote:
> Hi,
> 
> On Mon, 14 Nov 2011 13:50:17 +0100 (CET), Martin Bjorklund <[email-masked]>
> wrote:
> > 
> > o  Why don't we have a ipv6-unicast module?
> > 
> 
> I'd like to write the "ietf-ipv6-unicast-routing" module but first we
> need to agree on the distribution of IPv6 parameters between this module
> and "ietf-ip".
> 
> In the next revision of the "ietf-routing" module, I plan to add a list
> of interfaces under /rt:routing/rt:router with key being a leafref
> pointing to a configured logical interface. This is necessary in order to
> be able to specify the logical interfaces that belong to each logical
> router. As a side effect, interface parameters that are only relevant
> for routers, such as RA configuration, can be put here rather than under
> /if:interfaces. 
> 
> Any opinions or suggestions?

I need to think about the implications, but so far I think I like this
idea.  A couple of questions:

Does each router have a *list* of interfaces?  Can it be empty?

Can an interface be pointed to by more than one router?

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 2 Dec 2011 13:17:43 +0100

> Does each router have a *list* of interfaces?  Can it be empty?

Yes, each router will have to have this list, probably with min-elements = 1, because it doesn't make much sense to have a router without interfaces.

> Can an interface be pointed to by more than one router?

JUNOS implementation of logical routers doesn't allow this but in general I can imagine a different logic where this might  be allowed, for example if one logical router is for IPv4 and another for IPv6. So my plan is not to have this constraint in the module, and leave it to implementations to specify additional business rules if necessary. 

Lada

--
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 02 Dec 2011 13:38:04 +0100 (CET)

Ladislav Lhotka <[email-masked]> wrote:
> JUNOS implementation of logical routers doesn't allow this but in general I can
> imagine a different logic where this might be allowed, for example if one
> logical router is for IPv4 and another for IPv6.

What happens if two routers points to the same interface, and they
have different RA configs?

> So my plan is not to have this
> constraint in the module, and leave it to implementations to specify additional
> business rules if necessary.

I think it should also be up to data models to specify additional
constraints.  Hmm, maybe this is just too obvious.

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 2 Dec 2011 17:04:27 +0100

> have different RA configs?

IMO, this situation must not happen, and cannot happen both in JUNOS and in my hypothetical scenario.

> constraints.  Hmm, maybe this is just too obvious.

Do you mean the core routing data models or vendor-specific models derived from them?

Lada

--
Ladislav Lhotka, CESNET
PGP Key ID: E74E8C0C