Subject: [netmod] I-D Action: draft-ietf-netmod-interfaces-cfg-06.txt

From: [email-masked]
Date: Wed, 05 Sep 2012 00:30:30 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the NETCONF Data Modeling Language Working Group of the IETF.

	Title           : A YANG Data Model for Interface Management
	Author(s)       : Martin Bjorklund
	Filename        : draft-ietf-netmod-interfaces-cfg-06.txt
	Pages           : 33
	Date            : 2012-09-05

Abstract:
   This document defines a YANG data model for the management of network
   interfaces.  It is expected that interface type specific data models
   augment the generic interfaces data model defined in this document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-interfaces-cfg

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-netmod-interfaces-cfg-06

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-interfaces-cfg-06

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Lange, Jeffrey K (GE Energy)" <[email-masked]>
Date: Mon, 10 Sep 2012 13:12:32 +0000

Looking over the latest interfaces YANG file, shouldn't the speed leaf be config false?

	         leaf speed {	
 	           type yang:gauge64;	
 	           units "bits / second";	
 	           description	
 	               "An estimate of the interface's current bandwidth in bits	
 	                per second.  For interfaces which do not vary in	
 	                bandwidth or for those where no accurate estimation can	
 	                be made, this node should contain the nominal bandwidth.	
 	                For interfaces that has no concept of bandwidth, this	
 	                node is not present.";	
 	           reference	
 	             "RFC 2863: The Interfaces Group MIB -	
 	                        ifSpeed, ifHighSpeed";	
 	         }

I don't think I want a user telling me what they estimate my bandwidth is in bits / second.

-Jeff

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Wednesday, September 05, 2012 3:31 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [netmod] I-D Action: draft-ietf-netmod-interfaces-cfg-06.txt
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 10 Sep 2012 15:20:18 +0200 (CEST)

> Looking over the latest interfaces YANG file, shouldn't the speed

Yes it should!  Thanks, I will fix this.

/martin