Subject: Re: [netmod] I-D Action: draft-ietf-netmod-system-mgmt-04.txt

From: Xiang Li <[email-masked]>
Date: Fri, 11 Jan 2013 10:19:52 -0600

Hi

Looks good...I just have have a simple editorial comment.
This draft still does not contain a simple explanation on what these
  "?", "*", etc. means in the various data module structure diagram:

For example:
The data model for system identification has the following structure:

       +--rw system
          +--rw contact?          string
          +--rw name?             string
          +--rw location?         string
          +--ro platform
...

I noticed that the recent ietf-interface and ietf-routing all contain 
some texts clarifying
these symbols. I think  ietf-system-module  should add such texts too.

For example, in ietf-interface yang:

3.  Interfaces Data Model

    The data model in the module "ietf-interfaces" has the following
    structure, where square brackets are used to enclose a list's keys,
    "?" means that the leaf is optional, and "*" denotes a leaf-list:

       +--rw interfaces
          +--rw interface [name]
             +--rw name                        string

--Xiang Li

On 12/26/2012 2:45 PM, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>   This draft is a work item of the NETCONF Data Modeling Language Working Group of the IETF.
>
> 	Title           : YANG Data Model for System Management
> 	Author(s)       : Andy Bierman
>                            Martin Bjorklund
> 	Filename        : draft-ietf-netmod-system-mgmt-04.txt
> 	Pages           : 31
> 	Date            : 2012-12-26
>
> Abstract:
>     This document defines a YANG data model for the configuration and
>     identification of the management system of a device.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-netmod-system-mgmt
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-netmod-system-mgmt-04
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-system-mgmt-04
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
--
Xiang Li
Web: www.seguesoft.com
Voice:   1 (872) 216-2610 Cell 1 (217) 819-0942

---

From: Andy Bierman <[email-masked]>
Date: Thu, 31 Jan 2013 08:43:51 -0800

Hi,

IMO, the best solution would be if the tool authors would write
a short RFC defining the syntax and showing a few examples.
Then all the RFCs with YANG tree diagrams can just add an
informative reference instead of cut-and-pasting a couple sentences.

Those of use who have used the libsmi tool for MIB tree diagrams
may be used to all the symbols but there are many details that
cannot be inferred from examination of 1 or 2 examples.

E.g., some might see foo, foo? and wonder if foo* is also in the syntax,
and if they mean the same thing as RelaxNG. Or see r/w, and wonder what
are the other choices? r/c, r/o like SNMP?

Now that I2RS WG appears to want to use YANG tree diagrams as well,
it would help the standards process if there was actually a definition
of a YANG tree diagram in an Informational RFC.

Andy

On Fri, Jan 11, 2013 at 8:19 AM, Xiang Li <[email-masked]> wrote:

> I noticed that the recent ietf-interface and ietf-routing all contain some
> texts clarifying
>>         Filename        : draft-ietf-netmod-system-mgmt-**04.txt
>>         Pages           : 31
>>         Date            : 2012-12-26
>>
>> Abstract:
>> https://datatracker.ietf.org/**doc/draft-ietf-netmod-system-**mgmt<https://datatracker.ietf.org/doc/draft-ietf-netmod-system-mgmt>
>>
>> http://tools.ietf.org/html/**draft-ietf-netmod-system-mgmt-**04<http://tools.ietf.org/html/draft-ietf-netmod-system-mgmt-04>
>>
>> http://www.ietf.org/rfcdiff?**url2=draft-ietf-netmod-system-**mgmt-04<http://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-system-mgmt-04>
>>
>>
>> ftp://ftp.ietf.org/internet-**drafts/<ftp://ftp.ietf.org/internet-drafts/>
>>
>> ______________________________**_________________
>> netmod mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/netmod<https://www.ietf.org/mailman/listinfo/netmod>
>>
>
> --
> --
> Xiang Li
> Web: www.seguesoft.com
> ______________________________**_________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/netmod<https://www.ietf.org/mailman/listinfo/netmod>
>

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 31 Jan 2013 20:37:34 +0100 (CET)

Hi,

> a short RFC defining the syntax and showing a few examples.

Since we don't want to wait for that document at this point, I suggest
we do as the rest of the current documents, and include something
like this:

1.2.  Tree Diagrams

   A simplified graphical representation of the data model is used in
   this document.  The meaning of the symbols in these diagrams is as
   follows:

   o  Brackets "[" and "]" enclose list keys.

   o  Abbreviations before data node names: "rw" means configuration
      (read-write) and "ro" state data (read-only).

   o  Symbols after data node names: "?" means an optional node and "*"
      denotes a "leaf-list".

   o  Parentheses enclose choice and case nodes, and case nodes are also
      marked with a colon (":").

/martin