Subject: Re: [netmod] I-D Action: draft-ietf-netmod-system-mgmt-04.txt

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 1 Feb 2013 10:29:41 +0100

On Jan 31, 2013, at 8:37 PM, Martin Bjorklund <[email-masked]> wrote:

> Hi,
> 
> Andy Bierman <[email-masked]> wrote:
>> Hi,
>> 
>> IMO, the best solution would be if the tool authors would write
>> a short RFC defining the syntax and showing a few examples.
> 
> Since we don't want to wait for that document at this point, I suggest
> we do as the rest of the current documents, and include something
> like this:
> 
> 1.2.  Tree Diagrams
> 
>   A simplified graphical representation of the data model is used in
>   this document.  The meaning of the symbols in these diagrams is as
>   follows:
> 
>   o  Brackets "[" and "]" enclose list keys.
> 
>   o  Abbreviations before data node names: "rw" means configuration
>      (read-write) and "ro" state data (read-only).
> 
>   o  Symbols after data node names: "?" means an optional node and "*"
>      denotes a "leaf-list".
> 
>   o  Parentheses enclose choice and case nodes, and case nodes are also
>      marked with a colon (":").

Quite often, the trees are collapsed in some way, and then there should be a fourth item like this:

   o  Ellipsis ("...") stands for contents of subtrees that are not
      shown. 

The best place for that subsection is probably the "Terminology and Notation" section.

Lada

> 
> 
> 
> /martin
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Fri, 1 Feb 2013 10:00:33 -0800

Hi,

I suppose an Informational RFC is too much work, but there is
an easy solution available.  We can publish an OPS WEB page
with a boilerplate for RFCs that contain YANG modules.

There is already one for MIB modules:
http://trac.tools.ietf.org/area/ops/trac/wiki/mib-boilerplate

Andy

---

From: Xiang Li <[email-masked]>
Date: Fri, 01 Feb 2013 13:01:04 -0600

Andy,

I think the easy way and  arguably a better place is to put it in the
"Terminology and Notation" section as Lada suggested,  since you
have multiple places that show tree diagrams in this draft.

I am not sure it  is a good idea for a reader/operator to locate the
boilerplate for this information (probably ok for IETF module editors).

--Xiang

On 2/1/2013 12:00 PM, Andy Bierman wrote:
> On Fri, Feb 1, 2013 at 1:29 AM, Ladislav Lhotka <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>     On Jan 31, 2013, at 8:37 PM, Martin Bjorklund <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>     > Hi,
>     >
>     > Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
>     >> Hi,
>     >>
>     > [email-masked] <mailto:[email-masked]>

-- 
--
Xiang Li
Web: www.seguesoft.com
Voice:   1 (217) 472-4108 Cell 1 (217) 819-0942

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 1 Feb 2013 20:11:44 +0100

> boilerplate for this information (probably ok for IETF module editors).
 
Xiang,

the MIB boilerplate is copied into every document containing a MIB
module. So a reader would easily spot it and authors would easily find
the right text to include. (And who knows, the new xml2rfc might even
be hacked to generate such boilerplates automatically - that would be
cool.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Xiang Li <[email-masked]>
Date: Fri, 01 Feb 2013 13:20:00 -0600

On 2/1/2013 1:11 PM, Juergen Schoenwaelder wrote:
> module.
Apparently I did not know that...that's probably the best then.

--Xiang
> So a reader would easily spot it and authors would easily find