Subject: [netmod] I-D Action: draft-ietf-netmod-ip-cfg-08.txt

From: [email-masked]
Date: Wed, 06 Feb 2013 07:18:14 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the NETCONF Data Modeling Language Working Group of the IETF.

	Title           : A YANG Data Model for IP Management
	Author(s)       : Martin Bjorklund
	Filename        : draft-ietf-netmod-ip-cfg-08.txt
	Pages           : 22
	Date            : 2013-02-06

Abstract:
   This document defines a YANG data model for management of IP
   implementations.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-ip-cfg

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-netmod-ip-cfg-08

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-ip-cfg-08

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Thu, 7 Feb 2013 15:24:58 +0000

One quick comment on ietf-ip, the nodes "ipv4/neighbor/phys-address" & "ipv6/neighbor/phys-address" should be mandatory.  Phys-address is the only leaf in the neighbor list other than the key (ip), and it doesn't make any sense to create a static ARP entry without a physical address.

-Jeff

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Wednesday, February 06, 2013 10:18 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [netmod] I-D Action: draft-ietf-netmod-ip-cfg-08.txt
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: David Lamparter <[email-masked]>
Date: Thu, 7 Feb 2013 16:28:50 +0100

On Thu, Feb 07, 2013 at 03:24:58PM +0000, Lange, Jeffrey K (GE Energy Management) wrote:
> One quick comment on ietf-ip, the nodes "ipv4/neighbor/phys-address" &
> "ipv6/neighbor/phys-address" should be mandatory.  Phys-address is the
> only leaf in the neighbor list other than the key (ip), and it doesn't
> make any sense to create a static ARP entry without a physical
> address.

There are devices that support creation of static "unreachable" ARP
entries.  If the phys-address is mandatory, this will need some ugly
hack instead of a simple schema extension.

-David

---

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Thu, 7 Feb 2013 15:34:48 +0000

> There are devices that support creation of static "unreachable" ARP entries.
> If the phys-address is mandatory, this will need some ugly hack instead of a
> simple schema extension.

That makes sense.  However if that's the intended use-case of leaving it empty, perhaps there should be a note in the description about what it means if that leaf is not present.

-Jeff

> From: David Lamparter [mailto:[email-masked]]
> Sent: Thursday, February 07, 2013 10:29 AM
> To: Lange, Jeffrey K (GE Energy Management)
> Cc: [email-masked]
> Subject: Re: [netmod] I-D Action: draft-ietf-netmod-ip-cfg-08.txt
> 
> There are devices that support creation of static "unreachable" ARP entries.
> If the phys-address is mandatory, this will need some ugly hack instead of a
> simple schema extension.
> 
> -David
>