Subject: Re: [netmod] ietf-ip open issue

From: "Lange, Jeffrey K (GE Energy Management)" <[email-masked]>
Date: Fri, 8 Feb 2013 19:44:24 +0000

Bringing back an old thread here, but looking at the latest ietf-ip, the prefix-length is still defaulted to 32/128.  Was there an intent to change this to a mandatory field as stated by Martin below?

-Jeff

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Martin Bjorklund
> Sent: Monday, December 10, 2012 4:18 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [netmod] ietf-ip open issue
> 
> Juergen Schoenwaelder <[email-masked]> wrote:
> > On Mon, Dec 10, 2012 at 09:04:38PM +0100, Martin Bjorklund wrote:
> > > Hi,
> > >
> > > One WGLC comment was if the prefix-length really should have a
> > > default value (32 resp. 128).  There are two options:
> > >
> > >   1.  Keep the defaults
> > >
> > >   2.  Make prefix-length mandatory
> > >
> > >
> > > I think I agree with Lada that we should do (2).  The current
> > > defaults are not so common that it saves lots of config to use the
> > > default values.  Comments?
> >
> > I generally agree with the direction. But how would this work for IPv4
> > where we have either a prefix-length or a netmask?
> 
> It actually works fine:
> 
>         choice subnet {
>           mandatory true;
>           ...
>           leaf prefix-length { ... }
>           leaf netmask {
>             if-feature ipv4-non-contiguous-netmasks;
>             ...
>           }
>         }
> 
> 
> /martin
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 11 Feb 2013 08:15:12 +0100 (CET)

Hi,

"Lange, Jeffrey K (GE Energy Management)" <[email-masked]> wrote:
> Bringing back an old thread here, but looking at the latest ietf-ip, the
> prefix-length is still defaulted to 32/128.  Was there an intent to change this
> to a mandatory field as stated by Martin below?

Thanks for catching this, it was my mistake.

I have fixed this, and posted -09, and also I updated the "tree"
overview to match the new types introduced in -08.

/martin