Subject: [netmod] Keyless lists in rpc

From: Balazs Lengyel <[email-masked]>
Date: Wed, 24 Apr 2013 15:56:33 +0200

Hello,
Lists sometimes need a key(s) sometimes don't depending on the config 
true/false statement.
My question is, do lists under the rpc/input/output statement need a 
key? Here the config statement is meaningless/ignored. In my view the 
key should not be needed, but the RFC does not say so. Opinions?
regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
System Manager
ECN: 831 7320                        Tel: +36-1-437-7320
Mobile: +36-70-330-7909              email: [email-masked]

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 24 Apr 2013 16:17:03 +0200

On Apr 24, 2013, at 3:56 PM, Balazs Lengyel <[email-masked]> wrote:

> Hello,
> Lists sometimes need a key(s) sometimes don't depending on the config true/false statement.
> My question is, do lists under the rpc/input/output statement need a key? Here the config statement is meaningless/ignored. In my view the key should not be needed, but the RFC does not say so. Opinions?

I agree. Keys are needed only in configuration data.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Jernej Tuljak <[email-masked]>
Date: Wed, 24 Apr 2013 16:17:56 +0200

> key should not be needed, but the RFC does not say so. Opinions?
I think that the RFC is clear enough on this matter. Key statements for 
lists with a rpc/notification ancestor are optional, since such lists do 
not represent configuration - they represent rpc operation 
parameters/notification body.

Jernej