Subject: Re: [netmod] Last Call: draft-ietf-netmod-snmp-cfg-03 (20131220)

From: Randy Presuhn <[email-masked]>
Date: Thu, 16 Jan 2014 16:04:26 -0800 (GMT-08:00)

Hi -

>From: Juergen Schoenwaelder <[email-masked]>
>Sent: Jan 16, 2014 3:21 AM
>To: Randy Presuhn <[email-masked]>
>Cc: [email-masked]
>Subject: Re: [netmod] Last Call: draft-ietf-netmod-snmp-cfg-03 (20131220)
>
>On Thu, Jan 09, 2014 at 04:45:30PM -0800, Randy Presuhn wrote:
>> Hi -
>> >
>> >But you can't delete vacmGroupName.3.3.b.o.b with SNMP either.
>> 
>> Yes you can, but that's irrelevant. 
>
>I do wonder how though (even though it might be irrelevant).

Setting vacmSecurityToGroupStatus.3.3.b.o.b to 'destroy'
will get rid of the reference,
setting vacmAccessStatus.3.bob.* will get rid of the group.

Randy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 17 Jan 2014 08:01:19 +0100

> setting vacmAccessStatus.3.bob.* will get rid of the group.

In other words, you have to delete and re-create the user in order to
set him to no group (or you have to set the group to a magic value
that does not match anything to mean no group).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 16 Jan 2014 23:20:31 -0800

Hi -

> From: "Juergen Schoenwaelder" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, January 16, 2014 11:01 PM

> that does not match anything to mean no group).

No "magic value" required.  If there are no corresponding entries in
vacmAccessTable, then there's a reference but no group, from a
data model perspective if not from the quirkily-defined ASI.  Likewise,
setting vacmAccessStatus.3.bob.* to 'destroy' will get rid of the group

Randy