Subject: [netmod] YANG 1.1 issue: notification resource identification

From: Andy Bierman <[email-masked]>
Date: Fri, 11 Apr 2014 10:05:52 -0700

Hi,

Problem:

 NETCONF/YANG does not have a general mechanism
 to associate a data node with a notification event.
 A common feature (required by I2RS) is the ability
 to associate a notification with a resource instance.

Solution:

 YANG should define some common mechanism to indicate
 that a notification-stmt is associated with a data resource object.
 This can only be done now with description-stmt text.

 Possible implementation:

   * Allow the path-stmt to be present as a sub-statement
     of the notification-stmt.

  notification interface-enabled {
      path "/if:interfaces/if:interface";
      leaf name {
        type leafref {
           path "/if:interfaces/if:interface/if:name";
        }
     }
  }

The "name" leaf does not define the resource in a way that
a generic tool can figure out the resource object.  A tool would
need to be coded separately to support each notification-stmt.

The path-stmt allows the resource object to be easily identified.
It would not be present unless there is a data resource object
associated with the event type.

Andy

---

From: Thomas Nadeau <[email-masked]>
Date: Fri, 11 Apr 2014 13:58:11 -0400

I like this idea. 

On Apr 11, 2014:1:05 PM, at 1:05 PM, Andy Bierman <[email-masked]> wrote:

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 16 Apr 2014 15:38:47 +0200 (CEST)

Hi,

This is now Y36.

(BTW, the html at the wiki is now readable)

/martin