Subject: Re: [netmod] new YANG 1.1 issue: remove deviations

From: Martin Bjorklund <[email-masked]>
Date: Wed, 02 Apr 2014 10:16:51 +0200 (CEST)

Andy Bierman <[email-masked]> wrote:
> Hi,
> 
> I don't think YANG deviation statements are being used,

Deviations are used.  One data point: I recently extended the support
for deviations in pyang, based on requests from open source users.

/martin

> nor are they likely to ever be used. They are not allowed
> to appear in standard YANG modules, so I am asking
> vendors out there:
> 
>    Do you use (or plan to use) deviation statements in your YANG modules?
> 
> If consensus is no, then deviations should be removed from YANG 1.1.
> YANG would be simpler without them.
> IMO, conformance information should be handled differently anyway.

---

From: Andy Bierman <[email-masked]>
Date: Wed, 2 Apr 2014 09:21:19 -0700

> for deviations in pyang, based on requests from open source users.
OK -- I was just checking.
In theory they are very useful if the server does not instrument objects
correctly, then the client can identity the trouble spots automatically.
This is better than each platform group publishing its own version
of the foo module.

/martin

Andy