Subject: [netmod] new issue: add 'attribute' statement

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 04 Apr 2014 11:20:08 +0200

* add 'attribute' statement

** Description

There is a need for using metadata or tags on YANG-modelled instances.

A new YANG statement, 'attribute', is proposed to allow defining such
attributes. It would be allowed only at the top level of a module so
that it could be used for defining global attributes that can be
attached to any data node.

The statement would serve the following purposes:

1. Define semantics of the attribute by means of a 'description'
   statement.
2. Define a namespace and prefix for the attribute through the standard
   YANG mechanisms.
3. Allow the NETCONF/RESTCONF server to advertise support for
   particular sets of attributes via standard capabilities.

An attribute defined through this statement would be mapped to a namespaced XML
attribute.

The 'attribute' statement can have 'if-feature' as its substatement.

A typical use:

attribute inactive {
    description
        "Disable a data node together with its subtree.
	 The effect must be the same as if the data node was
         commented out."
}

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 04 Apr 2014 11:53:31 +0200 (CEST)

Hi,

Added as Y33.

/martin

Ladislav Lhotka <[email-masked]> wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>