Subject: [netmod] YANG1.1 issue: add filter type to pattern

From: chong feng <[email-masked]>
Date: Thu, 3 Apr 2014 23:56:53 +0800

Hi all,
     YANG1.0 can not express filter type,such as include or exclude,so
,YANG1.1 can add 'filter' statement as sub statement of pattern.
For example,
     leaf a {
            type string {
                 pattern p1 {
                      filter exclude;
                 }

            }
     }

'filter' statement has an argument 'type', this argument accept'include'
and 'exclude' as valid value,default is 'include'.

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 03 Apr 2014 22:56:59 +0200 (CEST)

Hi,

I think this is covered by Y23.  I rephrased that issue, and added
your proposal as Y23-02.

/martin