Subject: [netmod] Fwd: [Isis-wg] FW: New Version Notification for draft-litkowski-netmod-isis-cfg-00.txt

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 17 Jun 2014 18:19:02 +0200

FYI, I didn’t want to cross-post my reply.

Lada

Begin forwarded message:

> From: Ladislav Lhotka <[email-masked]>
> Subject: Re: [Isis-wg] FW: New Version Notification for draft-litkowski-netmod-isis-cfg-00.txt
> Date: 17 Jun 2014 18:14:02 GMT+2
> To: [email-masked]
> Cc: "[email-masked] list \([email-masked]\)" <[email-masked]>
> 
> Hi Stephane,
> 
> I am really pleased to see this I-D and the YANG module. I think though this work belongs to the ISIS WG where the exposure to routing experts’ eyes will likely be much higher than in NETMOD. That said, I’d be interested in helping you with further development of this module.
> 
> Thanks, Lada
> 
> On 17 Jun 2014, at 16:41, <[email-masked]> <[email-masked]> wrote:
> 
>> Hi folks,
>> 
>> FYI and comments ...
>> 
>> Here is an initial draft proposal for a YANG model for ISIS.
>> 
>> 
>> Best Regards,
>> 
>> Stephane
>> 
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] 
>> Sent: Tuesday, June 17, 2014 14:20
>> To: LITKOWSKI Stephane SCE/IBNF; LITKOWSKI Stephane SCE/IBNF
>> Subject: New Version Notification for draft-litkowski-netmod-isis-cfg-00.txt
>> 
>> 
>> A new version of I-D, draft-litkowski-netmod-isis-cfg-00.txt
>> has been successfully submitted by Stephane Litkowski and posted to the IETF repository.
>> 
>> Name:		draft-litkowski-netmod-isis-cfg
>> Revision:	00
>> Title:		Yang Data Model for ISIS protocol
>> Document date:	2014-06-17
>> Group:		Individual Submission
>> Pages:		22
>> URL:            http://www.ietf.org/internet-drafts/draft-litkowski-netmod-isis-cfg-00.txt
>> Status:         https://datatracker.ietf.org/doc/draft-litkowski-netmod-isis-cfg/
>> Htmlized:       http://tools.ietf.org/html/draft-litkowski-netmod-isis-cfg-00
>> 
>> 
>> Abstract:
>>  This document defines a YANG data model that can be used to configure
>>  and manage ISIS protocol.
>> 
>> 
>> 
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.
>> 
>> The IETF Secretariat
>> 
>> 
>> _________________________________________________________________________________________________________________________
>> 
>> Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
>> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
>> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
>> Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
>> 
>> This message and its attachments may contain confidential or privileged information that may be protected by law;
>> they should not be distributed, used or copied without authorisation.
>> If you have received this email in error, please notify the sender and delete this message and its attachments.
>> As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
>> Thank you.
>> 
>> _______________________________________________
>> Isis-wg mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/isis-wg
> 
> --
> Ladislav Lhotka, CZ.NIC Labs
> PGP Key ID: E74E8C0C
> 
> 
> 
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: <[email-masked]>
Date: Wed, 18 Jun 2014 08:11:24 +0000

Hi Lada,

For sure ISIS WG need to be involved, for ownership of the draft, I don't really know which WG need to be "owner". Maybe chairs can provide their feedback or we could discuss this point in Toronto.
I'm would like to present this first version in both WG if possible.

I would be happy to welcome any contributions, so if you have any point to raise or if you want to co-author by adding some text, don't hesitate.

Thanks,

Stephane

-----Original Message-----
From: Ladislav Lhotka [mailto:[email-masked]] 
Sent: Tuesday, June 17, 2014 18:14
To: LITKOWSKI Stephane SCE/IBNF
Cc: [email-masked] list ([email-masked])
Subject: Re: [Isis-wg] FW: New Version Notification for draft-litkowski-netmod-isis-cfg-00.txt

Hi Stephane,

I am really pleased to see this I-D and the YANG module. I think though this work belongs to the ISIS WG where the exposure to routing experts' eyes will likely be much higher than in NETMOD. That said, I'd be interested in helping you with further development of this module.

Thanks, Lada

On 17 Jun 2014, at 16:41, <[email-masked]> <[email-masked]> wrote:

> ______________________________________________________________________
> ___________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations 
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 18 Jun 2014 10:30:13 +0200

> I'm would like to present this first version in both WG if possible.

As a general principle, I prefer that data models are done in the WGs
that understand what is being modeled. Hence, this work should ideally
be done in the ISIS WG.

Since I am not following the ISIS WG myself, I ended up looking at the
WG charter page in order to get a clue what they are working on and
what I found is that apparently their milestones have not been updated
since 2009 (and the additional page pointed to in the charter,
<http://skat.usc.edu/~tli/Schedule.htm>, does not look more recent
either). So it remains somewhat difficult to judge whether ISIS may be
able to pick up this work.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 18 Jun 2014 10:53:37 +0200

> For sure ISIS WG need to be involved, for ownership of the draft, I don't really know which WG need to be "owner". Maybe chairs can provide their feedback or we could discuss this point in Toronto.

Yes, and I see Juergen has already started this discussion.

> I'm would like to present this first version in both WG if possible.

That’s fine and welcome, I think.

> I would be happy to welcome any contributions, so if you have any point to raise or if you want to co-author by adding some text, don't hesitate.

To start with, I plan a thorough review of the module, mainly from the YANG point of view. My first impressions are quite positive though. :-)

Lada

---

From: Andy Bierman <[email-masked]>
Date: Wed, 18 Jun 2014 07:22:01 -0700

Hi,

It is great to see new YANG modules proposed for standardization.
It would be even better if the data model is explained in some plain text.
IMO, a YANG tree diagram is not a substitute for a summary of the module.

Many of the data definitions have no description-stmt at all.
(Use pyang -ietf mode to identity the issues.)  Some ISIS protocol
reference-stmts
would also help readers understand this YANG module better.

thanks,
Andy

On Wed, Jun 18, 2014 at 1:53 AM, Ladislav Lhotka <[email-masked]> wrote:

> > For sure ISIS WG need to be involved, for ownership of the draft, I
> don't really know which WG need to be "owner". Maybe chairs can provide
> their feedback or we could discuss this point in Toronto.
>
> That's fine and welcome, I think.
>
> >
> > I would be happy to welcome any contributions, so if you have any point
> to raise or if you want to co-author by adding some text, don't hesitate.
>
> To start with, I plan a thorough review of the module, mainly from the
> YANG point of view. My first impressions are quite positive though. :-)
>
> Lada
>
> >
> > Thanks,
> >
> > Stephane
> >
> >
> > I am really pleased to see this I-D and the YANG module. I think though
> this work belongs to the ISIS WG where the exposure to routing experts'
> eyes will likely be much higher than in NETMOD. That said, I'd be
> interested in helping you with further development of this module.
> >
> > Thanks, Lada
> >
> >> URL:
> http://www.ietf.org/internet-drafts/draft-litkowski-netmod-isis-cfg-00.txt
> >> Status:
> https://datatracker.ietf.org/doc/draft-litkowski-netmod-isis-cfg/
> >> Htmlized:
> http://tools.ietf.org/html/draft-litkowski-netmod-isis-cfg-00
> >>
> >>
> >> Abstract:
> >> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
> >>
> >> The IETF Secretariat
> >>
> >>
> >> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi
> que les pieces jointes. Les messages electroniques etant susceptibles
> d'alteration, Orange decline toute responsabilite si ce message a ete
> altere, deforme ou falsifie. Merci.
> >>
> >> privileged information that may be protected by law; they should not be
> distributed, used or copied without authorisation.
> confidentielles ou privilegiees et ne doivent donc
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> > This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 18 Jun 2014 13:26:56 -0400

isis-wg is the right place.

Alia

---

From: <[email-masked]>
Date: Thu, 19 Jun 2014 08:06:53 +0000

Thanks Alia for the clarification.
The next update will be renamed with “isis” wg statement.

I think it may be valuable to keep some cross-discussions with Netmod as YANG expertise is IMO more in Netmod.

From: Alia Atlas [mailto:[email-masked]]
Sent: Wednesday, June 18, 2014 19:27
To: Juergen Schoenwaelder; LITKOWSKI Stephane SCE/IBNF; Ladislav Lhotka; [email-masked] list ([email-masked]); [email-masked]
Subject: Re: [netmod] [Isis-wg] FW: New Version Notification for draft-litkowski-netmod-isis-cfg-00.txt

Alia

On Wed, Jun 18, 2014 at 4:30 AM, Juergen Schoenwaelder <[email-masked]<mailto:[email-masked]>> wrote:

/js

--
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587<tel:%2B49%20421%20200%203587>         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103<tel:%2B49%20421%20200%203103>         <http://www.jacobs-university.de/>

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 19 Jun 2014 10:23:38 +0200

Hi,

it is surely good to keep the NETMOD WG updated about such activities
going on in other WGs. However, NETMOD is not functioning as a YANG
review team as stated on the NETMOD charter:

  The NETMOD Working Group will not serve as a review team for YANG
  modules developed by other working groups. The YANG doctors,
  organized by the OPS area director responsible for network
  management, can act as advisors for other working groups and they
  provide YANG reviews for the OPS area directors.

Since Lada indicated interest in this work and he is also a YANG
doctor, I think we are in a pretty good shape (and I am sure that Lada
will raise any issues that are more fundamental (should they show up)
when it is appropriate).

/js

---

From: <[email-masked]>
Date: Thu, 19 Jun 2014 10:48:47 +0000

Thanks for the clarification.

Stephane

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Thursday, June 19, 2014 10:24
To: LITKOWSKI Stephane SCE/IBNF
Cc: Alia Atlas; Ladislav Lhotka; [email-masked] list ([email-masked]); [email-masked]
Subject: Re: [netmod] [Isis-wg] FW: New Version Notification for draft-litkowski-netmod-isis-cfg-00.txt

Hi,

it is surely good to keep the NETMOD WG updated about such activities going on in other WGs. However, NETMOD is not functioning as a YANG review team as stated on the NETMOD charter:

Since Lada indicated interest in this work and he is also a YANG doctor, I think we are in a pretty good shape (and I am sure that Lada will raise any issues that are more fundamental (should they show up) when it is appropriate).

/js

On Thu, Jun 19, 2014 at 08:06:53AM +0000, [email-masked] wrote:
> To: Juergen Schoenwaelder; LITKOWSKI Stephane SCE/IBNF; Ladislav 
> Lhotka; [email-masked] list ([email-masked]); [email-masked]

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 19 Jun 2014 08:57:50 -0400

> I think it may be valuable to keep some cross-discussions with Netmod as YANG expertise is IMO more in Netmod.

	That is definitely the intent here.  The general idea is that specific WGs take on the actual model documents and
manage them, but netmod and YangDoctors will help the document authors with expert advice in the
design of the module. 

	--Tom

> On Wed, Jun 18, 2014 at 4:30 AM, Juergen Schoenwaelder <[email-masked]> wrote:

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 19 Jun 2014 15:17:07 +0200

> will raise any issues that are more fundamental (should they show up)

I am writing a review of this I-D, concentrating mainly on YANG issues and the integration with the core routing model. But I wonder - where should I send it? NETMOD or YANG doctors mailing list?

Lada

>> On Wed, Jun 18, 2014 at 08:11:24AM +0000,[email-masked]<mailto:[email-masked]> wrote:
>>> Hi Lada,
>>>

---

From: t.petch <[email-masked]>
Date: Thu, 19 Jun 2014 17:31:24 +0100

----- Original Message -----
From: "Alia Atlas" <[email-masked]>
Sent: Wednesday, June 18, 2014 6:26 PM

Alia

In a year or two, I expect that I would agree with you but right now,
the netmod WG has only just produced the basic models and in doing so,
found the need for some necessary modifications to YANG; and, in the
past 18 months, radically changed (IMO) the layout of most modules, to
the twin trees, cfg and state approach.

Give a year or two's experience of writing modules and there will
doubtless be guidelines on what to do and what not to do, but right now,
I think that the active involvement of the netmod group is essential.

I propose a three part approach; start in netmod to get the current
thinking of how to tackle common problems (the sort of things that Lada
has addressed although I disagree with him over the use of TLV - that is
how isis does things:-)

Then move to isis to get technicalities of the protocol correct, what to
model, what is config, defaults, etc

Then back to netmod to see that it still aligns with netmod best
practice (which likely will have moved on)

Tom Petch

> > On Wed, Jun 18, 2014 at 08:11:24AM +0000,
[email-masked]
> > wrote:

------------------------------------------------------------------------
--------

---

From: Andy Bierman <[email-masked]>
Date: Thu, 19 Jun 2014 10:06:22 -0700

> I think that the active involvement of the netmod group is essential.
I do not see config vs. operational subtrees as a major architecture change.
The expansion of functionality needs to be done with clue. Supporting
pre-provisioning and protocol controlled operational state may require
a separate tree, depending on the data model. IMO this should not a generic
solution.

The guidelines are bound to change the more standard functionality we addl
This should not slow down WGs using the existing functionality.

> has addressed although I disagree with him over the use of TLV - that is
The problem with this approach is that the NETMOD WG is a "plain old" WG,
with a charter to produce YANG 1.1 and other documents.  It is not chartered
to be the YANG Help Desk for the IETF. That is YANG Doctors' job.

It does not really scale well either (as we have seen from several YANG
proposals
that are waiting years to get chartered). NETMOD is already a bottleneck.
IMO, NETMOD should work on YANG 1.1, YANG Conformance,
and YANG Usage Guidelines.  It is time for domain-specific WGs to
work on YANG modules for their protocols.

> model, what is config, defaults, etc
A YANG Doctor (Lada) will help the isis WG.
The proper YANG usage is actually much easier to achieve than agreeing
on the exact text of every single protocol knob (by a mile),.
The protocol experts pay attention to the protocol WGs, not NETMOD.
Their review is easily missed if all YANG work is done in NETMOD.

> practice (which likely will have moved on)
This will happen as part of the AD review process.
I don't think YANG best practices are changing so rapidly that rewrites
will be required.
We will see wrt/ I2RS and YANG 1.1, but that should not affect any WG that
wants to standardize YANG configuration data models with YANG 1.0.

Andy

---

From: Alia Atlas <[email-masked]>
Date: Thu, 19 Jun 2014 15:55:46 -0400

Tom,

I agree with Andy.  Benoit and I have spoken about the best plan to enable
good fast YANG models and it is critical
to have the subject matter experts working on it and getting the structure
and knobs right.  That is where a lot of the
work is.  The hope is that YANG-doctors will provide the necessary advice.

If it proves too hard and that only specific experts in YANG can write good
useful models, that'll be a problem for the technology.

Alia

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 20 Jun 2014 10:11:54 +0200

> I am writing a review of this I-D, concentrating mainly on YANG issues and the integration with the core routing model. But I wonder - where should I send it? NETMOD or YANG doctors mailing list?

I guess the isis mailing list with a CC to the YANG doctors would be
the right approach. If YANG doctors then start debating certain
elements of your review, we may have to consider to extract these
issues and send them to the NETMOD wg. This is more or less how MIB
doctors work.

/js