Subject: [netmod] undecided Y36 associate a notification with a data node

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 2 Jun 2014 10:26:34 +0200

We need to decide whether this is in scope of YANG 1.1 or not.

There are several questions associated with this and perhaps this
requires some solution think through in order to understand the
implications in more details.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 03 Jun 2014 15:28:45 +0200

> implications in more details.

A general solution would IMO add a lot of complexity because the conditions triggering the notification may differ. For example:

- For a boolean leaf, should the notification be sent whenever the leaf is enabled, disabled or both?

- What are the triggering conditions for non-boolean leafs?

There are two good solutions for handling such needs:

- write appropriate description,

- define an extension.

So my preference is to reject this issue.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 10 Jun 2014 21:22:39 +0200

> implications in more details.

Interim proposal:

  Proposal: Reject this issue. May be considered for YANG 2.0.

If you disagree, please speak up by June 18th.

/js