Subject: Re: [netmod] I-D Action: draft-litkowski-netmod-isis-cfg-00.txt

From: t.petch <[email-masked]>
Date: Tue, 17 Jun 2014 16:21:52 +0100

Good to see.

My initial reaction is one to the choice of names and 'uses'.

The more 'uses' there are, the harder it is for me to understand what
the model is, unless and until I know them off by heart - which probably
will not happen for a protocol-specific model.

And e.g. to call the operational state tree 'op' when the other models
use '-state' again hampers my comprehension, as does the use of things
like 'interface-cfg'.  I do like it when you include '-isis-' in object
names and would favour some more of that.  I know, with YANG you can
have the same object name in a thousand different places in different
branches of the schema tree, but that does not mean it is a good idea:-(

Tom Petch

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, June 17, 2014 1:20 PM
Subject: I-D Action: draft-litkowski-netmod-isis-cfg-00.txt

>
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>
>
>         Title           : Yang Data Model for ISIS protocol
>         Author          : Stephane Litkowski
> Filename        : draft-litkowski-netmod-isis-cfg-00.txt
> Pages           : 22
> Date            : 2014-06-17
>
> Abstract:
>    This document defines a YANG data model that can be used to
configure
>    and manage ISIS protocol.
>
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-litkowski-netmod-isis-cfg/
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-litkowski-netmod-isis-cfg-00
>
>
> Please note that it may take a couple of minutes from the time of
submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 17 Jun 2014 18:32:06 +0200

> Good to see.

Absolutely.

> will not happen for a protocol-specific model.

Personally, I also prefer to use groupings only for node collections that are reused/reusable in multiple places. On the other hand, the IPFIX/PSAMP data model in RFC 6728 also uses lots of groupings but there it’s much more comprehensible because the groupings follow a uniform logic and are also nicely connected to the diagrams. 

> branches of the schema tree, but that does not mean it is a good idea:-(

I think this should be judged carefully on a case-by-case basis.

Lada

> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: <[email-masked]>
Date: Wed, 18 Jun 2014 07:58:21 +0000

Hi Tom,

Thanks for the feedback ...
It's my first YANG model coding, so sorry for some inconsistencies that I would be able to be fixed in future version ...

Regarding usage of "uses", I agree with your point that it may sort of complexify in a way, but in another way, it facilitates updates of the model by putting diffs only in one place (less errors). It may also simplify reading of big containers.

Regarding the "op" vs "state" , I would fix it ... regarding naming of object and containers I also agree with you, and I will fix by adding "isis" statement in names.

Stephane

-----Original Message-----
From: t.petch [mailto:[email-masked]] 
Sent: Tuesday, June 17, 2014 17:22
To: LITKOWSKI Stephane SCE/IBNF
Cc: [email-masked]
Subject: Re: I-D Action: draft-litkowski-netmod-isis-cfg-00.txt

Good to see.

The more 'uses' there are, the harder it is for me to understand what the model is, unless and until I know them off by heart - which probably will not happen for a protocol-specific model.

And e.g. to call the operational state tree 'op' when the other models use '-state' again hampers my comprehension, as does the use of things like 'interface-cfg'.  I do like it when you include '-isis-' in object names and would favour some more of that.  I know, with YANG you can have the same object name in a thousand different places in different branches of the schema tree, but that does not mean it is a good idea:-(

Tom Petch

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, June 17, 2014 1:20 PM
Subject: I-D Action: draft-litkowski-netmod-isis-cfg-00.txt

directories.
configure
submission
> Internet-Draft directories: http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.