Subject: [netmod] strawman REJECT Y24 YIN -> YANG translation breaks text formatting

From: Juergen Schoenwaelder <[email-masked]>
Date: Sun, 1 Jun 2014 17:19:57 +0200

This seems to add quite some complexity and it is unclear how widely
YIN is used to write YANG (most people seem to write YANG directly).

Speak up by June 10th if you disagree with this strawman proposal.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 02 Jun 2014 10:27:33 +0200

> YIN is used to write YANG (most people seem to write YANG directly).

I agree. If I am really the only person in the known universe that uses YIN, it might even make sense what Andy proposed - namely to move YIN out of the YANG spec.

On the other hand, it seems descriptions are quite often subject to machine processing, so it would be useful to have a recommended markup format for the YANG syntax, e.g. reStructuredText or markdown.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 2 Jun 2014 10:34:46 +0200

> On the other hand, it seems descriptions are quite often subject to machine processing, so it would be useful to have a recommended markup format for the YANG syntax, e.g. reStructuredText or markd…

The deadline for new feature submissions has passed.

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 2 Jun 2014 10:45:29 +0200

> The deadline for new feature submissions has passed.

I know that.

The first item only means restructuring that would make the main YANG spec cleaner and shorter. For instance, RELAX NG took the same approach: its compact syntax is defined in a separate document.

The second item is no new feature at all. Module writers can of course use some markup already now. However, having a RECOMMENDED markup format (with an informative reference) would mean more consistence and that would IMO be quite useful.

Lada