Subject: [netmod] undecided Y54 remove the advertisement of conformance information in NETCONF hello message

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 2 Jun 2014 10:33:30 +0200

We need to decide whether this is in scope of YANG 1.1 or not.

This may be subsumed by Y45 (OPEN) and Y16 (OPEN).

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 03 Jun 2014 15:49:21 +0200

> We need to decide whether this is in scope of YANG 1.1 or not.

I think this should be OPENed as it is one of the parts that are really NETCONF-specific.

Lada

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Tue, 3 Jun 2014 07:37:09 -0700

> I think this should be OPENed as it is one of the parts that are really
Agree to open, but solution very TBD

It is not really NETCONF-specific because the same URI could be conveyed
from the server to the client in different protocols. This text should just
identify
the contents of the URI without saying how it is used in a protocol.
Better yet would be to just advertise service-level YANG conformance
and drop module URIs from the advertisement.

Lada
Andy

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 3 Jun 2014 22:16:02 +0200

> I think this should be OPENed as it is one of the parts that are really NETCONF-specific.

Lets not confuse things. This issue is not about making YANG less
NETCONF specific. The question is whether this requires to the OPENed
or whether this is not already covered by Y45 (OPEN) and Y16 (OPEN).
If this is already covered, I prefer to not OPEN this another time.

/js

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 4 Jun 2014 13:37:01 +0200

> If this is already covered, I prefer to not OPEN this another time.

As I understand it, the point of Y54 is to move the specification of conformance declarations (whatever they are going to be) out of the YANG spec. IMO, this is worth considering and doesn’t seem to be covered by either Y16 or Y45 yet.

Maybe a new issue subsuming all three could be created.

Lada

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 10 Jun 2014 21:24:30 +0200

> This may be subsumed by Y45 (OPEN) and Y16 (OPEN).

Interim proposal:

  Proposal: Open this issue as it is related to the other conformance
  related issues.

If you disagree, please speak up by June 18th.

/js