Subject: [netmod] undecided Y26 allow mandatory nodes in augment

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 2 Jun 2014 10:20:54 +0200

We need to decide whether this is in scope of YANG 1.1 or not.

What are the implications of allowing mandatory in augments? Can this
be misused and do we need to constraint this?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Andy Bierman <[email-masked]>
Date: Mon, 2 Jun 2014 09:09:01 -0700

> be misused and do we need to constraint this?
I  think this is part of a larger issue -- how to design YANG modules for
reuse.
This should be an open issue.  There are design patterns that do not break
old clients, but constraining the language to only these patterns is still
a big TBD.

> /js
Andy

> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 03 Jun 2014 14:55:29 +0200

> old clients, but constraining the language to only these patterns is still

Yes, and it also has to do with conformance specification. For instance, ietf-routing module needs at least one address family specific module to be useful. So a conformace statement should say this, and then there is no reason why the address family modules augmenting ietf-routing couldn't define mandatory nodes.

Lada  

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 10 Jun 2014 21:21:05 +0200

> be misused and do we need to constraint this?

Interim proposal:

  Proposal: Open this issue even though a possible solution remains
  rather unclear.

If you disagree, please speak up by June 18th.

/js