Subject: [netmod] Comments on the draft of draft-litkowski-netmod-isis-cfg-00

From: Haoweiguo <[email-masked]>
Date: Thu, 7 Aug 2014 02:24:34 +0000

Hi Co-authors,

After reading this draft, i have the following comments and suggestions.

module: isis
+--rw isis-cfg
| +--rw instances
| +--rw instance [name]
| +--rw name
| +--rw enabled
| +--rw isis-level
| +--rw area
| +--rw system-id
| +--rw ipv4-router-id .....
| +--rw ipv6-router-id  ........

[weiguo]: I think IS-IS protocol doesn't use ipv4-router-id  and  ipv6-router-id , so it had better be removed.

+--rw isis-authentication-cfg
+--rw psnp-authentication
+--rw csnp-authentication
+--rw hello-authentication

+--rw isis-level-1-cfg
+--rw enabled
+--rw psnp-authentication
+--rw csnp-authentication
+--rw hello-authentication

[weiguo]: For the above authentication related config, PSNP-authentication and CSNP-authentication had better merge into single domain-authenciation, because PSNP and CSNP authentication configuration should be same. If two independant PSNP-authentication and CSNP-authentication exist, the operators can configure different para for PSNP and CSNP, confliction will occur.

Thanks

weiguo

---

From: <[email-masked]>
Date: Thu, 7 Aug 2014 08:25:04 +0000

Hi,

Thanks for the comment, please use the last version of the doc for your next comments (draft-litkowski-isis-yang-cfg).
Please find inline answers.

Stephane

From: netmod [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Thursday, August 07, 2014 04:25
To: [email-masked]
Subject: [netmod] Comments on the draft of draft-litkowski-netmod-isis-cfg-00

Hi Co-authors,

module: isis
+--rw isis-cfg
| +--rw instances
| +--rw instance [name]
| +--rw name
| +--rw enabled
| +--rw isis-level
| +--rw area
| +--rw system-id

[SLI] Wrong, IS-IS uses IPv4 and/or IPv6 router-ids. IPv4 router-id is TLV134 and it must be configurable.

+--rw isis-level-1-cfg
+--rw enabled

[SLI] Most of implementations already propose to tune authentication in this way ...

Thanks

weiguo

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Haoweiguo <[email-masked]>
Date: Thu, 7 Aug 2014 09:29:50 +0000

Hi,

Pls see my reply inline with [weiguo2] below.

Thanks

weiguo

________________________________
发件人: [email-masked] [[email-masked]]
发送时间: 2014年8月7日 16:25
收件人: Haoweiguo; [email-masked]
主题: RE: Comments on the draft of draft-litkowski-netmod-isis-cfg-00

Hi,

Stephane

Hi Co-authors,

module: isis
+--rw isis-cfg
| +--rw instances
| +--rw instance [name]
| +--rw name
| +--rw enabled
| +--rw isis-level
| +--rw area
| +--rw system-id
| +--rw ipv4-router-id

| +--rw ipv6-router-id

[weiguo2]: ipv4-router-id and ipv6-router-id  are for TE purpose, i think the two paras had better be configured in MPLS TE feature, then TE notifies IS-IS protocol to announce the para through the TLV134.

+--rw isis-level-1-cfg
+--rw enabled

[SLI] Most of implementations already propose to tune authentication in this way …

[weiguo2]: Sorry, i should correct my first comment as following:

 The authentication related config includes area-authentication, domain-authentication and hello-authentication, psnp-authentication and csnp-authentication name had better be modified.

Thanks

weiguo

---

From: <[email-masked]>
Date: Thu, 7 Aug 2014 14:29:42 +0000

module: isis
+--rw isis-cfg
| +--rw instances
| +--rw instance [name]
| +--rw name
| +--rw enabled
| +--rw isis-level
| +--rw area
| +--rw system-id
| +--rw ipv4-router-id

| +--rw ipv6-router-id

[SLI2] Even if router-ids where defined for TE purpose, they have now usage outside TE application and so configuration of router IDs is necessary even in non TE deployment.

+--rw isis-level-1-cfg
+--rw enabled

[SLI2] Hmmm ... that's a different way (Cisco way :) ) to view things ... From a protocol point of view, control of authentication is at PDU level. Each PDU may or not use authentication.

Thanks

weiguo

Thank you.

---

From: Haoweiguo <[email-masked]>
Date: Fri, 8 Aug 2014 05:57:37 +0000

发送时间: 2014年8月7日 22:29

module: isis
+--rw isis-cfg
| +--rw instances
| +--rw instance [name]
| +--rw name
| +--rw enabled
| +--rw isis-level
| +--rw area
| +--rw system-id
| +--rw ipv4-router-id

| +--rw ipv6-router-id

[weiguo3]: IMO, If the router-ids are used for other applications,  the configuation of router IDs had better be configured in these applications rather than in IS-IS.

+--rw isis-level-1-cfg
+--rw enabled

[SLI2] Hmmm … that’s a different way (Cisco way :) ) to view things … From a protocol point of view, control of authentication is at PDU level. Each PDU may or not use authentication.

Thanks

weiguo

Thank you.

---

From: <[email-masked]>
Date: Fri, 8 Aug 2014 07:59:36 +0000

module: isis
+--rw isis-cfg
| +--rw instances
| +--rw instance [name]
| +--rw name
| +--rw enabled
| +--rw isis-level
| +--rw area
| +--rw system-id
| +--rw ipv4-router-id

| +--rw ipv6-router-id

[weiguo3]: IMO, If the router-ids are used for other applications,  the configuation of router IDs had better be configured in these applications rather than in IS-IS.
[SLI3] IMO, advertisement of ISIS information should be kept in ISIS configuration. That's the way it's done today.