Subject: Re: [netmod] [nvo3] YANG models for OAM

From: "O'Connor, Don" <[email-masked]>
Date: Fri, 1 Aug 2014 20:00:48 +0000

Greg

The scope of the MEF specifications is the Ethernet Service Layer for Carrier Ethernet Services – Fault Management and Performance Management

Regards

Don

From: L2vpn [mailto:[email-masked]] On Behalf Of Greg Mirsky
Sent: Thursday, July 31, 2014 6:49 PM
To: O'Connor, Don
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nvo3] YANG models for OAM

Hi Don,
thank you for the reference. And I'd point that ITU SG15 is working on standardizing "generic protocol-neutral management information model" for transport network, including OAM. Hence my question, What is the scope of these documents?
Regards,
Greg

On Thu, Jul 31, 2014 at 4:31 PM, O'Connor, Don <[email-masked]<mailto:[email-masked]>> wrote:
Tissa, Greg, all

Metro Ethernet Forum has already standardized Yang Modules for Ethernet Service OAM Performance Monitoring and Fault Management. Please see MEF 38 and 39

http://metroethernetforum.org/carrier-ethernet/technical-specifications

Regards

Don

From: L2vpn [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Tissa Senevirathne
Sent: Thursday, July 31, 2014 5:53 PM
To: Greg Mirsky; Tissa Senevirathne (tsenevir)

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] YANG models for OAM

Greg

Yes it is, generic YANG model steup the base framework. It can be extended to add tools as well as other elements as well technology deviations. Alarms etc either be part of this document will be a separate document that specifies them. That is the reason we have designed the model as modular as possible and extensible as possible.

Please let us know if any of the parts are not extensible or not modular enough.

Thanks
Tissa

On Thursday, July 31, 2014 3:17 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Hi Tissa, authors, et. al,
I've read documents and would like to clarify scope of these documents. OAM is not limited to ping and traceroute functions. It even not limited to continuity check. And in connectionless networks there would not be connectivity verification. And the performance measurement is the big part of OAM as well as protection coordination, defect alarms, and etc. Hence my question, is it in plans of the authors to address all of OAM in respective documents?
Regards,
Greg

On Tue, Jun 10, 2014 at 12:03 PM, Tissa Senevirathne (tsenevir) <[email-masked]<mailto:[email-masked]>> wrote:
All

We have published YANG model for OAM. #1 draft below place the generic framework for OAM, that can be augmented for different technologies. #2 and #3 are application of the concept to NVO3 and TRILL,

1.      http://datatracker.ietf.org/doc/draft-tissa-netmod-oam/
2.      http://datatracker.ietf.org/doc/draft-tissa-nvo3-yang-oam/
3.      http://datatracker.ietf.org/doc/draft-tissa-trill-yang-oam/

Please review and share your comments

Thanks
Tissa

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "O'Connor, Don" <[email-masked]>
Date: Fri, 1 Aug 2014 20:08:22 +0000

Tissa

The MEF standards apply to the Ethernet Service Layer of Carrier Ethernet Services. Are the IDs in your email constrained to layers below the Ethernet Service Layer for Carrier Ethernet Service? Or are they not applicable to Carrier Ethernet Service?

Regards

Don

From: L2vpn [mailto:[email-masked]] On Behalf Of Tissa Senevirathne (tsenevir)
Sent: Thursday, July 31, 2014 6:49 PM
To: O'Connor, Don; Tissa Senevirathne; Greg Mirsky
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nvo3] YANG models for OAM

Don

I am aware of that, but this is different, MEF YANG model is specifically for Ethernet and structure does not allow to bring different addressing schemes other than MAC address. Additionally the proposed standard allow to add flow entropies and facilitate nested OAM between different technologies. You may have to read in to the details to see the actual differences.

From: O'Connor, Don [mailto:[email-masked]]
Sent: Thursday, July 31, 2014 4:32 PM
To: Tissa Senevirathne; Greg Mirsky; Tissa Senevirathne (tsenevir)
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [nvo3] YANG models for OAM

Tissa, Greg, all

Regards

Don

From: L2vpn [mailto:[email-masked]] On Behalf Of Tissa Senevirathne

Greg

Thanks
Tissa

Thanks
Tissa