Subject: [netmod] YANG plugin for Eclipse

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 13 Aug 2014 10:34:00 -0700

Can anyone recommend a plugin for YANG for the latest version of Eclipse
(Kepler)?

The ones I have tried (http://bcsw.net/YangEclipsePlugIn and
http://atnog.av.it.pt/~ptavares/yangplugin/installation/) are for older
versions or just do not work.

Thanks.

-- 
Mahesh Jethanandani
[email-masked]

---

From: Jan Lindblad <[email-masked]>
Date: Thu, 14 Aug 2014 15:55:09 +0200

Mahesh,

> Can anyone recommend a plugin for YANG for the latest version of Eclipse (Kepler)? 
> 
> The ones I have tried (http://bcsw.net/YangEclipsePlugIn

Tried the one above now, and it works fine for me in Kepler. Doesn't do very much yet, though. Syntax coloring (but not completely correct), indentation/outdentation, and keyword completion is what I've found. 

Outline view is what I'm really looking forward to! It's listed on the roadmap.

> and http://atnog.av.it.pt/~ptavares/yangplugin/installation/) are for older versions or just do not work.

Have tried this one in the past, but as you say it appears to no longer be developed and doesn't function with any remotely recent Eclipse version.

Best Regards,
/jan
--
Jan Lindblad, [email-masked], +46 702855728
Solutions Architect/Business Development, CTO Office
Cisco Cloud and Virtualization Group