Subject: Re: [netmod] metadata in JSON

From: Randy Presuhn <[email-masked]>
Date: Tue, 26 Aug 2014 11:25:54 -0700 (GMT-07:00)

Hi -

>From: Ladislav Lhotka <[email-masked]>
>Sent: Aug 26, 2014 7:38 AM
>To: Jürgen Schönwälder <[email-masked]>
>Cc: [email-masked]
>Subject: Re: [netmod] metadata in JSON
...
>I don’t think your previous objection that (non-IETF)
>module names aren’t guaranteed to be unique is really
>relevant: a server implementing two different modules
>with the same name must be considered seriously broken.

Consider, however, (1) the *client* working with multiple
servers using the same module name to refer to different
things, and (2) the situation in "open" systems with
components from multiple vendors installed.

Randy

---

From: Andy Bierman <[email-masked]>
Date: Tue, 26 Aug 2014 11:39:52 -0700

On Tue, Aug 26, 2014 at 11:25 AM, Randy Presuhn <
[email-masked]> wrote:

> >I don't think your previous objection that (non-IETF)
> >module names aren't guaranteed to be unique is really
The module names are supposed to start with some string to distinguish
the organization, e.g., ietf-interfaces and acme-interfaces should never
clash.

Randy

Andy

>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 27 Aug 2014 09:15:15 +0200

> components from multiple vendors installed.

Either situation represents no real problem because explicit namespace
identifiers will almost never be used - the client will just use local
names. A conflict could arise only in the case when two different
modules having the same name augment the same target node with sibling
nodes having identical local names, and a server uses such a bizarre
data model.

The price we pay for it is that the client has to keep the context
(i.e. the data model) for every server, but we want to do it anyway I
guess.

Lada

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C