Subject: [netmod] one module imported with two different prefixes

From: "Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Thu, 14 Jan 2016 09:11:52 +0000

Dear all

We've come across following set of import statements in YANG file:

import  a {
    prefix "a0";
}

import a {
    prefix "a1";
}

So, there is one module imported with 2 different prefixes and used at various places.

We're not sure if this is completely valid input for our YANG statement parser.

  Thank you for help.

       Best Regards

            Martin

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 14 Jan 2016 10:28:08 +0100 (CET)

> We're not sure if this is completely valid input for our YANG

There is no text in RFC 6020 (or 6020bis) that makes this invalid.

/martin

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 14 Jan 2016 10:49:22 +0100

> On 14 Jan 2016, at 10:28, Martin Bjorklund <[email-masked]> wrote:
> 

Yes, and in fact it is possible to import different revisions of the same module this way.

Lada

> 
> 
> /martin
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 14 Jan 2016 10:55:41 +0100 (CET)

> Yes, and in fact it is possible to import different revisions of the

Not in YANG 1, but it is allowed in 1.1.

RFC 6020 says:

   Multiple revisions of the same module MUST NOT be imported.

/martin

---

From: "Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco)" <[email-masked]>
Date: Thu, 14 Jan 2016 10:03:39 +0000

Hi all

Thank you for sharing your knowledge.
Obviously, we see the point of importing different revisions of very same module,
but in our case, revision is only one, so, that's why we've checked with you. Thanks.

   Best Regards

        Martin
________________________________________
Od: Martin Bjorklund <[email-masked]>
Odoslané: 14. januára 2016 10:55
Komu: [email-masked]
Kópia: Martin Ciglan -X (mciglan - PANTHEON TECHNOLOGIES at Cisco); Robert Varga -X (rovarga - PANTHEON TECHNOLOGIES at Cisco); Tony Tkacik -X (ttkacik - PANTHEON TECHNOLOGIES at Cisco); Peter Kajsa -X (pkajsa - PANTHEON TECHNOLOGIES at Cisco); [email-masked]
Predmet: Re: [netmod] one module imported with two different prefixes

RFC 6020 says:

/martin