Subject: [netmod] ABNF production for refine-stmt

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 18 Feb 2016 17:30:46 +0100

Hi,

$SUBJ doesn't allow for multiple default statements that are possible for leaf-lists:

OLD

   refine-stmt         = refine-keyword sep refine-arg-str optsep
                          "{" stmtsep
                              ;; these stmts can appear in any order
                              *if-feature-stmt
                              *must-stmt
                              [presence-stmt]
                              [default-stmt]
                              [config-stmt]
                              [mandatory-stmt]
                              [min-elements-stmt]
                              [max-elements-stmt]
                              [description-stmt]
                              [reference-stmt]
                            "}" stmtsep

NEW

   refine-stmt         = refine-keyword sep refine-arg-str optsep
                          "{" stmtsep
                              ;; these stmts can appear in any order
                              *if-feature-stmt
                              *must-stmt
                              [presence-stmt]
                              *default-stmt
                              [config-stmt]
                              [mandatory-stmt]
                              [min-elements-stmt]
                              [max-elements-stmt]
                              [description-stmt]
                              [reference-stmt]
                            "}" stmtsep

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 19 Feb 2016 12:18:39 +0100 (CET)

Hi,

You're right, I have applied the fix.

/martin

Ladislav Lhotka <[email-masked]> wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 19 Feb 2016 12:23:47 +0100

Lada,

this indeed looks like a bug. Martin (and others), can you confirm
this? If so, we should make sure we get this bug fixed as part of the
IESG review and approval.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 19 Feb 2016 12:33:28 +0100

I created a new file to keep track of issues during the IESG
processing cycle:

http://svn.tools.ietf.org/svn/wg/netmod/yang-1.1/iesg-process-comments.txt

/js