Subject: [netmod] 'uses' as a sub-statement to 'choice' statement?

From: Kent Watsen <[email-masked]>
Date: Tue, 2 Feb 2016 17:39:35 +0000

In a model where the choice shorthand notation is being used, it is necessary to use longhand notation if wanting a case statement to be defined by the ‘uses’ statement.   That is, 6020bis allows ‘uses’ as a sub-statement to the ‘case’ statement, but not to the ‘choice’ statement.  As an example, this choice statement:

     choice interface-type {
       case ethernet {
         uses ethernet;
       }
       case optical {
         uses optical;
       }
     }

Cannot use shorthand notation:

     choice interface-type {
       uses ethernet;
       uses optical;
     }

This seems like a bug to me.   Is it too late to fix in 6020bis as an issue raised by WGLC?

Kent  // as a contributor

---

From: Ladislav Lhotka <[email-masked]>
Date: Tue, 2 Feb 2016 19:03:30 +0100

> On 02 Feb 2016, at 18:39, Kent Watsen <[email-masked]> wrote:
> 
> 

This has already been discussed, see

https://mailarchive.ietf.org/arch/search/?email_list=netmod&gbt=1&index=uF7kbBPMxIBAMUm03D3AqxaJvK4

Lada

> 
> Kent  // as a contributor
> 
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Andy Bierman <[email-masked]>
Date: Tue, 2 Feb 2016 10:07:47 -0800

Hi,

I do not think this is a bug.
The uses-stmt has no node name, just a grouping name,
which may have a prefix.

In the example above 'ethernet' and 'optical' are forced to
be local names and be unique local names.

Andy

On Tue, Feb 2, 2016 at 9:39 AM, Kent Watsen <[email-masked]> wrote:

>
> In a model where the choice shorthand notation is being used, it is
> necessary to use longhand notation if wanting a case statement to be
> defined by the ‘uses’ statement.   That is, 6020bis allows ‘uses’ as a
> sub-statement to the ‘case’ statement, but not to the ‘choice’ statement.
> As an example, this choice statement:
>
>      choice interface-type {
>        case ethernet {
>          uses ethernet;
>        }
>        case optical {
>          uses optical;
>        }
>      }
>

---

From: Kent Watsen <[email-masked]>
Date: Tue, 2 Feb 2016 18:49:33 +0000

>https://mailarchive.ietf.org/arch/search/?email_list=netmod&gbt=1&index=uF7kbBPMxIBAMUm03D3AqxaJvK4

Okay, good answer.  Never mind.

Thanks,
Kent