Subject: [netmod] Last Call: <draft-ietf-netmod-yang-json-08.txt> (JSON Encoding of Data Modeled with YANG) to Proposed Standard

From: The IESG <[email-masked]>
Date: Wed, 24 Feb 2016 06:07:46 -0800

The IESG has received a request from the NETCONF Data Modeling Language
WG (netmod) to consider the following document:
- 'JSON Encoding of Data Modeled with YANG'
  <draft-ietf-netmod-yang-json-08.txt> as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits
final comments on this action. Please send substantive comments to the
[email-masked] mailing lists by 2016-03-09. Exceptionally, comments may be
sent to [email-masked] instead. In either case, please retain the
beginning of the Subject line to allow automated sorting.

Abstract

   This document defines encoding rules for representing configuration,
   state data, parameters of RPC operations or actions, and
   notifications defined using YANG as JavaScript Object Notation (JSON)
   text.

The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-json/

IESG discussion can be tracked via
https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-json/ballot/

No IPR declarations have been submitted directly on this I-D.

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 25 Feb 2016 14:26:17 +0100

Tom,

> On 25 Feb 2016, at 13:42, tom p. <[email-masked]> wrote:
> 
> In the interests of clarity
> 
> - datastores are not mentioned.  These loom large in YANG and NETCONF
> and, I think, have been misunderstood by those wishing to extend YANG in
> various, new directions.  Therefore I think that the I-D should say
> something, even if it is that the concept of datastore is alien to the
> envisaged uses of JSON (I could envisage a use where datastores do
> apply, but it is probably an unrealistic use:-)

I don't understand. This draft is about encoding a data tree in JSON under the assumption that the data tree is valid with respect to a YANG data model. How is this related to datastores? In particular, I don't think the concept of datastores is alien to it in any way (proofs exist to the contrary).

> 
> -YANG 1.0 ditto.  I realise that this I-D normatively references YANG
> 1.1 but there is a lot of YANG 1.0 about.  My sense is that this I-D
> cannot work with YANG 1.0, in which case, I think that that needs
> stating.

Right, this I-D references YANG 1.1 because, among other things, it also defines the encoding for "anydata", which is a new YANG 1.1 feature. All other rules are applicable to YANG 1.0. Anyway, I believe all new implementations should use YANG 1.1.

> 
> - the examples use the exact same identifiers (foo, bar) to identify an
> object and a namespace prefix.  Experts in YANG will know well the many
> namespaces in YANG and their scope and so could not posssibly be
> confused; but unless the I-D wants to make the point that there are many
> namespaces in YANG with different scopes, then I think that the worked
> examples should use distinct identifiers.

This is a valid point. I will change the prefixes to "foomod" and "barmod".

Thanks, Lada

> 
> Tom Petch
> 
> ----- Original Message -----
> From: "The IESG" <[email-masked]>
> Sent: Wednesday, February 24, 2016 2:07 PM
> 
>> 

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C