Subject: Re: [netmod] Broadband Forum intention of using ietf-entity YANG module

From: William Lupton <[email-masked]>
Date: Wed, 10 Feb 2016 16:41:46 +0000

Is there a status update on ietf-entity please? I don't see it as a milestone in the charter but maybe I don't know where to look.

Message received re YANG 1.1. All BBF YANG will use YANG 1.1.

Thanks,
William

> On 15 Dec 2015, at 10:17, Romascanu, Dan (Dan) <[email-masked]> wrote:
> 
> So, let's do it. Tom, or one of the other chairs - you need to run this. 
> 
> Regards,
> 
> Dan
> 
> 
>> -----Original Message-----
>> From: Benoit Claise [mailto:[email-masked]]
>> Sent: Monday, December 14, 2015 9:18 PM
>> To: Nadeau Thomas; Romascanu, Dan (Dan)
>> Cc: [email-masked]
>> Subject: Re: [netmod] Broadband Forum intention of using ietf-entity YANG
>> module
>> 
>> 
>>> 	I personally don’t see anything that prevents this.
>> Same opinion here.
>> 
>> Regards, Benoit
>>> 
>>> 	—Tom
>>> 
>>>> On Dec 13, 2015:6:56 AM, at 6:56 AM, Romascanu, Dan (Dan)
>> <[email-masked]> wrote:
>>>> 
>>>> Concerning the 'draft status' - anything prevents the wg from running a
>> short consensus call and adding this item to the netmod milestones?
>>>> 
>>>> Regards,
>>>> 
>>>> Dan
>>>> 
>>>> 
>>>>> -----Original Message-----
>>>>> From: netmod [mailto:[email-masked]] On Behalf Of Nadeau
>>>>> Thomas
>>>>> Sent: Friday, December 11, 2015 4:27 PM
>>>>> To: William Lupton
>>>>> Cc: [email-masked]
>>>>> Subject: Re: [netmod] Broadband Forum intention of using ietf-entity
>>>>> YANG module
>>>>> 
>>>>> 
>>>>> 	Dependance on 1.1 should not be an issue as that is almost ready to
>>>>> be approved. You should be building your model to comply with the 1.1
>> rules.
>>>>> 
>>>>> 	—Tom
>>>>> 
>>>>> 
>>>>>> On Dec 11, 2015:8:00 AM, at 8:00 AM, William Lupton
>>>>> <[email-masked]> wrote:
>>>>>> All,
>>>>>> 
>>>>>> The Broadband Forum would like to use the ietf-entity YANG module
>>>>> (currently draft-entitydt-netmod-entity) for equipment management
>>>>> but we are a bit concerned about its draft status and its dependence on
>> YANG 1.1.
>>>>> Any advice or reassurance?
>>>>>> Thanks,
>>>>>> William
>>> _______________________________________________
>>> netmod mailing list
>>> [email-masked]
>>> https://urldefense.proofpoint.com/v2/url?u=https-
>> 3A__www.ietf.org_mail
>>> 
>> man_listinfo_netmod&d=BQIDaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGx
>> R31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=9jKcR2EbKD3lb73tciJMJAk0J6
>> 2dQAbsU_4R85zluXs&s=eBlkOZe4c5IXMoz_2YJnIKglubNBDQmS0Ej03Al8meI
>> &e=
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Benoit Claise <[email-masked]>
Date: Tue, 23 Feb 2016 12:16:28 +0100

Dear all,

It would be great if we can receive a status update on the Entity YANG 
model from the design team.
And a milestone on the NETMOD charter would also make sense.

Regards, Benoit
> .

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 23 Feb 2016 12:30:49 +0100 (CET)

> model from the design team.

The design team is waiting for the WG to decide on adoption of the
document.  Last time this was discussed I think the chairs said that
the WG did not have any cycles for new work until current work was
finished, but I'll leave this to the chairs to answer.

There are actually quite a few drafts to consider when it is time to
add more work to the WG; "mount", "opstate",
draft-entitydt-netmod-entity, draft-wilton-netmod-intf-ext-yang,
draft-wilton-netmod-intf-vlan-yang,
draft-lear-ietf-netmod-acl-dnsname, draft-vallin-alarm-yang-module to
name a few.  I guess we need to prioritize.

/martin

> > Is there a status update on ietf-entity please? I don't see it as a
> > milestone in the charter but maybe I don't know where to look.
> >
> >>> YANG

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 23 Feb 2016 11:35:26 +0000

Speaking about mount - was I the alone in thinking during the virtual interim yesterday about the relationship between the entity and mount I-Ds. Maybe up to merging them? Are not NLEs the same (or almost) as logical entities? 

Regards,

Dan

> From: Martin Bjorklund [mailto:[email-masked]]
> Sent: Tuesday, February 23, 2016 1:31 PM
> To: [email-masked]
> Cc: [email-masked]; Romascanu, Dan (Dan);
> [email-masked]
> > >> On 15 Dec 2015, at 10:17, Romascanu, Dan (Dan)
> <[email-masked]>
> 
> > >> wrote:
> 
> > >>
> 
> > >> So, let's do it. Tom, or one of the other chairs - you need to run
> 
> > >> this.
> 
> > >>
> 
> > >> Regards,
> 
> > >>
> 
> > >> Dan
> 
> > >>
> 
> > >>
> 
> > >>>>> Concerning the 'draft status' - anything prevents the wg from
> running
> 
> > >>>>> a
> 
> > >>>>>> but we are a bit concerned about its draft status and its
> dependence
> 
> > >>>>>> on
> 
> > >>> YANG 1.1.
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 23 Feb 2016 07:03:57 -0500

Dan,
I could see entity as perhaps another use case, but don't understand how it 
could be another possible solution. Am I missing something?

Lou

On February 23, 2016 6:36:01 AM "Romascanu, Dan (Dan)" <[email-masked]> 
wrote:

> Speaking about mount - was I the alone in thinking during the virtual 
> interim yesterday about the relationship between the entity and mount I-Ds. 
> Maybe up to merging them? Are not NLEs the same (or almost) as logical 
> entities?
>
> Regards,
>
> Dan
>
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 23 Feb 2016 12:19:09 +0000

That's what I meant - LNEs seem to be an instantiation of logical entities. 

Regards,

Dan

> From: Lou Berger [mailto:[email-masked]]
> Sent: Tuesday, February 23, 2016 2:04 PM
> To: Romascanu, Dan (Dan); Martin Bjorklund; [email-masked]
> Cc: [email-masked]