Subject: [netmod] NETMOD WG Virtual Interim Meeting: 22 February 2016

From: IESG Secretary <[email-masked]>
Date: Wed, 10 Feb 2016 07:46:24 -0800

The NETCONF Data Modeling Language (NETMOD) WG will have a virtual 
interim meeting on 22 February 2016 at 10:00 EST (15:00 UTC) to discuss 
use-cases and solutions for combining YANG modules into the schema 
defined in other YANG modules, as this is a blocking item for some other 
working groups currently. The agenda for the meeting is:

5 min: agenda bashing, scribes, note well, etherpad, etc.
20 min: use-case summary (draft-rtgyangdt-rtgwg-device-model-02)
20 min: proposal #1 (draft-lhotka-netmod-ysdl-00)
20 min: proposal #2 (draft-bjorklund-netmod-structural-mount-00)
55 min: general discussion or end early

All participants should come prepared to discuss these drafts.

Note: it is understood that draft-clemm-netmod-mount is related work, 
but the chairs wish to only focus on the schema composition issue at 
this time.

Etherpad: http://etherpad.tools.ietf.org:9000/p/netmod-interim-20160222

Regards,

NETMOD Chairs

--
NETMOD Virtual Interim Meeting
Monday, February 22, 2016
4:00 pm | Europe Time (Berlin, GMT+01:00) | 2 hrs

Join WebEx meeting:
https://ietf.webex.com/ietf/j.php?MTID=me171803d3dfe83d3f0d003f8332b032f
Meeting number: 646 684 956
Meeting password: Qbds3nPZ

Join by phone
1-877-668-4493 Call-in toll free number (US/Canada)
1-650-479-3208 Call-in toll number (US/Canada)
Access code: 646 684 956
Toll-free calling restrictions

Add this meeting to your calendar. (Cannot add from mobile devices.)
https://ietf.webex.com/ietf/j.php?MTID=mf4e7a67f2b45f6542947fa3464d35e05

Can't join the meeting? Contact support.

IMPORTANT NOTICE: Please note that this WebEx service allows audio and 
other information sent during the session to be recorded, which may be 
discoverable in a legal matter. By joining this session, you 
automatically consent to such recordings. If you do not consent to being 
recorded, discuss your concerns with the host or do not join the 
session.

---

From: Kent Watsen <[email-masked]>
Date: Mon, 22 Feb 2016 13:23:20 +0000

Friendly reminder, this meeting starts in about 90 minutes.

Cheers,
Kent

On 2/10/16, 10:46 AM, "netmod on behalf of IESG Secretary" <[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>netmod mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/netmod

---

From: Kent Watsen <[email-masked]>
Date: Mon, 22 Feb 2016 20:50:53 +0000

Thank you all who joined today’s virtual interim meeting.

Other than my starting the recording late and rearranging the presentation order, I thought that the meeting went really well in that there seems to be a lot of support for trying to solve this problem, and because we have a plan to try to move towards having a WG document in the BA timeframe.  The plan is for draft-bjorklund-netmod-structural-mount to be updated based on the meeting and for it to be discussed on list as the basis for the WG effort on the topic.

Attached are the very rough Ethernet minutes captured during the meeting.  Please review carefully.  Corrections can be made on the etherpad here: http://etherpad.tools.ietf.org:9000/p/netmod-interim-20160222  (so we can track changes, the end of meeting snapshot is here: http://etherpad.tools.ietf.org:9000/p/netmod-interim-20160222/timeslider#3933)

To listen to the recording, please follow one of these two links:

  Streaming recording link:
    https://ietf.webex.com/ietf/ldr.php?RCID=4dc88386f13a49fa8f2c934db953f4a2

  Download recording link:
    https://ietf.webex.com/ietf/lsr.php?RCID=1b6490fe5cc6fc95d4e3c9b913dfdc1f

Thanks again,

Kent and Lou

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Tue, 23 Feb 2016 23:21:18 +0000

Hi Kent,

Thanks for running the interim, I agree it was quite useful.    

One thing I wanted to pull out from the minutes was the overall definition of "Mount".     Right now there are 830 web pages on the OpenDaylight site which refer to "Mount" in terms of Peer Mount (i.e., something much like draft-clemm-netmod-mount).   

That does not mean that the IETF need define "Mount" the same way as an Open Source project.  But it is possible at this stage to create both terminology and requirements which breaks down the overall problem space.   In other words there is nothing stopping us from defining a set of terms and technology solutions which fit together in a complimentary way.  Nothing here need conflict.

If there is community interest, I would be willing to pull together a strawman requirements/terminology draft describing the differences between mounting schemas on a box, mounting a remote datastore.

Any interest?
Eric 

> From: netmod, February 22, 2016 3:51 PM
> 
> 
> Other than my starting the recording late and rearranging the presentation order,
> I thought that the meeting went really well in that there seems to be a lot of
> support for trying to solve this problem, and because we have a plan to try to
> move towards having a WG document in the BA timeframe.  The plan is for
> draft-bjorklund-netmod-structural-mount to be updated based on the meeting
> and for it to be discussed on list as the basis for the WG effort on the topic.
> 
> Attached are the very rough Ethernet minutes captured during the meeting.
> Please review carefully.  Corrections can be made on the etherpad here:
> http://etherpad.tools.ietf.org:9000/p/netmod-interim-20160222  (so we can
> track changes, the end of meeting snapshot is here:
> http://etherpad.tools.ietf.org:9000/p/netmod-interim-
> 20160222/timeslider#3933)
>

---

From: Kent Watsen <[email-masked]>
Date: Wed, 24 Feb 2016 00:18:42 +0000

Hi Eric,

If you have a proposal, please send.  A draft seems overkill to me, but maybe you have something in mind?

I’m personally okay to name the schema-mount thing to something that doesn’t use the word “mount”, so long as it’s still easy to understand.  Worst case we could all switch to using long form (e.g., schema-mount-point, instance-mount-point), what do you think?

Kent

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 24 Feb 2016 01:27:25 +0000

> From: Kent Watsen, February 23, 2016 7:19 PM
> 
> Hi Eric,
> 

I have only the beginnings of a division of terminology and function in mind.  I would put time into this should people care.  More below.

> I’m personally okay to name the schema-mount thing to something that doesn’t
> use the word “mount”, so long as it’s still easy to understand.  Worst case we
> could all switch to using long form (e.g., schema-mount-point, instance-mount-
> point), what do you think?

At IETF 94, there was a proposal for something called Alias Mount.
https://www.ietf.org/proceedings/94/slides/slides-94-netmod-19.pdf
(see slide 6)
Alias mount didn't add a reference to an external box (like peer mount).  It included just the subset of configuration needed to reference a locally targeted subtree.   There were not provisions to augment the schema with additional info.

I can see a reason for schema mount, alias mount, and peer mount.  So without thinking too deeply, I believe it should be possible to have the needed parameters for WG selected mount variations which could be placed under the generalized mount keyword.  

This would seem to be an approach which is extensible, and which allows the technology solutions/requirements to be driven in parallel.

Eric

> >One thing I wanted to pull out from the minutes was the overall definition of
> "Mount".     Right now there are 830 web pages on the OpenDaylight site which
> refer to "Mount" in terms of Peer Mount (i.e., something much like draft-clemm-
> netmod-mount).
> >
> >That does not mean that the IETF need define "Mount" the same way as an
> Open Source project.  But it is possible at this stage to create both terminology
> and requirements which breaks down the overall problem space.   In other
> words there is nothing stopping us from defining a set of terms and technology
> solutions which fit together in a complimentary way.  Nothing here need
> conflict.
> >
> >If there is community interest, I would be willing to pull together a strawman
> requirements/terminology draft describing the differences between mounting
> schemas on a box, mounting a remote datastore.
> >
> >Any interest?
> >Eric
> >
> >> Other than my starting the recording late and rearranging the
> >> presentation order, I thought that the meeting went really well in
> >> that there seems to be a lot of support for trying to solve this
> >> problem, and because we have a plan to try to move towards having a
> >> WG document in the BA timeframe.  The plan is for
> >> draft-bjorklund-netmod-structural-mount to be updated based on the
> meeting and for it to be discussed on list as the basis for the WG effort on the
> topic.
> >>
> >> http://etherpad.tools.ietf.org:9000/p/netmod-interim-20160222  (so we
> >> can track changes, the end of meeting snapshot is here:

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 24 Feb 2016 09:53:38 +0100

Hi Eric,

I agree with you that it is important to distinuguish the construction of a data model schema from mechanisms for combining data trees, and I believe the term "mount" is mostly connected to the latter (as in NFS mount). FWIW, the YSDL draft doesn't use the term "mount" at all.

I'd suggest to wait for the concrete technical solution of structural-mount/YSDL, then it may be easier to figure out an appropriate term.

Lada

> On 24 Feb 2016, at 00:21, Eric Voit (evoit) <[email-masked]> wrote:
> 
> Hi Kent,
> 

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Nadeau Thomas <[email-masked]>
Date: Wed, 24 Feb 2016 09:19:30 -0500

> On Feb 23, 2016:6:21 PM, at 6:21 PM, Eric Voit (evoit) <[email-masked]> wrote:
> 
> Hi Kent,
> 
	
	I agree that normalizing the terminology is probably a good thing.  What I would caution against is a unilateral definition here as it is likely to be IETF-centric; its a good idea to poll the other communities that are using this technology.

	—Tom

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 24 Feb 2016 19:39:02 +0000

> From: Nadeau Thomas, February 24, 2016 9:20 AM
> 
> 	I agree that normalizing the terminology is probably a good thing.  What
> I would caution against is a unilateral definition here as it is likely to be IETF-
> centric; its a good idea to poll the other communities that are using this
> technology.

Makes sense.   Any thoughts on who might represent the meaning of Mount from ODL?

Eric

---

From: Nadeau Thomas <[email-masked]>
Date: Wed, 24 Feb 2016 15:02:06 -0500

> On Feb 24, 2016:2:39 PM, at 2:39 PM, Eric Voit (evoit) <[email-masked]> wrote:
> 

	I’d ask on the yangtools-dev or controller-dev lists.

	—Tom