Subject: [netmod] YANG library draft. WG check of last call edits

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 4 Feb 2016 11:09:13 -0800

The yang-library draft went through a Last Call that ended January 22. Martin has taken the suggestions from the last call comments and posted an updated draft.

https://tools.ietf.org/html/draft-ietf-netconf-yang-library-04 <https://tools.ietf.org/html/draft-ietf-netconf-yang-library-04>

Please review it for the changes made to the draft and any edits that were either missed or are not right. This would not be a time to bring in new changes or comments.

The comment/review period will go till Monday, February 15, at which time it will be sent to our fearless AD, Benoit Claise for publication.

Cheers.

Mahesh & Mehmet.

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 08 Feb 2016 10:59:17 +0100

Hi,

I found one thing that may need clarification: consider a module
containing deviations that's present in the "module" list as
required. What happens if such a module does not appear in the "deviation"
list of a module to which its deviation(s) are supposed to apply? Does
it mean that such deviations are ignored?

This doesn't seem to be specified in the description of the "deviation"
list, or elsewhere.

Lada

Mahesh Jethanandani <[email-masked]> writes:

> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

-- 
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Mon, 08 Feb 2016 11:12:40 +0100 (CET)

> it mean that such deviations are ignored?

Yes.  Just as it does today with similar info in <hello>.  Note that
this is not an error.  For example, you might have a deviation module
that deviates A and B, but in one particular implemementation, only
the deviation for A applies.

/martin

> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 8 Feb 2016 11:33:03 +0100

> On 08 Feb 2016, at 11:12, Martin Bjorklund <[email-masked]> wrote:
> 

IMO this isn't sufficiently explained in RFC 6020 either.

> the deviation for A applies.

OK, although this seems over-engineered, given that deviations are strongly discouraged and cannot be standardised. I assume deviation modules should mostly be very device-specific.

Lada

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 17 Feb 2016 08:30:41 -0800

The review period for changes made to the draft is now closed.

There are two issues that are open on GitHub that need addressing. The authors are waiting on a response on how to address the secdir review comments, and will work on addressing the second issue raised by Lada.

Other than that, idnits has revealed this issue, although it is not clear why. I see that in terminology section (1.1), the recommended boiler plate statements exist for RFC 2119.

Miscellaneous warnings:
  ----------------------------------------------------------------------------

  == The document seems to lack the recommended RFC 2119 boilerplate, even if
     it appears to use RFC 2119 keywords. 

     RFC 2119, paragraph 2:
        The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
        "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in
        this document are to be interpreted as described in RFC 2119.

     (The document does seem to have the reference to RFC 2119 which the
     ID-Checklist requires).

It also complains about this, which is not clear to me.
tmp/draft-ietf-netconf-yang-library-04.txt(201): Line has weird spacing: '...-set-id    str...'
tmp/draft-ietf-netconf-yang-library-04.txt(210): Line has weird spacing: '...evision    uni...'
tmp/draft-ietf-netconf-yang-library-04.txt(215): Line has weird spacing: '...evision    uni...'

Once the authors have received a response from secdir, and post an updated draft (as need to address the other open issue), I will check the diffs, finish my writeup and send the document to Benoit.

Thanks

> On Feb 4, 2016, at 11:09 AM, Mahesh Jethanandani <[email-masked]> wrote:
>