Subject: [netmod] Module and Submodule Revision Dates

From: JOEY BOYD <[email-masked]>
Date: Thu, 11 Feb 2016 19:54:14 +0000

Hi all,

In RFC6087, there's a statement under Lifecycle Management regarding the revision date of a module with respect to its submodules.

"If submodules are used, then the document containing the main module MUST be updated so that the main module revision date is equal or   more recent than the revision date of any submodule that is (directly or indirectly) included by the main module."

In the Broadband Forum, we weren't aware of this statement until our models were validated using another tool besides pyang which flagged an error as our main modules' revision dates were older than some of their submodules.  We were wondering why pyang does not check for this when using the --lint option as it seems to validate RFC6087 requirements.  Is this just an oversight or are we interpreting something incorrectly?

Best Regards,
Joey

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 12 Feb 2016 10:41:31 +0100 (CET)

JOEY BOYD <[email-masked]> wrote:
> Hi all,
> 
> In RFC6087, there's a statement under Lifecycle Management regarding
> the revision date of a module with respect to its submodules.
> 
> "If submodules are used, then the document containing the main module
> MUST be updated so that the main module revision date is equal or more
> recent than the revision date of any submodule that is (directly or
> indirectly) included by the main module."
> 
> In the Broadband Forum, we weren't aware of this statement until our
> models were validated using another tool besides pyang which flagged
> an error as our main modules' revision dates were older than some of
> their submodules.  We were wondering why pyang does not check for this
> when using the --lint option as it seems to validate RFC6087
> requirements.  Is this just an oversight or are we interpreting
> something incorrectly?

An oversight in the tool.  [Please report this as a bug at
https://github.com/mbj4668/pyang]

/martin