Subject: Re: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft

From: Eric Gray <[email-masked]>
Date: Wed, 6 Apr 2016 13:57:54 +0000

Apologies for responding so late to this message.

I only recently was apprised of this draft and I wanted to know if the authors can explain what the draft offers that is not already easily supported using RFC 7223?

If it is possible to support the capabilities explicitly targeted in this draft, using the existing model, does it make sense to introduce a new set of enhancements that make it possible to represent the same concepts in two ways?

--
Eric

-----------------
Re: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft
Kent Watsen <[email-masked]> Mon, 29 February 2016 23:07 UTCShow header
The chairs were just reviewing notes and realized that this thread never closed properly. Juergen has some concerns regarding realistic milestones, that were never addressed. Robert, can you please try to address Juergen’s concerns now? Also, there were only a two responses before indicating willingness to review the draft as it progresses (thanks Dan and Martin). Can others that support this draft and willing to review this draft say so? Thanks, Netmod Chairs From: netmod <[email-masked]<mailto:[email-masked]>> on behalf of Kent Watsen <[email-masked]<mailto:[email-masked]>> Date: Tuesday, December 15, 2015 at 11:48 AM To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> Subject: [netmod] call for consensus to adopt draft-wilton-netmod-intf-ext-yang as NETMOD WG draft The minutes for IETF 94 show that there was in-room support for adopting draft-wilton-netmod-intf-ext-yang as a WG draft. The minutes also show that this decision would be confirmed on the mailing list, which I am doing now. Should we move to adopt draft-wilton-netmod-intf-ext-yang as a WG item and correspondingly add this to the WG charter as a milestone? Please comment by Tuesday, December 22, 2015 at 9AM EST at which time the WG Chairs will gauge whether or not there is consensus to move forward with the document. Thanks, Kent 
Sent from my iPad

---

From: Robert Wilton <[email-masked]>
Date: Mon, 11 Apr 2016 11:46:33 +0100

Hi Eric,

Sorry for the delay, just catching up after some PTO.

In short, this draft is defining extensions to RFC 7223 for common 
interface based features that are mostly applicable to routers/switches.

The idea is that there is a set of fairly common interface level 
features that several (perhaps most?) router vendors implement, and many 
customers make use of for configuring their networks.  Examples include 
MTU configuration, or carrier delay (also sometimes called interface 
hold time).  If you are familiar with the OpenConfig interface models 
(https://github.com/openconfig/public/tree/master/release) then you will 
see that they also define some of the same leaves that are not defined 
in RFC 7223.

Of course, as you say, each vendor could define their own proprietary 
extensions to RFC 7223 to cover the specific features that they 
implement.  Alas, this would then require the operators to use hard 
coded proprietary leaves/paths when trying to configure fairly standard 
network configurations.

As such, I believe that for all the features covered by this draft there 
is no direct equivalent in RFC 7223.

Thanks,
Rob

On 06/04/2016 14:57, Eric Gray wrote:
> I only recently was apprised of this draft and I wanted to know if the 
> authors can explain what the draft offers that is not already easily 
> supported using RFC 7223?
>
> If it is possible to support the capabilities explicitly targeted in 
> this draft, using the existing model, does it make sense to introduce 
> a new set of enhancements that make it possible to represent the same 
> concepts in two ways?
>
> --
> Eric
>
> -----------------
>
>
>   Re: [netmod] call for consensus to adopt
>   draft-wilton-netmod-intf-ext-yang as NETMOD WG draft
>
> Kent Watsen <[email-masked] <mailto:[email-masked]>> Mon, 29 
> February 2016 23:07 UTCShow header 
> <https://mailarchive.ietf.org/arch/search/?email_list=netmod&q=Wilton#>
>
> The chairs were just reviewing notes and realized that this thread 
> never closed properly. Juergen has some concerns regarding realistic 
> milestones, that were never addressed. Robert, can you please try to 
> address Juergen’s concerns now? Also, there were only a two responses 
> before indicating willingness to review the draft as it progresses 
> (thanks Dan and Martin). Can others that support this draft and 
> willing to review this draft say so? Thanks, Netmod Chairs From: 
> netmod <[email-masked] 
> <mailto:[email-masked]><mailto:[email-masked]>> on 
> behalf of Kent Watsen <[email-masked] 
> <mailto:[email-masked]><mailto:[email-masked]>> Date: 
> Tuesday, December 15, 2015 at 11:48 AM To: "[email-masked] 
> <mailto:[email-masked]><mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]><mailto:[email-masked]>> Subject: [netmod] 
> call for consensus to adopt draft-wilton-netmod-intf-ext-yang as 
> NETMOD WG draft The minutes for IETF 94 show that there was in-room 
> support for adopting draft-wilton-netmod-intf-ext-yang as a WG draft. 
> The minutes also show that this decision would be confirmed on the 
> mailing list, which I am doing now. Should we move to adopt 
> draft-wilton-netmod-intf-ext-yang as a WG item and correspondingly add 
> this to the WG charter as a milestone? Please comment by Tuesday, 
> December 22, 2015 at 9AM EST at which time the WG Chairs will gauge 
> whether or not there is consensus to move forward with the document. 
> Thanks, Kent
> Sent from my iPad
>
>
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod