Subject: Re: [netmod] list keys out of order

From: Randy Presuhn <[email-masked]>
Date: Wed, 22 Jun 2016 11:54:01 -0700 (GMT-07:00)

Hi -

> From: Andy Bierman
> Sent: Jun 22, 2016 8:47 AM
...
> Subject: Re: [netmod] list keys out of order
...
> I checked our server and it accepts any node out of order,
> including keys,so I agree out-of-order keys SHOULD be accepted.

"SHOULD" isn't helpful from an interoperability perspective,
since it effectively requires the sender to produce in-order
keys, and gives no clue as to the circumstances under which
rejecting out-of-order keys would be appropriate.  If key
order is irrelevant, and folks think it's helpful for senders
to be able to send keys in whatever order they like, then the
appropriate normative language would state that out-of-order
keys *MUST* be accepted.

Randy

---

From: "Xiang Li" <[email-masked]>
Date: Wed, 22 Jun 2016 14:01:02 -0500

> -----Original Message-----
> From: netmod [mailto:[email-masked]] On Behalf Of Randy
> Presuhn
> Sent: Wednesday, June 22, 2016 1:54 PM
> To: [email-masked]
> > I checked our server and it accepts any node out of order, including
> > keys,so I agree out-of-order keys SHOULD be accepted.
> 
> "SHOULD" isn't helpful from an interoperability perspective, since it
> effectively requires the sender to produce in-order keys, and gives no
clue as
> to the circumstances under which rejecting out-of-order keys would be
> appropriate.  

agreed.

> If key order is irrelevant, and folks think it's helpful for senders
> to be able to send keys in whatever order they like, then the appropriate
> normative language would state that out-of-order keys *MUST* be accepted.

+1

-Xiang

> 
> Randy
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 23 Jun 2016 08:40:49 +0200

> On 22 Jun 2016, at 20:54, Randy Presuhn <[email-masked]> wrote:
> 
> Hi -
> 
>> From: Andy Bierman

Then IMO the text about key order can be dumped altogether.

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C