Subject: [netmod] ACL YANG Data Model and

From: Dmytro Gassanov <[email-masked]>
Date: Fri, 24 Jun 2016 15:18:54 +0000

Hello Everybody,

I read the latest revision of "Network Access Control List (ACL) YANG Data Model" and paid attention to +--rw matches leaf.

As far as I understood, currently it does not have matches regarding:

*         Type of application

*         TOS - IP Precedence (RFC 791)

*         COS - 802.1q

*         Time (time based ACL)

What do you think, is it make sense to add these attributes to the leaf?

Thank you.

Best regards,

Dmytro Gassanov,
Netcracker Technology

+380 44 238-8727 | ext. 6825 | office
+380 67 441-5834 | mobile

We are Netcracker, and we are focused forward

________________________________
The information transmitted herein is intended only for the person or entity to which it is addressed and may contain confidential, proprietary and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

---

From: Dean Bogdanovic <[email-masked]>
Date: Fri, 24 Jun 2016 11:31:20 -0400

Dmytro,

We had those discussions and as those are not widely supported, we decided not to add it to the base model. The point is that additional match conditions are easily added via augmentation. An example is shown in module efxample-newco-acl

Dean

> On Jun 24, 2016, at 11:18 AM, Dmytro Gassanov <[email-masked]> wrote:
> 
> Hello Everybody,
>  
> I read the latest revision of “Network Access Control List (ACL) YANG Data Model” and paid attention to +--rw matches leaf.
>  
> ·         Type of application
> ·         TOS - IP Precedence (RFC 791)
> ·         COS - 802.1q 
> ·         Time (time based ACL)
>  
> _______________________________________________
> netmod mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>