Subject: [netmod] draft-ietf-netmod-yang-model-classification-02.txt posted

From: Benoit Claise <[email-masked]>
Date: Mon, 27 Jun 2016 12:39:50 +0200

Dear all,

We have posted draft-ietf-netmod-yang-model-classification version 2

https://datatracker.ietf.org/doc/draft-ietf-netmod-yang-model-classification/

We believe that we have addressed all the open issues, and that this 
draft is ready for WGLC.

Regards, Carl, Dean, and Benoit

---

From: Jonathan Hansford <[email-masked]>
Date: Mon, 27 Jun 2016 16:10:11 +0100

General
• Inconsistent capitalisation of “module”?

Abstract
• s/analysis the/analysis of the

1. Introduction
• The first paragraph is a little confusing. Should the first reference to YANG replace “and YANG standards” further on?
• s/community gain/community gains
• s/a type of module that have/a type of module that has
• But, would it be better to have “A number of module types have created substantial discussion during the development of this document including those concerned with topologies.” Instead of “An example of a type of module that have created substantial discussion during the development of this document is topologies.”?
• s/as well as in/as well as on
• Figure 1 seems to take a long time appearing

2.  First Dimension: YANG Data Model Abstraction Layers
• s/YANG modules For/YANG modules. For
• Given the third paragraph, should this be “First Dimension: YANG Data Model Abstraction Layers” or “First Dimension: YANG Module Abstraction Layers”?

2.1.  Network Service YANG Modules
• s/define services models/define service models

3.  Second Dimension: Module Types
• The first paragraph uses either/and (should be either/or) for more than two alternatives. It would be better to have a bulleted list.

3.1.  Standard YANG Modules
• If the IEEE acronym is expanded, shouldn’t MEF also be expanded?

3.2.  Vendor-specific YANG Modules and Extensions
• s/contributed back to, or adopted by an SDO/contributed back to, or adopted by, an SDO
• “lifecycles ... are” or “lifecycle ... is”. I suggest the former
• s/than what is covered/than that covered

3.3.  User-specific YANG Modules and Extensions
• “operators service providers” – should that be “operators’ service providers”?
• s/what is provided/that provided
• s/include ability/include the ability
• “lifecycles ... are” or “lifecycle ... is”. I suggest the former

4.  Adding The Classification Type to YANG Module Catalogs
• s/Such catalog/Such a catalog
• s/to YANG module/to the YANG module
• s/A extensible/An extensible
• “definite” or “definitive”?

5.  Security Considerations
• Remove the closing double quote

8.  Change log [RFC Editor: Please remove]
• s/epxlain/explain

Jonathan

From: Benoit Claise
Sent: 27 June 2016 11:40
To: NETMOD Working Group
Cc: [email-masked]; [email-masked]
Subject: [netmod] draft-ietf-netmod-yang-model-classification-02.txt posted

Dear all,

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Carl Moberg <[email-masked]>
Date: Tue, 28 Jun 2016 15:45:56 +0200

First of all, thanks a lot.

 Secondly, I’ve added a draft -03 including changes based on the below in github here:
  https://github.com/YangModels/yang/blob/master/experimental/ietf/YANG-MODEL-CLASSIFICATION/draft-ietf-netmod-yang-model-classification-03.xml

 …and since I made the changes in a renamed file, I can’t send a link to the commit in github, but made the diff available here:
  http://www.mergely.com/zFp8lfAb/

 Comments inline below:

> On Jun 27, 2016, at 5:10 PM, Jonathan Hansford <[email-masked]> wrote:
> 
> General
> ·         Inconsistent capitalisation of “module”?

 The intent was to only capitalize instances referring the terms suggested (e.g. "Network Service YANG Modules”), so I have fixed the irregularities I found in the current version.

> Abstract
> ·         s/analysis the/analysis of the

 Fixed, thanks.

> 1. Introduction
> ·         The first paragraph is a little confusing. Should the first reference to YANG replace “and YANG standards” further on?

OLD

 The Internet Engineering Steering Group (IESG) has been actively
 encouraging IETF working groups to use the YANG [RFC6020]
 [I-D.ietf-netmod-rfc6020bis] and NETCONF [RFC6241] and YANG standards
 for configuration management purposes, especially in new working
 group charters [Writable-MIB-Module-IESG-Statement].

NEW

 The Internet Engineering Steering Group (IESG) has been actively
 encouraging IETF working groups to use YANG modeling language
 [RFC6020] [I-D.ietf-netmod-rfc6020bis] and NETCONF protocol [RFC6241]
 for configuration management purposes, especially in new working
 group charters [Writable-MIB-Module-IESG-Statement].

> ·         s/community gain/community gains
> ·         s/a type of module that have/a type of module that has
> ·         But, would it be better to have “A number of module types have created substantial discussion during the development of this document including those concerned with topologies.” Instead of “An example of a type of module that have created substantial discussion during the development of this document is topologies.”?
> ·         s/as well as in/as well as on

 Fixed, thanks

> ·         Figure 1 seems to take a long time appearing

 Good catch, moved up a couple of paragraphs, thanks.

> ·         s/YANG modules For/YANG modules. For
> ·         Given the third paragraph, should this be “First Dimension: YANG Data Model Abstraction Layers” or “First Dimension: YANG Module Abstraction Layers”?

 Yes, fixed, thanks.

> ·         s/define services models/define service models

 Fixed, thanks.

> ·         The first paragraph uses either/and (should be either/or) for more than two alternatives. It would be better to have a bulleted list.

OLD

 This document suggests classifying YANG module types as either
 standard YANG modules, vendor-specific YANG modules and extensions,
 and user-specific YANG modules and extensions

NEW

 This document suggests classifying YANG module types as standard
 YANG modules, vendor-specific YANG modules and extensions, or
 user-specific YANG modules and extensions

> ·         If the IEEE acronym is expanded, shouldn’t MEF also be expanded?

 Removed expansion, it should be well knowN.

> ·         s/contributed back to, or adopted by an SDO/contributed back to, or adopted by, an SDO
> ·         “lifecycles ... are” or “lifecycle ... is”. I suggest the former
> ·         s/than what is covered/than that covered

 Fixed, thanks.

> ·         “operators service providers” – should that be “operators’ service providers”?
> ·         s/what is provided/that provided
> ·         s/include ability/include the ability

 Fixed, thanks.

> ·         “lifecycles ... are” or “lifecycle ... is”. I suggest the former

OLD

 User-specific YANG modules are developed by organizations that operate
 YANG-based infrastructure including devices and orchestrators. For example,
 network administrators in enterprises, or operators service providers. […]

NEW

 User-specific YANG modules are developed by organizations that operate
 YANG-based infrastructure including devices and orchestrators. For example,
 network administrators in enterprises or at service providers. […]

> ·         s/Such catalog/Such a catalog
> ·         s/to YANG module/to the YANG module
> ·         s/A extensible/An extensible
> ·         “definite” or “definitive”?

 Fixed, thanks.

> ·         Remove the closing double quote

 Fixed, thanks.

> ·         s/epxlain/explain

 Fixed, thanks.