Subject: [netmod] YANG 1.1 final review of the edits resulting from the IESG process

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 10 Jun 2016 13:06:42 +0200

Hi,

Martin has posted revision -13 of the YANG 1.1 specification. This
revision incorporates all comments that we have received during the
IESG process. A big thanks in particular to our gen-art and ops-dir
reviewers and to Martin for following up on the issues. Please check
the edits do make sure that nothing broke. The diff can be found
here:

https://tools.ietf.org/rfcdiff?url2=draft-ietf-netmod-rfc6020bis-13.txt

Note that this is _not_ the time to raise new issues or to suggest
alternate resolutions to issues discussed before. This is only a check
to verify that the edits were done correctly. Please check the edits
as soon as possible, any errors found must be raised by Thursday
2016-06-16.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Benoit Claise <[email-masked]>
Date: Fri, 10 Jun 2016 14:12:18 +0200

Thank you Jürgen and Martin.
The document really improved IMO.

Regards, Benoit

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 10 Jun 2016 15:00:22 +0200

Hi,

I don't want to open a new round of discussion about the leafref issue, but I think the text in sec. 9.9 isn't correct:

- The first paragraph says that "path" refers to a leaf or leaf-list schema node - OK.

- The second paragraph then says:

   If the "require-instance" property (Section 9.9.3) is "true",
   there MUST exist an node in the data tree, or a node with a
   default value in use (see Section 7.6.1 and Section 7.7.2),
   of the referred schema tree leaf or leaf-list node with the
   same value as the leafref value in a valid data tree.

IMO this means that *any* instance of the referred leaf or leaf-list schema node would do, whereas in fact the instance must belong to the node set resulting from the "path" expression (evaluated as XPath). In other words, if the "path" statement selects a specific list entry via path predicate, the required instance must be in this entry.

Lada

> On 10 Jun 2016, at 13:06, Juergen Schoenwaelder <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: Martin Bjorklund <[email-masked]>
Date: Fri, 10 Jun 2016 15:48:27 +0200 (CEST)

Ladislav Lhotka <[email-masked]> wrote:
> Hi,
> 
> I don't want to open a new round of discussion about the leafref
> issue, but I think the text in sec. 9.9 isn't correct:
> 
> - The first paragraph says that "path" refers to a leaf or leaf-list
> - schema node - OK.
> 
> IMO this means that *any* instance of the referred leaf or leaf-list
> schema node would do, whereas in fact the instance must belong to the
> node set resulting from the "path" expression (evaluated as XPath). In
> other words, if the "path" statement selects a specific list entry via
> path predicate, the required instance must be in this entry.

Note that the text for "path" provides further details:

   The "path" expression evaluates to a node set consisting of zero,
   one, or more nodes.  If the leaf with the leafref type represents
   configuration data, this node set MUST be non-empty.

However, this part is not correct in YANG 1.1 :(   It would be more
correct to say:

NEW:

   The "path" expression evaluates to a node set consisting of zero,
   one, or more nodes.  If the "require-instance" property is "true",
   this node set MUST be non-empty.

/martin

> 
> Lada
> 
>  
> > On 10 Jun 2016, at 13:06, Juergen Schoenwaelder
> > <[email-masked]> wrote:
> > 
> > Hi,
> >

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 10 Jun 2016 16:02:50 +0200

> On 10 Jun 2016, at 15:48, Martin Bjorklund <[email-masked]> wrote:
> 

Right, and then the second paragraph from the beginning of sec. 9.9 should be removed because it says something else.

Also, shouldn't the text about "path" statement in the first paragraph of 9.9 ('The "path" substatement ... is the value space of the referred node.') be moved to 9.9.2?

Lada

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 16 Jun 2016 14:04:30 +0200

> as soon as possible, any errors found must be raised by Thursday

I just finished my review of the changes. Things look pretty good to
me. I found a little nit though:

   There is no ambiguity if both modules define the type, since
   there is no ambiguity.

This sentence can likely be removed without loosing anything (but it
also does not cause any harm).

/js

---

From: Martin Bjorklund <[email-masked]>
Date: Thu, 16 Jun 2016 14:43:12 +0200 (CEST)

>    There is no ambiguity if both modules define the type, since

I'll remove the last part of this sentence.

/martin

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 16 Jun 2016 14:53:13 +0200

> > path predicate, the required instance must be in this entry.

Perhaps the text is not perfect but since section 9.9.2 clarifies how
this works we won't change the paragraph.

>    this node set MUST be non-empty.

This is indeed a bug and Martin's NEW text will be incorporated to
fix the bug.

/js