Subject: Re: [netmod] Opstate solutions discussions: update and request for WGinput

From: Susan Hares <[email-masked]>
Date: Wed, 22 Jun 2016 18:18:07 -0400

Andy and Juergen:
The I2RS data models have constraints on installing routes (I2RS rib), filters (i2rs fb-rib), and topology termination points that depend on the existence of interfaces.  It would be helpful to know that there is agreement or disagreement on Juergen's answer.
Thank you,
Sue

Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone-------- Original message --------From: Juergen Schoenwaelder <[email-masked]> Date: 6/17/2016  3:19 PM  (GMT-05:00) To: Andy Bierman <[email-masked]> Cc: [email-masked], netmod WG <[email-masked]> Subject: Re: [netmod] Opstate solutions discussions: update and request for
  WGinput 
On Fri, Jun 17, 2016 at 11:33:38AM -0700, Andy Bierman wrote:
> 
> IMO this has always been a protocol issue.
> The state of the data depends on the interaction model and that depends on
> the protocol.
> E.g., how does confirmed-commit factor into the state machine?
> The config may be applied but also temporary, pending confirmation.
> 
> What if a YANG protocol mandated that <ok> means applied, not just intended?
> That interaction model would not need separate datastores for intended vs.
> applied.
> (One solution approach is to update NETCONF to provide this interaction
> model.)
>

You can have configuration for an interface in <running> that does not
get applied because the interface is currently not present. I do not
think that this is a protocol semantics issue.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Andy Bierman <[email-masked]>
Date: Wed, 22 Jun 2016 15:29:24 -0700

On Wed, Jun 22, 2016 at 3:18 PM, Susan Hares <[email-masked]> wrote:

> Andy and Juergen:
>
> The I2RS data models have constraints on installing routes (I2RS rib),
> filters (i2rs fb-rib), and topology termination points that depend on the
> existence of interfaces.  It would be helpful to know that there is
> agreement or disagreement on Juergen's answer.
>
> Thank you,
>
>
I don't know what issues need to be resolved.
The NETCONF iietf-interfaces module allows
interfaces to be configured that are not enabled or present.

IMO this is unrelated to the content=all query parameter, which just
filters retrieval nodes
based on the config-stmt.

Sue

Andy

>
> Sent via the Samsung Galaxy Note5, an AT&T 4G LTE smartphone
> -------- Original message --------
> From: Juergen Schoenwaelder <[email-masked]>
> Date: 6/17/2016 3:19 PM (GMT-05:00)
> To: Andy Bierman <[email-masked]>
> Cc: [email-masked], netmod WG <[email-masked]>
> Subject: Re: [netmod] Opstate solutions discussions: update and request
> for WGinput
>