Subject: Re: [netmod] contact statement content

From: Kent Watsen <[email-masked]>
Date: Fri, 1 Jul 2016 14:08:48 +0000

Taking both Robert’s and Dale’s comments into account, I believe that there are two 6087bis updates:

1) Remove the text “In addition, the Area Director and other contact information MAY be present”, as there is no reason to hint that listing ADs makes sense.

2) Update the template to:

            WG Web Page:   <http://tools.ietf.org/wg/your-wg-name/>
            WG Mailing List:  <mailto:[email-masked]>
            Editor:   your-name   [Optional]
                      mailto:[email-masked]

            Author: your-name   [Optional]
                      <mailto:[email-masked]>

In the above, I also added an “Author” example and added “[Optional]” to more clearly indicate that those fields are not required.

Makes sense?

Kent  // as a contributor

From: Robert Wilton <[email-masked]>
Date: Thursday, June 30, 2016 at 5:58 AM
To: Kent Watsen <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [netmod] contact statement content

Hi Kent,

Below, you seemed to suggest also removing the WG Chair from the contact information, but it wasn't in your example update.  I would support removing it since I'm not sure that listing the WG chair(s) is that useful.  Presumably it is more desirable that any comments/questions go to the WG list or authors.

Thanks,
Rob

On 27/06/2016 23:50, Kent Watsen wrote:
Lou and I were looking a draft today and were wondering if the YANG Module Template in 6087bis makes sense.  Here’s the template:

       contact
           "WG Web:   <http://tools.ietf.org/wg/your-wg-name/><http://tools.ietf.org/wg/your-wg-name/>
            WG List:  <mailto:[email-masked]><mailto:[email-masked]>

            WG Chair: your-WG-chair
                      <mailto:[email-masked]><mailto:[email-masked]>

            Editor:   your-name
                      <mailto:[email-masked]><mailto:[email-masked]>";

6020 says:

   The "contact" statement provides contact information for the module.
   The argument is a string that is used to specify contact information
   for the person or persons to whom technical queries concerning this
   module should be sent, such as their name, postal address, telephone
   number, and electronic mail address.

6087bis says:

  The contact statement MUST be present.  If the module is contained in
   a document intended for Standards Track status, then the working
   group web and mailing information MUST be present, and the main
   document author or editor contact information SHOULD be present.  If
   additional authors or editors exist, their contact information MAY be
   present.  In addition, the Area Director and other contact
   information MAY be present.

It seems that our primary goal is to have questions directed to the working group.  Does it really make sense to have chairs or ADs listed?   That said, we understand listing authors, as they’re listed in RFCs too.

One related nit, is the “WG” acronym widely known enough to use it in the template?   How the following instead?

OLD
       contact
           "WG Web:   <http://tools.ietf.org/wg/your-wg-name/><http://tools.ietf.org/wg/your-wg-name/>
            WG List:  <mailto:[email-masked]><mailto:[email-masked]>

NEW
        contact
           "Web Page:    <http://tools.ietf.org/wg/your-wg-name/><http://tools.ietf.org/wg/your-wg-name/>
             Mailing List:  <mailto:[email-masked]><mailto:[email-masked]>

Kent (and Lou)

_______________________________________________

netmod mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/netmod

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 05 Jul 2016 21:16:13 -0400

Kent Watsen <[email-masked]> writes:
> 1) Remove the text "In addition, the Area Director and other contact
> information MAY be present", as there is no reason to hint that
> listing ADs makes sense.

If there's a role email address for the relevant Area Director, that is
likely to be more stable than the working group address, since areas are
expected to be semi-permanent, whereas WGs are assumed to have a finite
lifetime.  Of course, a personal address for an AD will likely be less
stable.

Dale

---

From: Andy Bierman <[email-masked]>
Date: Tue, 5 Jul 2016 18:26:09 -0700

> > information MAY be present", as there is no reason to hint that
My rationale for listing ADs and WG chairs is that they get no credit
whatsoever for the work they put into the RFC.  Considering Benoit
has put more review time into these drafts than anybody in the WG,
this seems appropriate.

This thread started as a 6020bis request to move the contact info and
now it is a 6087bis request to remove guideline text about the contact info.

Can you restate the OLD and NEW so we can gauge WG consensus on the change?

> lifetime.  Of course, a personal address for an AD will likely be less

Andy

> [email-masked]

---

From: Benoit Claise <[email-masked]>
Date: Wed, 6 Jul 2016 11:24:15 +0200

On 7/6/2016 3:26 AM, Andy Bierman wrote:
>
>
> On Tue, Jul 5, 2016 at 6:16 PM, Dale R. Worley <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Kent Watsen <[email-masked] <mailto:[email-masked]>> writes:
Thanks Andy. The draft acknowledgment section seems appropriate in such 
a case.
However, ADs come and go, as WG chairs btw. And their affiliations can 
change too.
So I'm not convinced of the value of listing the AD and WG chairs in the 
YANG module itself.
The more stable point of contact is always the WG list. A role email 
address for the relevant Area Director, that is likely to be more stable 
than the working group address, would anyway be constructed out of the 
WG list.

Regards, Benoit (as a contributor)
>     [email-masked] <mailto:[email-masked]>

---

From: Kent Watsen <[email-masked]>
Date: Thu, 7 Jul 2016 13:43:05 +0000

> Can you restate the OLD and NEW so we can gauge WG consensus on the change?

This email still captures the current 6087bis change request:

                https://www.ietf.org/mail-archive/web/netmod/current/msg16292.html

But for completeness:

            WG Web Page:   <http://tools.ietf.org/wg/your-wg-name/>
            WG Mailing List:  <mailto:your-wg-name at ietf.org>

            Editor:   your-name   [Optional]
                      <mailto:your-email at example.com>

            Author: your-name   [Optional]
                      <mailto:your-email at example.com>

Kent  // as a contributor

From: netmod <[email-masked]> on behalf of Benoit Claise <[email-masked]>
Date: Wednesday, July 6, 2016 at 5:24 AM
To: Andy Bierman <[email-masked]>, "Dale R. Worley" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [netmod] contact statement content

On Tue, Jul 5, 2016 at 6:16 PM, Dale R. Worley <[email-masked]<mailto:[email-masked]>> wrote:

My rationale for listing ADs and WG chairs is that they get no credit
whatsoever for the work they put into the RFC.  Considering Benoit
has put more review time into these drafts than anybody in the WG,
this seems appropriate.
Thanks Andy. The draft acknowledgment section seems appropriate in such a case.
However, ADs come and go, as WG chairs btw. And their affiliations can change too.
So I'm not convinced of the value of listing the AD and WG chairs in the YANG module itself.
The more stable point of contact is always the WG list. A role email address for the relevant Area Director, that is likely to be more stable than the working group address, would anyway be constructed out of the WG list.

Dale

Andy

netmod mailing list