Subject: Re: [netmod] grouping if-feature

From: Martin Bjorklund <[email-masked]>
Date: Fri, 01 Jul 2016 14:28:39 +0200 (CEST)

Hi,

Michal Vaško <[email-masked]> wrote:
> Hi,
> in NETCONF server draft [1] there is ietf-ssh-server model. It defines
> feature "ssh-x509-certs" and then uses it twice in a
> grouping. Referring to RFC 6020 [2] (I haven't noticed any difference
> in the YANG 1.1 draft), in a grouping prefixes, type names, grouping
> names, and extensions should be resolved in the context of the uses
> that referenced this grouping. What about if-feature, where should
> that be resolved?

It is resolved locally (lexically).

> Either way, to my understanding, there is one
> "ssh-x509-certs" feature definition redundant, either in
> ietf-netconf-server or in ietf-ssh-server. Thanks for clarification.

Hmm, I think the one in ietf-netconf-server should be removed.  But
this should really go to the netconf list.

/martin

> 
> Regards,
> Michal Vasko
> 
> [1] https://tools.ietf.org/html/draft-ietf-netconf-server-model-09
> [2] https://tools.ietf.org/html/rfc6020#section-7.11
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Kent Watsen <[email-masked]>
Date: Fri, 1 Jul 2016 13:15:39 +0000

> this should really go to the netconf list.

Yes, that was a cut-n-paste error.  

I just removed the “ssh-x509-certs” feature definition from my local copy of the ietf-netconf-server module.  

Thanks!   
Kent

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 05 Jul 2016 21:53:25 -0400

Martin Bjorklund <[email-masked]> writes:
> Michal Vasko <[email-masked]> wrote:

The feature name is resolved in the context where a data node is
created.  Feature names are local to the module:

6.2.1

   o  All feature names defined in a module and its submodules share the
      same feature identifier namespace.

So the uses of the feature "ssh-x509-certs" in ietf-netconf-server and
ietf-ssh-server are different features.  It seems to me that the feature
must be declared in both modules, which it is, by separate declarations
in each module.  In principle you could put the feature statement in the
grouping statement, but the syntax doesn't allow that; a feature
statement has to be the child of a module or submodule statement.

Dale