Subject: [netmod] [Technical Errata Reported] RFC6991 (5105)

From: RFC Errata System <[email-masked]>
Date: Fri, 1 Sep 2017 07:40:56 -0700 (PDT)

The following errata report has been submitted for RFC6991,
"Common YANG Data Types".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5105

--------------------------------------
Type: Technical
Reported by: Ladislav Lhotka <[email-masked]>

Section: 3

Original Text
-------------
A schema node of this type will be set to zero (0) on creation
and will thereafter increase monotonically until it reaches
a maximum value of 2^32-1 (4294967295 decimal), when it
wraps around and starts increasing again from zero.

Corrected Text
--------------
A leaf instance of this type will be set to zero (0) on creation
and will thereafter increase monotonically until it reaches
a maximum value of 2^32-1 (4294967295 decimal), when it
wraps around and starts increasing again from zero.

Notes
-----
In a number of descriptions in both ietf-yang-types and ietf-inet-types, the term "schema node" is used incorrectly in places where "leaf instance" or "instance of a leaf" should be used instead. However, not all occurences of "schema node" are wrong: schema nodes just have to be distinguished from nodes in an instance data tree.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6991 (draft-ietf-netmod-rfc6021-bis-03)
--------------------------------------
Title               : Common YANG Data Types
Publication Date    : July 2013
Author(s)           : J. Schoenwaelder, Ed.
Category            : PROPOSED STANDARD
Source              : NETCONF Data Modeling Language
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 1 Sep 2017 18:48:41 +0200

> "Common YANG Data Types".

Yes. I would probably prefer 'a data node instance of this type'
instead of 'a leaf instance' - I am not sure I would to exclude a
leaf-list and who knows whether we have any other data nodes in the
future. And yes, all occurances of 'schema node' need careful
inspection. I am not sure whether you want to identify all occurances
now or whether you wanted to have a generic errata just so that we do
not forget to fix this when this document is revised.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Ladislav Lhotka <[email-masked]>
Date: Mon, 04 Sep 2017 10:12:52 +0200

> future. And yes, all occurances of 'schema node' need careful

OK.

> not forget to fix this when this document is revised.

I think it should suffice to keep this general erratum and fixed it in the next
revision.

Thanks, Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Benoit Claise <[email-masked]>
Date: Tue, 5 Sep 2017 09:19:13 +0200

> I think it should suffice to keep this general erratum and fixed it in the next
Just flagged as such in the system.

Regards, Benoit