Subject: [netmod] draft-ietf-netmod-rfc6087bis as a BCP?

From: Benoit Claise <[email-masked]>
Date: Mon, 11 Sep 2017 16:16:41 +0200

Dear all,

I'm wondering if it's not time to classify draft-ietf-netmod-rfc6087bis 
as a BCP, as opposed to informational

This text would need to change:

        This document is similar to the Structure of Management
        Information
        version 2 (SMIv2) usage guidelines specification [RFC4181] in intent
        and structure.  However, since that document was written a decade
        after SMIv2 modules had been in use, it was published as a 'Best
        Current Practice' (BCP).  This document is not a BCP, but rather an
        informational reference, intended to promote consistency in documents
        containing YANG modules.

Indeed, it seems to me that the consistency in YANG modules is a pretty 
important topic.

Feedback?

Regards, Benoit

---

From: Kent Watsen <[email-masked]>
Date: Tue, 12 Sep 2017 18:29:57 +0000

Hi Benoit,

BCP seems right, but I wonder if there is some sort of stability metric that applies to BCPs.
YANG still seems to be evolving, so I can only imagine yet another update to this document
in the not too distant future.  Does that disqualify it in any way?

Kent

On 9/11/17, 10:16 AM, "netmod on behalf of Benoit Claise" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Dear all,

I'm wondering if it's not time to classify draft-ietf-netmod-rfc6087bis as a BCP, as opposed to informational

   Information

   containing YANG modules.

Indeed, it seems to me that the consistency in YANG modules is a pretty important topic.

Feedback?

Regards, Benoit