Subject: [netmod] Broadband Forum NMDA Questions

From: David Sinicrope <[email-masked]>
Date: Thu, 21 Sep 2017 17:29:30 +0000

https://datatracker.ietf.org/liaison/1544/

Hi All,
The datatracker entry for the subject liaison requests a response by Nov 27 which is the week before the 4Q2017 BBF meeting.

However, the BBF group requesting the response has a conference call Nov 21 (Monday after Singapore).
If there is any way to get a response for that call, I’m sure they would greatly appreciate it.

Dave Sinicrope
BBF/IETF Liaison Manager

---

From: "t.petch" <[email-masked]>
Date: Fri, 22 Sep 2017 17:27:56 +0100

For those who wonder, the text of the liaison  (slightly mangled by code
page issues) is as follows (I know what advice I would give but am
probably in a minority there on this list:-))

Broadband Forum NMDA Questions

Body

Dear all,

The Broadband Forum has been considering the impact of NMDA (Network
Management Datastore Architecture) on its YANG work.

Many of our standard and draft YANG modules are dependent on the
ietf-interfaces (RFC 7223) and ietf-hardware (draft-ietf-netmod-entity)
YANG
modules, both of which will be impacted by NMDA. Therefore we need to
decide
whether (and, if so, how) we should update our published and draft YANG
modules. We see three possible approaches:
- Ignore NMDA, relying on the fact that updated IETF YANG modules will
retain backwards compatibility.
- Embrace NMDA, updating all our YANG modules to use single trees (no
separate state trees).
- Support NMDA, while retaining backwards compatibility in the same way
as IETF YANG modules will do so.

Our decision will be affected by:
- Our level of confidence that NMDA will be the "last big change" to the
way in
which IETF YANG modules are written.
- The timescales on which NMDA-compliant versions of the ietf-interfaces
and ietfhardware YANG modules will be published as RFCs (we note that
NMDA-compliant versions of these modules are now available).

We would much appreciate your feedback on our analysis of the possible
approaches and on our concerns as expressed above.

Sincerely
Michael Fargano
Broadband Forum Technical Committee Chair

CC:
David Sinicrope, BBF / IETF Liaison Officer/Manager,
<[email-masked]> Sven Ooghe, BBF Common YANG Project
Stream
Leader, <[email-masked]> William Lupton, BBF Common YANG Project
Stream
Leader, <wlupton@broadbandforum. org> Robin Mersh, Broadband Forum CEO
<[email-masked]> Gabrielle Bond, Broadband Forum Secretariat
<[email-masked]> Statements at IETF <[email-masked]>
Liaisons at BBF <[email-masked]>

  StatementHistoryStatePosted
      Posted Date2017-09-20
      From GroupBROADBAND-FORUM
      From ContactMichael Fargano
      To Groupsnetmod, OPS
      To ContactsWarren Kumari
      Benoit Claise
      JÃ¼rgen SchÃ¶nwÃ¤lder
      Tom Nadeau
      CcDavid Sinicrope
      Kent Watsen
      Warren Kumari
      The IETF Chair
      Lou Berger
      Benoit Claise
      Network Modeling Discussion List
      Response [email-masked]
      [email-masked]
      PurposeFor comment
      Deadline2017-11-27 Action Needed
      Attachments41;.final