Subject: [netmod] FW: WGLC for draft-ietf-tictoc-1588v2-yang

From: Jiangyuanlong <[email-masked]>
Date: Fri, 15 Sep 2017 01:42:16 +0000

Hi netmoders,

This draft does not tackle the general YANG problem, but provide a generic time synchronization module of 1588.
Some of you may have interests in time synchronization, some definitely not. But as experts in YANG, could you please have a review of this YANG module and give an expert opinion?

Thanks,
Yuanlong

-----Original Message-----
From: TICTOC [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Thursday, September 14, 2017 3:16 AM
To: [email-masked]
Cc: [email-masked]
Subject: [TICTOC] WGLC for draft-ietf-tictoc-1588v2-yang

Folks,

This message begins a 2 week working group last call (WGLC) for the following document: 

YANG Data Model for IEEE 1588v2
https://datatracker.ietf.org/doc/draft-ietf-tictoc-1588v2-yang/

Please review the referenced document and send any comments to the mailing list including your assessment of whether this document is mature enough to proceed to the IESG. Please note that these messages of support for progression to the mailing list are important and will be used to determine WG consensus to proceed. 

Please send all comments in by Thursday 28 September 2017.  

Thank you!
Karen
_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: Alex Campbell <[email-masked]>
Date: Fri, 15 Sep 2017 05:27:23 +0000

Hi,
I've reviewed the draft and found the following issues.

* YANG enumeration values are conventionally lowercase, but the delay-mechanism-enumeration and port-state-enumeration types in the draft have uppercase values.
* Similarly, hyphens should be used rather than underscores (pre-master instead of PRE_MASTER)
* number-ports doesn't read naturally in English; I suggest renaming it to number-of-ports.
* The description of port-ds-list contains a typo - "memer" instead of "member".
* There's no need to have groupings that are only used once (such as parent-ds-entry, current-ds-entry, default-ds-entry, transparent-clock-default-ds-entry, port-ds-entry, transparent-clock-default-ds-entry, and so on) unless this is for futureproofing or some other reason I'm not aware of.
* Is it necessary to include -ds in the name of every leaf, container and grouping?

Note I'm not familiar with IEEE 1588, apart from a brief look through it just now.

Alex

________________________________________
From: netmod <[email-masked]> on behalf of Jiangyuanlong <[email-masked]>
Sent: Friday, 15 September 2017 1:42 p.m.
To: [email-masked]
Cc: [email-masked]
Subject: [netmod] FW: WGLC for draft-ietf-tictoc-1588v2-yang

Hi netmoders,

Thanks,
Yuanlong

-----Original Message-----
From: TICTOC [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Thursday, September 14, 2017 3:16 AM
To: [email-masked]
Cc: [email-masked]
Subject: [TICTOC] WGLC for draft-ietf-tictoc-1588v2-yang

Folks,

Thank you!
Karen

_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod

---

From: Benoit Claise <[email-masked]>
Date: Fri, 15 Sep 2017 14:48:26 +0200

Hi Yuanong,

There is pyang error.
http://www.claise.be/IETFYANGPageCompilation.html

    [email-masked]:294: error: the value "0xFFFF" does
    not match its base type - not an integer

However, this is a pyang problem. See 
https://github.com/mbj4668/pyang/issues/329

Mehmet, can you please a YANG doctor. The YANG doctor review is normally 
done during IETF LC, but nothing prevents an early review.

Regards, Benoit
> .

---

From: Rodney Cummings <[email-masked]>
Date: Fri, 15 Sep 2017 20:31:13 +0000

Thanks Alex,

Good feedback.

As an overall point, most of these names have a 1-1 association to a name from the IEEE Std 1588-2008 standard. The 1588 document uses "DS" as an abbreviation for its "data set", which is essentially an information model for a collection of nodes. Beyond that, 1588 uses camel-case for its names, such as:
	DefaultDS.numberPorts
The co-authors of this I-D used the following approach:
	Change names to the typical YANG convention (lowercase dashed), but otherwise strive to keep the 1-1 relationship with the 1588 name.
We were trying to avoid someone getting confused, and thinking that the YANG name is something new, not specified in 1588.
This means that you will see names like:
	default-ds.number-ports
I'd prefer to avoid changing to "number-of-ports", because for whatever reason, 1588 uses numberPorts, and it'd be best to keep the 1-1 relationship.

Other than that, all of your comments seem fine with me.

Rodney

> From: TICTOC [mailto:[email-masked]] On Behalf Of Alex Campbell
> Sent: Friday, September 15, 2017 12:27 AM
> To: Jiangyuanlong <[email-masked]>; [email-masked]
> Cc: [email-masked]
> Subject: Re: [TICTOC] WGLC for draft-ietf-tictoc-1588v2-yang
> 
> Hi,
> * YANG enumeration values are conventionally lowercase, but the delay-
> mechanism-enumeration and port-state-enumeration types in the draft have
> uppercase values.
> * There's no need to have groupings that are only used once (such as
> parent-ds-entry, current-ds-entry, default-ds-entry, transparent-clock-
> default-ds-entry, port-ds-entry, transparent-clock-default-ds-entry, and
> so on) unless this is for futureproofing or some other reason I'm not
> aware of.
> Some of you may have interests in time synchronization, some definitely
> not. But as experts in YANG, could you please have a review of this YANG
> module and give an expert opinion?
> 
> Thanks,
> Yuanlong
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dtictoc-2D1588v2-
> 2Dyang_&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCiE2uzI1jjZZuIPelcSjixA&r=WA71sf2o7
> Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=KYy1NqCkT9fELXGg7ARrUez4toujzAfPIBGxu
> 4O-IwA&s=JeFM02MFCMdOI1qLRL6vF-Db7NDdjIn4sLd9_HuDPio&e=
> 
> Please review the referenced document and send any comments to the mailing
> list including your assessment of whether this document is mature enough
> to proceed to the IESG. Please note that these messages of support for
> progression to the mailing list are important and will be used to
> determine WG consensus to proceed.
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_tictoc&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCi
> E2uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=KYy1
> NqCkT9fELXGg7ARrUez4toujzAfPIBGxu4O-
> IwA&s=zEhnTQKhHxNWCB1MNgv1Oulcl78Y4yP3S5Zfb7m9dPY&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_netmod&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCi
> E2uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=KYy1
> NqCkT9fELXGg7ARrUez4toujzAfPIBGxu4O-IwA&s=cEawQxd1IoW8ewaY4Q822u-
> yKPhzvQSiK12nIyg39cA&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_tictoc&d=DwICAg&c=I_0YwoKy7z5LMTVdyO6YCi
> E2uzI1jjZZuIPelcSjixA&r=WA71sf2o7Dw7CbYhFt24DPjt3lJuupswWYdnboKbZ8k&m=KYy1
> NqCkT9fELXGg7ARrUez4toujzAfPIBGxu4O-
> IwA&s=zEhnTQKhHxNWCB1MNgv1Oulcl78Y4yP3S5Zfb7m9dPY&e=

---

From: Jiangyuanlong <[email-masked]>
Date: Mon, 18 Sep 2017 02:58:40 +0000

Dear Alex,

Thanks a lot for your prompt review, most of your suggestions will be reflected in the next revision. Please see my further comments inline (prefixed with JY).

Cheers,
Yuanlong

-----Original Message-----
From: Alex Campbell [mailto:[email-masked]] 
Sent: Friday, September 15, 2017 1:27 PM
To: Jiangyuanlong; [email-masked]
Cc: [email-masked]
Subject: Re: WGLC for draft-ietf-tictoc-1588v2-yang

Hi,

JY: All suggestions above are accepted.

* There's no need to have groupings that are only used once (such as parent-ds-entry, current-ds-entry, default-ds-entry, transparent-clock-default-ds-entry, port-ds-entry, transparent-clock-default-ds-entry, and so on) unless this is for futureproofing or some other reason I'm not aware of.
JY: This grouping structure was used for readability of the main module, otherwise, a single parent container will include tens of pages of YANG codes. 
Turning some sub-containers into groupings will not change the codes in compiling for computers, but may reduce the complexity in reading as a layman;)
I know this is a very subjective judgment for myself, so I would like to see more opinions in the WG before restructuring the module.

* Is it necessary to include -ds in the name of every leaf, container and grouping?
JY: As explained in Rodney's previous email.

Alex

Hi netmoders,

Thanks,
Yuanlong

-----Original Message-----
From: TICTOC [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Thursday, September 14, 2017 3:16 AM
To: [email-masked]
Cc: [email-masked]
Subject: [TICTOC] WGLC for draft-ietf-tictoc-1588v2-yang

Folks,

Thank you!
Karen

---

From: Jiangyuanlong <[email-masked]>
Date: Mon, 18 Sep 2017 03:16:41 +0000

Dear Benoit,

Thank you much for the instruction and the explanation.
There are errors shown in https://datatracker.ietf.org/doc/draft-ietf-tictoc-1588v2-yang/?include_text=1, but it passes validation by http://www.yangvalidator.com/draft-validator. It seems different versions of pyang were used and the results provided by our official site are inconsistent now.

Best regards,
Yuanlong

From: Benoit Claise [mailto:[email-masked]]
Sent: Friday, September 15, 2017 8:48 PM
To: Jiangyuanlong; [email-masked]; Mehmet
Cc: [email-masked]
Subject: Re: [netmod] FW: WGLC for draft-ietf-tictoc-1588v2-yang

Hi Yuanong,

There is pyang error.
http://www.claise.be/IETFYANGPageCompilation.html
[email-masked]:294<mailto:[email-masked]:294>: error: the value "0xFFFF" does not match its base type - not an integer

However, this is a pyang problem. See https://github.com/mbj4668/pyang/issues/329

Mehmet, can you please a YANG doctor. The YANG doctor review is normally done during IETF LC, but nothing prevents an early review.

Regards, Benoit

Hi netmoders,

Thanks,

Yuanlong

-----Original Message-----

To: [email-masked]<mailto:[email-masked]>

Cc: [email-masked]<mailto:[email-masked]>

Folks,

Thank you!

Karen

TICTOC mailing list

[email-masked]<mailto:[email-masked]>

netmod mailing list

[email-masked]<mailto:[email-masked]>

.

---

From: Benoit Claise <[email-masked]>
Date: Wed, 20 Sep 2017 16:54:25 -0700

Dear Yuanlong,

The pyang bug has been fixed (thanks Martin).
I updated my toolchain with the latest pyang version (and the latest 
yanglint 0.13.49, btw).
So no more errors at http://www.claise.be/IETFYANGPageCompilation.html 
for your draft.

For the IETF tracker, I guess we have to wait until the next pyang 
version (1.7.4) for Henrik to update pyang.

yangcatalog.org still needs to be updated with the latest validators.

Regards, Benoit
> There are errors shown in 
> https://datatracker.ietf.org/doc/draft-ietf-tictoc-1588v2-yang/?include_text=1, 
> but it passes validation by 
> http://www.yangvalidator.com/draft-validator. It seems different 
> versions of pyang were used and the results provided by our official 
> site are inconsistent now.
>
> Best regards,
>
> Yuanlong
>
> *From:*Benoit Claise [mailto:[email-masked]]
> *Sent:* Friday, September 15, 2017 8:48 PM
> *To:* Jiangyuanlong; [email-masked]; Mehmet
> *Cc:* [email-masked]
> *Subject:* Re: [netmod] FW: WGLC for draft-ietf-tictoc-1588v2-yang
>
> Hi Yuanong,
>
> There is pyang error.
> [email-masked]:294 
> <mailto:[email-masked]:294>: error: the value 
> "0xFFFF" does not match its base type - not an integer
>
> <https://github.com/mbj4668/pyang/issues/329>
>
> Mehmet, can you please a YANG doctor. The YANG doctor review is 
> normally done during IETF LC, but nothing prevents an early review.
>
> Regards, Benoit
>
>     Hi netmoders,
>
>     This draft does not tackle the general YANG problem, but provide a
>     generic time synchronization module of 1588.
>
>     Some of you may have interests in time synchronization, some
>     definitely not. But as experts in YANG, could you please have a
>     review of this YANG module and give an expert opinion?
>
>     Thanks,
>
>     Yuanlong
>
>     To: [email-masked] <mailto:[email-masked]>
>
>     Cc: [email-masked] <mailto:[email-masked]>
>
>     Please review the referenced document and send any comments to the
>     mailing list including your assessment of whether this document is
>     mature enough to proceed to the IESG. Please note that these
>     messages of support for progression to the mailing list are
>     important and will be used to determine WG consensus to proceed.
>
>     [email-masked] <mailto:[email-masked]>
>
>     [email-masked] <mailto:[email-masked]>
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 21 Sep 2017 13:50:09 +0200

Hi Benoit,

The version of pyang used by the datatracker will be updated when the next
release installation is done, which I expect to be later today (6.62.1).

Best regards,

	Henrik