Subject: [netmod] I-D Action: draft-ietf-netmod-schema-mount-07.txt

From: [email-masked]
Date: Wed, 27 Sep 2017 03:52:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Network Modeling WG of the IETF.

        Title           : YANG Schema Mount
        Authors         : Martin Bjorklund
                          Ladislav Lhotka
	Filename        : draft-ietf-netmod-schema-mount-07.txt
	Pages           : 27
	Date            : 2017-09-27

Abstract:
   This document defines a mechanism to combine YANG modules into the
   schema defined in other YANG modules.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-netmod-schema-mount/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-netmod-schema-mount-07
https://datatracker.ietf.org/doc/html/draft-ietf-netmod-schema-mount-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-netmod-schema-mount-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 27 Sep 2017 12:55:58 +0200 (CEST)

Hi,

This version fixes the XPath context for parent-reference.

However, there is one more thing to discuss, which is the term "mount
point".  

The current text says:

   - mount point: container or list node whose definition contains
     the "mount-point" extension statement. The argument of the
     "mount-point" statement defines the name of the mount point.

So if we have:
    
  container top {
    container root {
      yangmnt:mount-point ni;
    }
  }
    
There is one mount point, the node /top/root, with the name "ni".

Pretty confusing...   Does anyone have any comments around this?

/martin

[email-masked] wrote:
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: "Xufeng Liu" <[email-masked]>
Date: Wed, 27 Sep 2017 09:43:40 -0400

Alternatively we can use "/top/root" as the name of the mount-point, then
there won't be case for 
  'A module MAY contain multiple "mount-point" statements having the same
argument.'
The "mount-point" extension statement won't take an argument, which will be
cleaner, and make the extension statement look more like a property
specifier than a node declaration.

Thanks,
- Xufeng

> -----Original Message-----
> From: netmod [mailto:[email-masked]] On Behalf Of Martin
> Bjorklund
> Sent: Wednesday, September 27, 2017 6:56 AM
> To: [email-masked]
> Subject: Re: [netmod] I-D Action: draft-ietf-netmod-schema-mount-07.txt
> 
> Hi,
> 
point".
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at
tools.ietf.org.

---

From: Lou Berger <[email-masked]>
Date: Wed, 27 Sep 2017 14:24:34 -0400

Hi Martin,

See below

> There is one mount point, the node /top/root, with the name "ni".
in the NI draft [1] we solve this by keeping the names the same:

        container vrf-root {
          description
            "Container for mount point.";
          yangmnt:mount-point "vrf-root" {
            description
              "Root for L3VPN type models. This will typically
               not be an inline type mount point.";
          }
        }

[1] https://tools.ietf.org/html/draft-ietf-rtgwg-ni-model-04
> Pretty confusing...   Does anyone have any comments around this?
When the NE authors discussed this, we (a) discussed it's not a
significant impediment or issue worth discussing, and (b) one author
noted that the flexibility may even be useful down the road.

Thanks,
Lou
(As contributor)

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 27 Sep 2017 21:59:24 +0200 (CEST)

> noted that the flexibility may even be useful down the road.

Yes, I don't want to change any functionality, but perhaps change the
terminology to make it less confusion.

Maybe change the extension to:

  extension mount-point {
    argument id; // instead of 'name'
    ...
  }

So the container "vrf-root" would be a mount point, with id "ni".

/martin