Subject: Re: [netmod] schema mount open issue #1

From: Lou Berger <[email-masked]>
Date: Tue, 12 Sep 2017 12:37:22 -0400

Hi,

The LNI/NI authors/RTG Area DT met yesterday and discussed the proposed
change as well as the other topics that came up in the subsequent
discussion.  The high order bit is that the proposed and current
definitions are adequate for our needs.  Read further if you care about
details, including confirming our understanding:

1) WRT xpath context change proposed by martin

Our understanding is that absolute paths continue to be allowed, for
example the following remains valid:

           "use-schema": [
             {
               "name": "ni-schema",
               "parent-reference": [
                 "/*[namespace-uri() = 'urn:ietf:...:ietf-interfaces']"
               ]
             }
           ]

Assuming yes, then we have no objection to the change (as it allows the
server implementor to choose how/if they support vrf name filtering.
Obviously, using the new syntax exposes the restriction to the client
which is probably desirable.)

2. parent-reference location is adequate for our needs. 
This said, we think parent-references are more appropriately contained
within the schema list and having them there will yield less complex
operational data. 

3. current mount point extension usage definition (must be in a list or
container).
Our use case is covered by always having a single mount point contained
in a container.  We don't see the need for mount point extensions within
lists or for there to ever be siblings of mount point extensions.

We don't see a need to discuss items 2 and 3 further at this time. 
Assuming  our understanding is correct, we will update the NI and LNE
draft as soon as schema mount is updated as proposed.

Lou
(as contributor and NI/LNE draft co-author)

On 8/30/2017 5:29 AM, Lou Berger wrote:
> FYI I've asked folks in the routing area, i.e., the ietf users of schema 
> mount, if they have an opinion on the node discussion. I will also do so on 
> the point I raised on parent reference location. (Which is independent from 
> your format change.) Clearly, if I'm the only one to be raising objections, 
> I'll be the one in the rough on these points.
>
> Thanks,
>
> Lou
> - as contributor
>
>
> On August 30, 2017 3:42:26 AM Martin Bjorklund <[email-masked]> wrote:
>
>> Ladislav Lhotka <[email-masked]> wrote:
>>> Lou Berger <[email-masked]> writes:
>>>
>>>> Lada,
>>>>
>>>>
>>>> On 8/28/2017 10:16 AM, Ladislav Lhotka wrote:
>>>>> Lou Berger píše v Po 28. 08. 2017 v 09:40 -0400:
>> [...]
>>
>>>>>> PS is your view aligned with martin or our example?
>>>>> If you mean shifting the XPath context node to the mount point instance, 
>>> then
>>>>> yes.
>> So, going back to the original issue; does anyone have any objection
>> to changing the XPath context for parent-reference as describied in my
>> original post?
>>
>>
>> /martin
>>

---

From: Martin Bjorklund <[email-masked]>
Date: Wed, 13 Sep 2017 13:20:31 +0200 (CEST)

Hi,

Lou Berger <[email-masked]> wrote:
> Our understanding is that absolute paths continue to be allowed

Yes, this is correct.

> , for

Ok, since we haven't seen any objections to the proposal, I will
update the schema mount draft accordingly.

/martin

---

From: "t.petch" <[email-masked]>
Date: Wed, 20 Sep 2017 12:27:21 +0100

Martin

Since you are doing an update, you might consider updating the
definitions to point to the  NMDA I-D
rather than RFC6241 although configuration data is not defined in
RFC7950 or NMDA.

Tom Petch

----- Original Message -----
From: "Martin Bjorklund" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 13, 2017 12:20 PM
Subject: Re: [netmod] schema mount open issue #1

Hi,

Yes, this is correct.

/martin

> >> to changing the XPath context for parent-reference as describied in
my
_______________________________________________
netmod mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/netmod