Subject: Re: PGP/MIME interop testing: Very first steps towards a test suite.

From: Thomas Roessler <[email-masked]>
Date: Sat, 1 Apr 2000 11:14:54 +0200

On 2000-03-31 15:47:56 -0800, Jon Callas wrote:

> So, popping back to your questions, no, we have to have
> binary mode signatures, or else PGP/MIME can't sign a
> binary file cross-platform.

Beg your pardon?  What PGP/MIME does is converting binary
data to a canonical text representation which matches
MIME's and OpenPGP's idea of canonical text.  That is,
with PGP/MIME (or any other signature standard based on
RFC 1847), all you have to look at are signatures of
textual data.  MIME does the conversion for you.

> If all parties are using the same rules of what text
> is, then it doesn't matter what mode you use, as long
> as you use the same mode. If you want to cross a
> text-rule boundary, you have to use the right mode.

Right.

-- 
http://www.guug.de/~roessler/

---

From: Ian Bell <[email-masked]>
Date: Mon, 3 Apr 2000 11:02:53 +0100

>textual data.  MIME does the conversion for you.

Yes, and unless there are absolutely no inter-operability problems 
arising from the different modes of signing MIME messages, the 
openPGP/MIME draft should say "MUST use text-mode signatures", not 
"SHOULD NOT use binary-mode signatures" as I previously suggested.

-- 
Ian Bell                                           T U R N P I K E  Ltd