Subject: 3.6.1.3 Clarification

From: Erron Criddle <[email-masked]>
Date: Tue, 06 Jun 2000 15:52:16 +0800

To all,

Just to make sure I understand before we code, two options are available 
per instance (I am also not taking into consideration multiple instances 
when the hash bit count is smaller than the required key length). Consider 
the two options:

1) A simple salt + iteration:

count=20 bytes
salt=12 bytes
pass phrase=12 bytes

from this, we simply do:

hash (salt + pass phrase)

where:

salt=12 bytes
pass phrase=12 bytes

2) A concatenated salt + iteration:

count=40 bytes
salt=12 bytes
pass phrase=12 bytes

from this, we simply do:

hash(salt(0) + pp(0) + salt(1) + pp(1))

where:

salt(0)=12 bytes
pass phrase (0)=12 bytes
salt (1)=12 bytes
pass phrase(1)=left 4 bytes of the 12 byte pass phrase

Is this correct, or have I got it wrong?

TIA.

Regards

Erron Criddle
Comasp Ltd.
ACN: 089 468 682
Level 2, 45 Stirling Hwy
NEDLANDS  WA  6009
Australia

Fax: +61 8 9386 9473
Tel: +61 8 9386 9534
Mob: +414/0414 800 888

[email-masked]
http://www.comasp.com

---

From: [email-masked]
Date: Tue, 06 Jun 2000 18:42:11 +0900

From: Erron Criddle <[email-masked]>
Subject: 3.6.1.3 Clarification
Date: Tue, 06 Jun 2000 15:52:16 +0800
Message-ID: <[email-masked]>

> hash (salt + pass phrase)

this looks correct to me.  it fulfills the "has at least one complete salt +
passphrase" requirement.

> pass phrase(1)=left 4 bytes of the 12 byte pass phrase

this looks correct to me as well.  it fulfills the "assuming at least one
complete salt + passphrase will be hashed, hash exactly count bytes"
requirement.

for reference, there was discussion of this area of the rfc recently,
and i submitted candidate alternate phrasing for this section.  you
can find that at:

  http://www.imc.org/ietf-openpgp/mail-archive/msg03156.html