Subject: Re: final q re sigs.

From: [email-masked]
Date: Sun, 23 Jul 2000 22:50:44 -0700

> My question is, for a version 4 sig using DSA and SHA1, do we:
>
> 2) H(a + b + c) = 160 bit value to be fed into the sig. alg.

It is this one, where the "+" means concatenation.  Most implementations
of hash functions do not require you to literally concatenate the data,
but rather you can pass the data in pieces, so you first pass in a, then
b, then c.  In the spec we write this as "first hash a, then hash b, then
hash c," and so on.

Hal

---

From: Erron Criddle <[email-masked]>
Date: Mon, 24 Jul 2000 13:48:57 +0800

Hal,

>b, then c.  In the spec we write this as "first hash a, then hash b, then

Aahhh...this is where I was getting confused (re the *then* words)

Thanks :)

Regards

Erron Criddle
Comasp Ltd.
Level 2, 45 Stirling Hwy
NEDLANDS  WA  6009
Australia

Fax: 08 9386 9473
Tel: 08 9386 9534

http://www.comasp.com
[email-masked]