Subject: Correction reqd. in 5.2

From: Erron Criddle <[email-masked]>
Date: Fri, 21 Jul 2000 12:02:10 +0800

To all,

Another one (trivial but may confuse newcomers):

section 5.2 starts off with:

"A signature packet describes a binding between some public key and some data."

should read:

"A signature packet describes a binding between a private key and some data."

Regards

Erron Criddle
Comasp Ltd.
Level 2, 45 Stirling Hwy
NEDLANDS  WA  6009
Australia

Fax: 08 9386 9473
Tel: 08 9386 9534

http://www.comasp.com
[email-masked]

---

From: Jon Callas <[email-masked]>
Date: Thu, 20 Jul 2000 21:52:45 -0700

In our last episode ("Correction reqd. in 5.2", shown on 7/21/00), Erron

>"A signature packet describes a binding between a private key and some data."

I disagree. A signature binds the public key and the data. Signature
verification is done with the public key only, and that is the whole point
of the exercise.

	Jon

---

From: Erron Criddle <[email-masked]>
Date: Fri, 21 Jul 2000 12:57:38 +0800

At 01:51 PM 21/07/2000 +0900, [email-masked] wrote:

>hi-
>
>From: Erron Criddle <[email-masked]>
>Subject: Correction reqd. in 5.2
>Date: Fri, 21 Jul 2000 12:02:10 +0800
>Message-ID: <[email-masked]>
>
>isn't the binding really between "the keypair" and "some data"?

I believe that would be a better description. It could read:

"A signature packet describes a binding between a public key pair and some 
data."

or thereabouts :)

Regards

Erron Criddle
Comasp Ltd.
Level 2, 45 Stirling Hwy
NEDLANDS  WA  6009
Australia

Fax: 08 9386 9473
Tel: 08 9386 9534

http://www.comasp.com
[email-masked]

---

From: Erron Criddle <[email-masked]>
Date: Fri, 21 Jul 2000 13:14:29 +0800

At 09:52 PM 20/07/2000 -0700, Jon Callas <[email-masked]> wrote:

<snip>

>I disagree. A signature binds the public key and the data.

Isn't the private key used as well to create the sig?

>  Signature verification is done with the public key only, and that is the 
> whole point
>of the exercise.
>
>         Jon

Agreed.

It should read key pair as the signature is bound to both the private and 
public keys.

Anyhow, you decide - I understood it, however someone else *may* get confused.

Regards

Erron Criddle
Comasp Ltd.
Level 2, 45 Stirling Hwy
NEDLANDS  WA  6009
Australia

Fax: 08 9386 9473
Tel: 08 9386 9534

http://www.comasp.com
[email-masked]

---

From: Bill Frantz <[email-masked]>
Date: Fri, 21 Jul 2000 00:33:04 -0700

>verification is done with the public key only, and that is the whole point

Well, really there are two bindings.  The signature binds the public key
and the data.  The public key and the private key are bound by their
mathematical relationship.

However, the real binding people are usually interested in is the binding
between the holder of the private key and the data.  The two bindings let
us get  between the private key and the data, but the next step is still
only conjecture.

-------------------------------------------------------------------------
Bill Frantz       | Microsoft Outlook, the     | Periwinkle -- Consulting
(408)356-8506     | hacker's path to your      | 16345 Englewood Ave.
[email-masked] | hard disk.                 | Los Gatos, CA 95032, USA