Subject: dash escaped text and cleartext sig. q

From: Erron Criddle <[email-masked]>
Date: Thu, 20 Jul 2000 15:10:14 +0800

To all,

Just to clarify:

If a cleartext signed message is sent to a recipient and the message body 
originally contained a "-" at the start of a line, would the recipient 
receive that same line prepended with a "- "?

I am asking this because I have just received a message that has been 
cleartext signed using GnuPG 1.0.1, however there are whole lines of "-" in 
them and they are not received as "- -------------------..."???

Does anyone know what is going on here or, once again, have I missed something?

TIA.

Regards

Erron Criddle
Comasp Ltd.
Level 2, 45 Stirling Hwy
NEDLANDS  WA  6009

Fax: 08 9386 9473
Tel: 08 9386 9534

http://www.comasp.com
[email-masked]

---

From: Erron Criddle <[email-masked]>
Date: Tue, 25 Jul 2000 15:45:52 +0800

Tom,

At 11:27 AM 20/07/2000 -0400, Tom Zerucha <[email-masked]> wrote:

>On Thu, Jul 20, 2000 at 03:10:14PM +0800, Erron Criddle wrote:
> > To all,
> >
> > Just to clarify:
> >
>My opgp will insert the extra dashes on any line beginning with a dash
>(and hash the thus escaped text).

I have just read 7.1, paragraph 2 and it states "...The message digest is 
computed using the cleartext itself, not the dash escaped form."

You say "(and hash the thus escaped text)", however they say different...

What way is the right way - to hash the dash escaped text or not?

Also, does the receiver of a dash-escaped email receive text as "- 
---------" or "---------"?

TIA.

Regards

Erron Criddle
Comasp Ltd.
Level 2, 45 Stirling Hwy
NEDLANDS  WA  6009
Australia

Fax: 08 9386 9473
Tel: 08 9386 9534

http://www.comasp.com
[email-masked]

---

From: Tom Zerucha <[email-masked]>
Date: Tue, 25 Jul 2000 12:44:09 -0400

> >(and hash the thus escaped text).

OOPS! I was wrong...

> computed using the cleartext itself, not the dash escaped form."

I should have looked at my code more carefully.  I insert a
dash/space, but I call my text line canonicalizer which strips it.

> ---------" or "---------"?

Good question..

I think they are supposed to receive:

- ------------

But my implementation doesn't do this, though it probably should